Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


I've already logged in but the Upload button does not appear

Explorer ,
Aug 06, 2021 Aug 06, 2021

Copy link to clipboard

Copied

I've been using Adobe Stock for years, but today, the Upload Button suddenly disappeared from the header menu, instead the "Login" link keeps staying there although i've logged in many times.

I can view my Contributor Page (my earnings etc) but i cant find anywhere to upload.

 

fannrei_0-1628251958379.png

 

TOPICS
Contributors

Views

37

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , Aug 06, 2021 Aug 06, 2021
I've deleted all the cookies and now it works.Thank you

Likes

Translate

Translate
Adobe Community Professional ,
Aug 06, 2021 Aug 06, 2021

Copy link to clipboard

Copied

Try this link: https://contributor.stock.adobe.com/uploads?upload=1

 

You may have a problem with your browser. Using a different one can help. Also disabling any pop-up  blockers, script blockers etc could help. You can also try browsing incognito. And you can try a different computer or a tablet, to see if the upload button appears.

ABAMBO | Hard- and Software Engineer | Photographer

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 06, 2021 Aug 06, 2021

Copy link to clipboard

Copied

Thank you.

 

The link keeps redirecting me to login page...

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 06, 2021 Aug 06, 2021

Copy link to clipboard

Copied

LATEST

I've deleted all the cookies and now it works.

Thank you

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines