Model Release Problem?

New Here ,
Dec 17, 2020 Dec 17, 2020

Copy link to clipboard

Copied

I searched but found nothing exactly like my issue so hope someone can help. I created a model release through the Adobe "create new" tab. It was successfully sent to the model. I received and signed the document when Adobe sent it to me, asking for the signature. I signed it the same as always (my signature liteally hasn't changed in 40 years). I submitted the file with the model release that was listed in my releases (I worked with this model over a year ago and verified that I did choose the correctly dated release and not the old one).

 

Today I see the photo is in my "Reminder" tab, saying it needs a model release. I can see that the correct model release IS already attached but in red it says to "replace any invalid model release with new documents that fulfill our requirements". I am at a loss. We both signed the release. I got the email stating it was all signed. It was in my list of releases in Adobe Stock at file submission (it's gone now, though, it seems, even though it's still listed as attached to the file), which is how I attached it. It was created by Adobe Stock and not me. Is there a way to find out or do any of you know what could have happened here?

TOPICS
General Feedback

Views

74

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 17, 2020 Dec 17, 2020

Copy link to clipboard

Copied

This is a user-to-user forum.  Suggest you reach out directly to Stock Contributor support from your contributor panel.

 

 

Nancy O'Shea, Adobe Product User & Community Professional
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 18, 2020 Dec 18, 2020

Copy link to clipboard

Copied

LATEST

The problem may be with your model realease that there is a problem with it. Please be sure that you followed exactly the requirements.

Especially: 

  • is there a witness who signed the form?
  • are all required items present, like dates, addresses, signatures?
  • are the three dates the same?

Please look into the documentation and check every bit against what you have: https://helpx.adobe.com/stock/contributor/help/model-release.html 

 

Best is probably to contact Contributor support with this: https://helpx.adobe.com/stock/contributor/help/Need-Help-Contact-Us.html. You may also post you model realease here, so that someone can look into this, but you absolutly need to edit out ALL private data. 

ABAMBO | Hard- and Software Engineer | Photographer

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines