Can't disable Safe Search in Microsoft Edge

Community Beginner ,
Dec 09, 2016 Dec 09, 2016

Copy link to clipboard

Copied

Hi everyone,

I think this may be a problem in a more recent iteration of Adobe Stock, but suddenly I can't disable Safe Search if I'm using Microsoft Edge (which is, for better or worse, my default browser).  I tried getting in through Firefox and I could disable safe search from there, but I'd really rather not change my default browser if I don't have to; I know where everything is.  Is anyone else having this problem with Edge?  Sigh... thanks again, Microsoft. 

Is there some sort of setting that needs to be activated within Edge's control panel for that button functionality to be available?  Disabling safe search worked fine not too long ago, but suddenly stopped working fairly recently, which is why I think it could be an issue with a newer version of the software/application/whatever Adobe Stock is.  Could it be yet another HTML5 functionality that Edge hasn't yet adopted?

Is there a way in Adobe Stock (or Creative Cloud) settings to just shut Safe Search off by default?  I have no qualms about seeing the occasional racy photo in a search; and it's entirely possible that an "unsafe" image would have elements I need to incorporate into my work, and any naughty bits I can simply cover up as necessary.  I'd prefer to have that option by default, rather than manually click off the Safe Search button every time.  My work environment is private, so there's no problem with "Not Safe For Work" imagery. 

All that aside, what I really need is the option to turn Safe Search off when I need to, which I cannot currently do on the browser I use.

Views

1.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Employee , Dec 09, 2016 Dec 09, 2016
Hi Rich,This has been reported to our engineering team. Thank you for bringing it to our attention. I understand you not wanting to change your default browser, however I do not have an ETA for the fix for this. I'll update this thread when I have more information.EBQ

Likes

Translate

Translate
Adobe Employee ,
Dec 09, 2016 Dec 09, 2016

Copy link to clipboard

Copied

Hi Rich,

This has been reported to our engineering team. Thank you for bringing it to our attention. I understand you not wanting to change your default browser, however I do not have an ETA for the fix for this. I'll update this thread when I have more information.

EBQ

EBQ

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 13, 2020 Apr 13, 2020

Copy link to clipboard

Copied

LATEST

I can't stop it either

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines