Locked

stock.adobe.com costing too much time

New Here ,
Mar 24, 2017 Mar 24, 2017

Copy link to clipboard

Copied

When all of the credits I had at other stock image sites were transferred over to the new Adobestock, I was actually excited. However the stock.adobe.com site never functions correctly and costs us a lot of time trying to navigate to locate images.

The website will conduct a search and after the results show up, the page will lock up. You cannot scroll down, or click on an image.

Sometimes it functions relatively fine. Just clunky. Long wait times for items to load up and inspect on their individual stock pages.

But as I am sitting here watching my designers, I am noticing a lot of wasted time as their searches lead to crashed pages.

Does anybody else have issues with the functionality of the adobestock site?   or is it just us?

Views

1.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Employee , Mar 24, 2017 Mar 24, 2017
Hi Bluetaildesign, Sorry about your experience. Please try clearing the cookies/cache or using a different browser. Hope this helps!Feel free to update the thread for any other query.

Likes

Translate

Translate
Adobe Employee ,
Mar 24, 2017 Mar 24, 2017

Copy link to clipboard

Copied

Hi Bluetaildesign,

Sorry about your experience.

Please try clearing the cookies/cache or using a different browser.

Hope this helps!

Feel free to update the thread for any other query.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 19, 2018 Dec 19, 2018

Copy link to clipboard

Copied

Same thing happening for me, it seems to go through cycles and CLEARING cookies/cache is not the FIX!  I repeat I have done this countless times and the problem just comes back!  I've been dealing with the issue for way too long now and I'm done, hopefully, Adobe can figure this one out, but I don't think it will be anytime soon!

I've been using Chrome & Safari and it doesn't matter, the same issue keeps recurring, stock.adobe.com locks up and you cannot use it, making the objective of the entire site completely useless!

I'm speaking with my boss, and we're probably switching to another stock image site, this is just becoming a huge waste of time!

Good Luck!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 19, 2018 Dec 19, 2018

Copy link to clipboard

Copied

you did also try on a different network?

Regards, Abambo
Hard- and Software Engineer and Photographer.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 19, 2018 Dec 19, 2018

Copy link to clipboard

Copied

Yes, from home, from work, it's not a network issue.

Just out of curiosity, what about the network could possibly be causing this one site to crash and not any others?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Dec 19, 2018 Dec 19, 2018

Copy link to clipboard

Copied

Please review Re: Adobe Stock slow and unresposive  - there are several troubleshooting tips there.

EBQ

EBQ

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 20, 2018 Dec 20, 2018

Copy link to clipboard

Copied

Office networks may tend to be quite closed. Therefor when I have a network problem (slow responses, no connection, connection errors) I always test first in a more open environment, where the company's proxy and firewall and other protection systems do not interfere.

Regards, Abambo
Hard- and Software Engineer and Photographer.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 20, 2018 Dec 20, 2018

Copy link to clipboard

Copied

Hi Abambo -

So, you're saying that the AdobeStock site might all of the sudden be lagging due to my office network traffic, but only this particular site?  My issue is that it's only happening when I'm on the AdobeStock site, every other site runs perfectly normal, plus the issue is not only happening on my office network it's now been 3 different places.  So, I'm still very unclear about this being a network issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 20, 2018 Dec 20, 2018

Copy link to clipboard

Copied

savagequest  wrote

Hi Abambo -

So, you're saying that the AdobeStock site might all of the sudden be lagging due to my office network traffic, but only this particular site?  My issue is that it's only happening when I'm on the AdobeStock site, every other site runs perfectly normal, plus the issue is not only happening on my office network it's now been 3 different places.  So, I'm still very unclear about this being a network issue.

  1. Other users do not have that problem, so it needs to be in relation with your infrastructure. It does not need especially be in relation with your office network. But my experience with my office network let's me check the problem on a different network each time I have a problem.
  2. I'm also testing each time different computers. Even if my IT tells me that there is no difference between 2 computers, I know that sometimes differences exist that are not captured by IT. There may be subtle differences with big impact.
  3. I also test with different user profiles on the same and different machines as this sometimes resolves the problem.
  4. You need to run tests on a clean machine with no add ons and minimal security just to be sure that not somewhere something breaks you out.

There is always the possibility that there is a breakage with the Adobe network, but I would doubt the Adobe network  as a kind of last resort. If the problem lies with Adobe, there will be masses of users complaining, not only a few. Even if you find a lot of complaints here, look at the time of the posting. And keep in mind that users with no problems do not post here to complain that they have no problems. But the Adobe user base is quite huge, even for services and programs that are not used that much from the Adobe point of view.

This said, when you have problems, all suggestions here may be of help to get a solution. Don't rule out a given solution until you have tested that one without the hoped result.

Regards, Abambo
Hard- and Software Engineer and Photographer.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 20, 2018 Dec 20, 2018

Copy link to clipboard

Copied

Thanks for the insight! Sounds like you do a lot of testing, unfortunately for me I don’t have that option or the time. I’m testing the LastPass help suggestion, so, we’ll see what works.

1. My IT department does not allow this type of on/off one/two different network testing. If they did, they are. It offering.

2. I don’t have several computers to test from, so, I’m stuck with the one computer and when things go wrong I seriously don’t have hours to find another computer and test all kinds of different scenarios.

3. It’s just me, myself and I that use AdobeStock, and I’m pretty much the only one in the office with the same Mac setup so different profiles on my machine or other machines or other uses - simply does not exist for me.

4. As previously started, I have one machine and no time to get my hands on a “Clean Machine” nor do I have the time to wipe my current machine and test everything that was working just fine 2 days ago.

Thanks for the assistance, I wish my project load and my company allowed me to spend the money and time to do all this testing, however, we are too busy!

Thanks!

Thank you,

Mark Savage

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 23, 2019 Jan 23, 2019

Copy link to clipboard

Copied

LATEST

Hello,

We've pushed a fix for this issue to production, please sign out of the Adobe Stock website, clear your browser history and sign back into the site. Let us know if you experience any issues.

EBQ

EBQ

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 20, 2018 Dec 20, 2018

Copy link to clipboard

Copied

Do any of the people having trouble with this also use a password manager and browser plug in, like LastPass?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 20, 2018 Dec 20, 2018

Copy link to clipboard

Copied

Yes, I use LastPass, but I will disable it today and test out this theory, Thanks for the update!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 20, 2018 Dec 20, 2018

Copy link to clipboard

Copied

It is Lastpass. Take it from me. When you use a private window in your browers (incognito mode in Chrome) all issues go away!

I informed Lastpass about it. Will post when I get their reply.

Happy Holidays!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jan 04, 2019 Jan 04, 2019

Copy link to clipboard

Copied

I've been using the site now in Chrome with LastPass disabled and still have major lag.

I was really hoping this was the solution but looks like I just have to use 2 different browsers for the time being until the Chrome issues are corrected. I have too many work-related reasons and must stay on Chrome to be most efficient with certain tasks, so I cannot afford to leave Chrome at this point, this is very frustrating and disappointing to think that the answer is to switch browsers - today that's not something that is very easily done!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 04, 2019 Jan 04, 2019

Copy link to clipboard

Copied

sorry mark, but I’m working with 3 browsers in parallel. So it’s easily done.

Regards, Abambo
Hard- and Software Engineer and Photographer.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines