Why are the watermarks not going away when I license something in Adobe Stock?

New Here ,
Mar 09, 2018 Mar 09, 2018

Copy link to clipboard

Copied

I have licensed several images and saved to my library, and it shows that they are licensed, but no matter what the watermark will not go away. Does anyone have any idea why this would be happening?

Views

117

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Employee , Mar 23, 2018 Mar 23, 2018
Hi there,Please Contact Customer Care for more troubleshooting.Regards,Sheena

Likes

Translate

Translate
LEGEND ,
Mar 09, 2018 Mar 09, 2018

Copy link to clipboard

Copied

How are you opening/downloading your files? Sounds like you are downloading the lo-res preview image.

List the steps you are taking to download/use your images.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 23, 2018 Mar 23, 2018

Copy link to clipboard

Copied

LATEST

Hi there,

Please Contact Customer Care for more troubleshooting.

Regards,

Sheena

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines