• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Designer doesn't save selected shader

Participant ,
Mar 06, 2024 Mar 06, 2024

Copy link to clipboard

Copied

Every time I close Designer, the chosen shader switches back to Adobe Standard Material. So, each time, I have to go back, set the shader to metallic roughness, and, on top of that, I have to re-enter the specific parameters I wanted for this shader.

 

In my 3D view I have a cube, although I had a plane (hi res).

Why is this happening?

Why doesn't Designer keep my settings?

Bug Unresolved
TOPICS
Bugs & Crashes

Views

55

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
4 Comments
Participant ,
Mar 06, 2024 Mar 06, 2024

Copy link to clipboard

Copied

It seems this happens when I switch between subgraphs, I don't have to exit Designer.

So I'm working on a subgraph, I go back to my main subgraph and everything goes back to default settings.

Votes

Translate

Translate

Report

Report
Community Expert ,
Mar 07, 2024 Mar 07, 2024

Copy link to clipboard

Copied

Have you tried setting an alternative default in Preferences > Projects > 3D View > Default Shader  ?

 

Dave

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Mar 07, 2024 Mar 07, 2024

Copy link to clipboard

Copied

Hello @RoxanaMD,

 

This is because modifications you made haven't been saved as new Default 3D view. As Dave mentioned, you can check in 

Preferences > Projects > 3D View > Default Shader

to manually select a new one, or you can click on

3D view > Scene > Set Current scene as Default.

Which will set the current scene as the default one.


Regards,

Cyril Dellenbach (Micro) | QA Support Artist | Adobe

Votes

Translate

Translate

Report

Report
Participant ,
Mar 08, 2024 Mar 08, 2024

Copy link to clipboard

Copied

LATEST

I followed your instructions, and now every project opens with that shader, containing all the maps from the base material I created. However, this isn't what I intended.

 

Let me make sure I understand: I'm working in two different subgraphs. When I switch back to the first subgraph, the scale and tessellation settings for the shader are reset, and the plane becomes flat. This forces me to readjust these settings every time I go back, which seems unusual given the frequent back-and-forth while working.

Your suggested solution was to set that shader as the default. I did that, and now in the 3D view, I see the base material from when I set the metallic roughness shader as default. However, I only wanted to have that shader for this specific project. Am I missing something?

 

 

2024-03-08_12-11.png

Votes

Translate

Translate

Report

Report