Boolean parameter presets are not reflected.

New Here ,
Mar 21, 2022 Mar 21, 2022

Copy link to clipboard

Copied

When a preset is added from a file, the boolean parameters are not reflected. Other parameters are reflected correctly.
The preset file is opened in a text editor, the boolean parameters are saved correctly.

Version is 11.3.3.Thanks.

TOPICS
Bugs & Crashes , How to

Views

59

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Mar 29, 2022 Mar 29, 2022
Hello @mmplus, Thank you for providing these very helpful additional details! This let me assess the problem more accurately. There is indeed a known bug where using the Add presets from file option in the drop down menu button next to the preset selection combobox would result in preset values not being applied as expected in some cases. We are tracking this issue and plan to fix it for this summer's release. I appreciate your patience in the meantime! Best regards.

Likes

Translate

Translate
Adobe Employee ,
Mar 28, 2022 Mar 28, 2022

Copy link to clipboard

Copied

Hello,

 

Thank you for reporting this issue. The issue did not occur on my side in version 11.3.3 during my testing.

 

It is possible the boolean parameter if your project file is controlling a parameter which cannot be dynamic – i.e., cannot be changed at runtime. See this Limitations section in the Exposing a Parameter page of Designer's documentation to learn more.

Feel free to share more details regarding how the boolean parameter is used in the graph so I can confirm this hypothesis.

 

Best regards.

 

Luca Giarrizzo
QA Analyst
Substance 3D Designer

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 28, 2022 Mar 28, 2022

Copy link to clipboard

Copied

Thanks for answering.

It is very simple: two "Uniform Colors" are switched by a "Switch Color" boolean.
If I export these colors and the boolean to a preset file and then load the preset with "Add Preset From File", only the boolean is not reflected.
The result is the same whether the default parameter is False or True.
If you look at the image, you will see that only the booleans are not reflected.
Thanks.sample.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 29, 2022 Mar 29, 2022

Copy link to clipboard

Copied

LATEST

Hello @mmplus,

 

Thank you for providing these very helpful additional details! This let me assess the problem more accurately.

 

There is indeed a known bug where using the Add presets from file option in the drop down menu button next to the preset selection combobox would result in preset values not being applied as expected in some cases.

 

We are tracking this issue and plan to fix it for this summer's release. I appreciate your patience in the meantime!

 

Best regards.

 

Luca Giarrizzo
QA Analyst
Substance 3D Designer

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines