Changing MDL version

Community Beginner ,
Mar 24, 2022 Mar 24, 2022

Copy link to clipboard

Copied

Hi everyone,

 

I'm working on a proof of concept with MDL graphs. Currently, substance exports MDL graphs in MDL version 1.5. Vray only supports MDL version 1.4.3. 
Is there a way to set substance MDL graphs to an older version? As to not have compatibility issues. 

Thanks

TOPICS
How to , Import & Export , MDL Graph

Views

118

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Adobe Employee , Mar 28, 2022 Mar 28, 2022

Hello,

 

The MDL version present in Designer is defined by the version of the Iray SDK, as that kit includes both the MDL and Iray librairies.

As such, it is not possible to change the MDL version, and there are no compatibility options available on export. Thank you for your patience regarding this limitation.

 

Best regards.

 

Likes

Translate

Translate
Adobe Employee , Mar 29, 2022 Mar 29, 2022

Hello @jens_ha,

 

As the MDL version is linked to the Iray SDK, this cannot be changed in Designer. I will bring up the topic of compatibility options with the team, although we would need to check if that is supported by the SDK in the first place.

 

The most recent version of Designer which uses version 1.4.x of the MDL specification is 9.1.3 (2019.1.3, build 2520).

 

Best regards.

 

Likes

Translate

Translate
Adobe Employee ,
Mar 28, 2022 Mar 28, 2022

Copy link to clipboard

Copied

Hello,

 

The MDL version present in Designer is defined by the version of the Iray SDK, as that kit includes both the MDL and Iray librairies.

As such, it is not possible to change the MDL version, and there are no compatibility options available on export. Thank you for your patience regarding this limitation.

 

Best regards.

 

Luca Giarrizzo | QA Analyst, 3D & Immersive | Adobe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 28, 2022 Mar 28, 2022

Copy link to clipboard

Copied

Hi luca,

 

Could i change the SDK used in substance?

If not, is compatibility options something for the future?

 

And which version of substance still uses the MDL 1.4.3 version of the SDK?

 

Thanks

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 29, 2022 Mar 29, 2022

Copy link to clipboard

Copied

Hello @jens_ha,

 

As the MDL version is linked to the Iray SDK, this cannot be changed in Designer. I will bring up the topic of compatibility options with the team, although we would need to check if that is supported by the SDK in the first place.

 

The most recent version of Designer which uses version 1.4.x of the MDL specification is 9.1.3 (2019.1.3, build 2520).

 

Best regards.

 

Luca Giarrizzo | QA Analyst, 3D & Immersive | Adobe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 29, 2022 Mar 29, 2022

Copy link to clipboard

Copied

Hi @Luca Giarrizzo 

Where can I find that version? The oldest version I can download in CC is 10.2.2

 

Cheers

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 30, 2022 Mar 30, 2022

Copy link to clipboard

Copied

Hello,

 

Indeed, the first version we released in Creative Cloud was 10.2.2, back when we launched an early Enterprise offering.
Version 9.1.3 is only available for Substance (i.e., Legacy) and Steam editions. I will get in touch with our customer support team to see to what extent we can help, considering your current license.

 

Best regards.

 

Luca Giarrizzo | QA Analyst, 3D & Immersive | Adobe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 31, 2022 Mar 31, 2022

Copy link to clipboard

Copied

LATEST

Hello @jens_ha,

 

Thank you for your patience. I have some news about the matters discussed in this thread:

 

The 9.1.3 version was released exclusively under Allegorithmic's legacy license, which is no longer available to the public. If you have an existing legacy perpetual license, you may access and download older versions through your Substance3d.com account.

Unfortunately, if you do not have such a license then we are unable to provide access to versions lower than 10.2.2.

 

Regarding compatibility options for exporting MDL modules, the engineer with adequate knowledge of the Iray SDK for assessing this is currently on leave for some months. We are unable to commit to anything related to it at this time.

 

I understand none of these answers are what you were hoping for, and I appreciate your understanding.

 

Best regards.

 

Luca Giarrizzo | QA Analyst, 3D & Immersive | Adobe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines