• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Multi Switch Expose

Community Beginner ,
Jul 28, 2023 Jul 28, 2023

Copy link to clipboard

Copied

Hi,

I am trying to do something very simple. I have 3 logos (imported them )  and trying to expose the parameters so i can switch them in CLO3d. Attached an image of the issue. When i bring the sbsar file , it appears as white, the expose parameters are there but it doesnt work. I also tried to expose the input number but didint work either.. Any idea where i am doing wrong? 

Thank you

 

TOPICS
How to

Views

177

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 29, 2023 Jul 29, 2023

Copy link to clipboard

Copied

I can't see anything wrong in your screenshots. Can you share the SBS file (replace the logos with another image if they are confidential)

 

Dave

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 29, 2023 Jul 29, 2023

Copy link to clipboard

Copied

Hi Dave @davescm 

Thank you for the reply. Attached the sbs file.. They were tiff and  i switched to jpg to see if it will make any difference but it still didint work 😕 it works in Designer but when i publish as sbsar  the paremeters are there but its all white and it doesnt work

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 29, 2023 Jul 29, 2023

Copy link to clipboard

Copied

Hi

Thanks for sharing the SBS. It gave an warning error when I opened it as I did not have the associated resources file, but I substituted 3 bitmaps of my own and published to SBSAR. That worked correctlyand embedded those bitmaps within the SBSAR and on using teh sbsar I could switch between the images using your exposed parameters. So there is nothing wrong with the graph build or parameters as such.

The white you describe would indicate that for some reason your bitmaps are not being correctly embedded within the SBSAR file on publishing.

If you can send the associated resources file, I can try with your images rather than mine.

 

Dave

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 29, 2023 Jul 29, 2023

Copy link to clipboard

Copied

Hi Dave @davescm 

Attached the images. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 30, 2023 Jul 30, 2023

Copy link to clipboard

Copied

I opened your original SBS file and repointed each bitmap node to the three jpegs you attached in your last post.

2023-07-30_11-07-46.jpg

I  saved the file as Logo Switch Test Rebuilt

I then published it as sbsar (settings below)

2023-07-30_11-09-50.jpg

Using that sbsar in a new graph looks like this and gives access to the three images

2023-07-30_11-12-21.jpg

 

Dave

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 30, 2023 Jul 30, 2023

Copy link to clipboard

Copied

Thank you @davescm  I checked your sbsar file in CLO3d , parameters are there but it is still in white.. why do you think the bitmaps still  not embedded? 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 30, 2023 Jul 30, 2023

Copy link to clipboard

Copied

The bitmaps are embedded within the sbsar.  I don't use CLO3D so can't comment on that software or its requirements.

 

To use it with the Blender 3D add in, I had to specify an output use for the output node and republish.

Here I used baseColor

2023-07-30_21-30-30.jpg

 

Dave

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 30, 2023 Jul 30, 2023

Copy link to clipboard

Copied

@davescm  SBSAR works in CLO, I used many other ones but this one for some reason doesnt. May be multi swicth doesnt work in CLO?  So, hope someone would comment who knows CLO requierements as well. Thanks!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 30, 2023 Jul 30, 2023

Copy link to clipboard

Copied

Did you try setting the output usage as shown in my last post?

Dave

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 31, 2023 Jul 31, 2023

Copy link to clipboard

Copied

@davescm Yes! i did, but it still doesnt work 😕

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 31, 2023 Jul 31, 2023

Copy link to clipboard

Copied

LATEST

Ok. Given that it works in Blender and in Painter, we'll have to wait for someone with experience of CLO3D to comment.

 

Dave

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines