What does "Computation result is empty" mean in the modeling graph

New Here ,
Jun 14, 2022 Jun 14, 2022

Copy link to clipboard

Copied

So I'm trying to learn how to model in the modeling graph of designer. And I keep on running into an issue that I can't find a resolution for in the documentation and I am bit confused as to how to fix it. This seems to happen a lot with curves and I'm sure it's something silly that I'm missing but it's been with the extrude curve note and the parametric curve node. I would appreciate any assistance thank you in advance.

TOPICS
General , How to , Substance Model Graph

Views

40

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 15, 2022 Jun 15, 2022

Copy link to clipboard

Copied

This error means that there was an error with the inputs or with some parameters, and so the result has not been computed.
For example, in the Curve Extrude node, if the input curve is not closed, the extrusion can not be computed, and you have this error. 
You can check the documentation of a node to see what are the requirements concernings the inputs, how to use parameters, etc. For example, here is the doc of the Curve Extrude node: https://substance3d.adobe.com/documentation/sddoc/extrude-curve-215286497.html


Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 15, 2022 Jun 15, 2022

Copy link to clipboard

Copied

LATEST

Thank you for the reply @Nicolas3D , so the extrude make sense it wasn't a closed curve. But, I am stuck on the Isoparametric curve node is still a mystery to me. In the documentation it asks for "The input Scene holding the SubD meshes which Curves should be extracted from." this makes me believe that we need edge loops to steal from the surface, meaning multiple divisions between the two caps or supporting edges from the top and bottom. But no matter what type of mesh I put in I seem to keep on running the same error, I have tried using closed and open topology and the result is still the same. Even if I generated instead of Maya.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines