• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Painter will not properly import my substance designer .sbsar file.

Community Beginner ,
Mar 12, 2024 Mar 12, 2024

Copy link to clipboard

Copied

Every time I try to import my material I get this error: 

 

"[EngineProcedural] Failed to decode Substance.
resource://session/Hair_Vector_Map/Hair_Vector_Map?version=688a4474f58c00e71c8d0b5f0ce3052f0f6e7806.sbsar"

 

What am I doing wrong here that it wont work properly?

Bug Unresolved
TOPICS
Bugs & Crashes , Import & Export

Views

121

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
5 Comments
Community Beginner ,
Mar 12, 2024 Mar 12, 2024

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Mar 12, 2024 Mar 12, 2024

Copy link to clipboard

Copied

Hello @Kelsey36024474018z,

 

Thanks for the message.

 

What's your Painter's version? Depending on resources used in the graph, the .SBSAR file cannot be loaded in an old Substance Painter's update.

 

As instance, you cannot load a .SBSAR with splines, if the Painter's version is prior to 9.0 (where we introduced Path tool).

 

Let me know.

Cyril Dellenbach (Micro) | QA Support Artist | Adobe

Votes

Translate

Translate

Report

Report
Community Beginner ,
Mar 12, 2024 Mar 12, 2024

Copy link to clipboard

Copied

My painter version is 8.3.1

 

All of the generators in my designer file include splines... So do I have to repurchase a software I already own just to stop this bug?

Uncool of the company. But thank you for your help sir.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Mar 13, 2024 Mar 13, 2024

Copy link to clipboard

Copied

Unfortunately, that isn't really a bug. When we add new features, we have to update the Substance Engine. Older engines are just not capable of reading files with features from our newest Engine.

 

I agree this is bothering, but we can't really do differently. Here's the list of all application updates and the Engine version related to it. That being said, this list doesn't indicate which node isn't compatible with previous engine versions, but that's a start.

 

To give a straight answer to your question, if you need to read Splines in Substance Painter; yes you need a newer version of the application. That's how it always worked, but we have to update the engine to add features.

 

Regards,

Cyril Dellenbach (Micro) | QA Support Artist | Adobe

Votes

Translate

Translate

Report

Report
Community Beginner ,
Mar 13, 2024 Mar 13, 2024

Copy link to clipboard

Copied

LATEST

I ended up buying the painter 2024 version. The path tool and the newer materials/brushes are really nice. It's just frustrating as a consumer because I had to pay 200 dollars again for changes that appear relatively minimal on the surface. But I'm not a programmer so I have no idea what might be going on under the hood of the engine. I apologize if I came off badly through my frustration, your explanation for what was up ended helping me a lot. Thank you again. 

Votes

Translate

Translate

Report

Report
Resources