• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
5

BUG: Layer blending mode appears on another monitor.

New Here ,
Oct 11, 2021 Oct 11, 2021

Copy link to clipboard

Copied

Just as the title says: the blending mode of a layer appears on another monitor on Windows 10 and Windows 11. 

Screenshot_1 copy.png

Its been years since this bug was reported and it was never fixed.

TOPICS
Bugs & Crashes

Views

642

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 04, 2023 May 04, 2023

Copy link to clipboard

Copied

Have updated to latest version and I still get same bug. When trying to open blending mode menu it always appears on the primary monitor and not the one I am currently working on. This is extremely frustrating when working on display tablet. Is there any workaround or am I missing something?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 05, 2023 May 05, 2023

Copy link to clipboard

Copied

I can't replicate that here on Windows 11 using v8.3.1 and two displays both connected to an NVidia RTX3090 GPU card.

 

I tried :

Substance Painter Window maximised on monitor 1

Substance Painter Window maximised on monitor 2

Substance Painter floating in monitor 1

Substance Painter floating in monitor 2

Substance Painter floating between the two monitors.

 

In all cases the Layer blending mode opened inside the Substance Window.

 

Have you tried menu Window > Reset UI ?

 

Dave

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 05, 2023 May 05, 2023

Copy link to clipboard

Copied

Hi Dave,

 

Thank you for your response.

 

No, the Window > Reset UI did not fix it for me.

 

Here are my specs:

Operating System: Windows 10
Graphics Card: NVIDIA GeForce RTX 2060
Setup: Laptop with one monitor and one display tablet connected (as shown in screenshot)
Substance Painter version: 8.3.1
Display Tablet: Huion KAMVAS 13 GS1331

 

My screen setup is shown below:

Monitor 1: Laptop screen
Monitor 3: Other monitor
Monitor 2: Display tablet

 

setup_screenshot.png

 

As shown in the screenshot above the Blending mode menu does not appear inside my display tablet. Even after reseting the UI or reopening the program.

 

I tried to change my main display to be the display tablet instead of my laptop but it did not fix it either.

 

The only way I managed to bring the menu to open inside of my display tablet with this setup was to disable the other 2 monitors.

 

When I enabled them, it kept appearing on my laptop screen.

 

After performing a few tests I noticed that the only way to bring it to open inside the display tablet was to change the screen setup as shown below

 

screen_setup_02.PNG

 

However now the blending mode menu will appear on my display tablet when I open the program on my laptop screen as shown below

screen_setup_02_test.png

Not sure why this is happening but it seems to me like an issue with multi monitor setups.

 

Any further assistance would be appreciated.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 08, 2023 May 08, 2023

Copy link to clipboard

Copied

Hello @konstantina22965736si7m,

 

Thanks for the message and all the details (always helps troubleshooting).

 

Considering your message, we are running a few tests on our side. In the meantime, I'd love to know which version of Substance 3D Painter do you have.

 

Keep me updated.

Cyril Dellenbach (Micro) | QA Support Artist | Adobe

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 08, 2023 May 08, 2023

Copy link to clipboard

Copied

Hi Cyril,

As mentioned in the previous post my version is as follows:

Substance Painter version: 8.3.1

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 10, 2023 May 10, 2023

Copy link to clipboard

Copied

Hi again @konstantina22965736si7m,

 

So after a discussion with the team, it seems the issue comes from the tool we are using to setup the UI and unfortunately, there's not much we can do to avoid the problem.

 

With that being said, there's a workaround that helps for most of the users with the issue: Try to move the Layers window and check if the popup blending mode comes back to place.

 

LayerWindow.gif

 

Keep me posted.

 

Cyril Dellenbach (Micro) | QA Support Artist | Adobe

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 12, 2023 May 12, 2023

Copy link to clipboard

Copied

Hello @Cyril Dellenbach,

 

Moving the Layers window did not fix it.

I tried to change the display tablet Scale from 150% (which was set by default as recommended) down to 125% as shown below.

konstantina22965736si7m_0-1683900179685.png

 

Now when I open the Blending Mode window of the top layer in the Layers stack it opens correctly but for all the others below it it keeps opening on another monitor. It is like the menu opens always below the cursor and if there is not much space it gets pushed to another monitor.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 16, 2023 Nov 16, 2023

Copy link to clipboard

Copied

This is happening to me as well, did you ever find a solution?

I'm on version 9.1.0 build 2983

Windows 10 on a wacom cintiq 22hd

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 18, 2024 Mar 18, 2024

Copy link to clipboard

Copied

Version 9.1.2
Windows 11
Huion Kamvas Pro 24

Getting the same thing happening.  It's absolutely maddening when there's a lot of layer, paint, and fill blending to deal with.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 27, 2024 Apr 27, 2024

Copy link to clipboard

Copied

I did recently find a work around that works where you can keep your display size
first off you have the default UI

Auzzie36740318k04r_0-1714286087033.png

this is what you need to do to get it to stick to the screen you are using. you will need to drag the layers above the texture set list

Auzzie36740318k04r_1-1714286177895.png

Then you will have the drop down on the same screen

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 01, 2024 May 01, 2024

Copy link to clipboard

Copied

Can we have any support on this, this has been a huge issue during production. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 01, 2024 May 01, 2024

Copy link to clipboard

Copied

LATEST

This bug seems to be arround. It has caused massive headaches during our production. Can anyone of the staff activelly work on this? 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources