• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Can't apply a generator to a mask

New Here ,
Oct 19, 2021 Oct 19, 2021

Copy link to clipboard

Copied

I've got a layer group, I added a black mask, I added a generator layer to the mask, and Painter will not let me add a generator to the empty generator layer. I click the Generator button, get the mini shelf, I select a generator, and the generator layer remains empty. No matter what generator I pick, none will actually take.

I've got baked mesh maps that all look good. I really need to find out what's going on here.

TOPICS
Bugs & Crashes

Views

2.7K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Apr 14, 2023 Apr 14, 2023

Hi @Vincent29312308ac63,

 

Thanks for the visual and the precision, it's always very helpful to troubleshoot.

 

For your specific case, it's due to the fact that the concrete edge 2 isn't a generator, but a smart mask. I admit it, this is kind of confusing, because the smart masks have the same icon as the generators, but they aren't the same thing. In fact, you can even see a warning in your log.

 

Warning log.png

 

If you want to only display the generators in the mini shelf, you can add the text u:generator

...

Votes

Translate

Translate
Adobe Employee ,
Oct 20, 2021 Oct 20, 2021

Copy link to clipboard

Copied

Hi, 

Could you share screenshots and a log as well? This would help us pinpoint the source of your issue more accurately.

Thank you,

Kind Regards,

Geoffroy SC

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 21, 2022 Mar 21, 2022

Copy link to clipboard

Copied

I'm having this same problem. Was a solution ever found?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 18, 2022 Oct 18, 2022

Copy link to clipboard

Copied

same! I need helps D:

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 18, 2022 Oct 18, 2022

Copy link to clipboard

Copied

Could you share screenshots and logs of your issues? Troubleshooting without information isn't possible! 

Kind Regards,

Geoffroy SC

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 13, 2023 Apr 13, 2023

Copy link to clipboard

Copied

Here is an example:

I click on the "concrete edges 2" but it does not get applied to my generator. The generator slot stays empty. 

Strangely if I search for another generator like "curvature". I can apply that.

 

But for some reason clicking on "concrete edges 2" or any of the other edge generators does nothing. Is there some additional criteria needed to apply this generator? It gives no error message or warning. Just closes the window and does nothing

 

Vincent29312308ac63_1-1681427656450.png

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 14, 2023 Apr 14, 2023

Copy link to clipboard

Copied

LATEST

Hi @Vincent29312308ac63,

 

Thanks for the visual and the precision, it's always very helpful to troubleshoot.

 

For your specific case, it's due to the fact that the concrete edge 2 isn't a generator, but a smart mask. I admit it, this is kind of confusing, because the smart masks have the same icon as the generators, but they aren't the same thing. In fact, you can even see a warning in your log.

 

Warning log.png

 

If you want to only display the generators in the mini shelf, you can add the text u:generator before your search. And if you want to add a smart mask to your layer, you can drag and drop it from the library.

 

 

Best regards,

 

Cyril Dellenbach (Micro) | QA Support Artist | Adobe

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources