• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Edge wear/curvature map not working on mesh after baking

New Here ,
Jan 07, 2022 Jan 07, 2022

Copy link to clipboard

Copied

Hey there! I'm working on a new model, but I'm having issues with edge wear in Substance Painter. For some reason after baking all my texture maps, curvature just doesn't seem to work. When baking, the preview for curvature is entirely black, and when I view the mesh map in the 3D viewport the edges are very faint. The only way I've been able to get edge wear to work on this model is by using the deprecated "Generate from Normals" option in the curvature baker settings, but this results in a jagged and overall poor-quality map even with max antialiasing.

 

I've never had this issue before and I've spent hours now trying to find a solution, but nothing works. I've even sent the model to a friend to try on his end in substance, and he hasn't been getting any edge wear either. No matter what smart material or mask I apply I can't seem to get it to work. 

 

Distanced_0-1641598373697.png

I've applied the smart material "Steel Painted Stained" here, as you can see there's no edge wear.

 

Distanced_1-1641598475278.png

Same pov, viewing the curvature map. It's just completely gray in this case

 

I'm going to attach the .FBX of my model to this post, if someone can figure out what the hell is going on with this thing I'd be eternally grateful. But be careful, cause I have a feeling that this model is cursed lol

TOPICS
Baking

Views

1.8K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 11, 2022 Jan 11, 2022

Copy link to clipboard

Copied

Hi

By taking your model, setting the bake output size to 2048 x 2048 and then in curvature settings turning off Auto tonemapping and using Tonemapping min -0.1 and Max 0.1 I got this curvature map. That should work with the smart material

2022-01-11_15-01-46.jpg

2022-01-11_15-03-44.jpg

 

Dave

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 11, 2022 Jan 11, 2022

Copy link to clipboard

Copied

LATEST

Awesome, I'll take a look! Thank you so much!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources