• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Problems with UVs misaligning between Painter and Blender (UDIM workflow)

New Here ,
Sep 25, 2022 Sep 25, 2022

Copy link to clipboard

Copied

Hi there,

I'm new to Substance Painter and I am having an issue where my UVs are changing between Painter and Blender - it appears Painter is changing them but I can't see where or why.

 

I unwrapped my model in Blender using a UDIM workflow, and then exported that as an fbx. In Painter the mesh appears correctly and is texturing fine. 

 

f0b42c63a84b04dd20f57937274847c558ccacd9_2_690x401.jpeg57f683b2fc40b3f09d8d7db73b04627ad6f35f44_2_690x421.jpeg

 

But it appears to have changed the UV map, because when I export those textures (or even the mesh itself) and open them in Blender, they no longer align:

 

935de637b9590f6e3c2581cbc5a481f9850fc246_2_690x409.jpegb3cbc3c0eab3daea1ba5786f971f81805aea9a7e_2_574x500.jpeg

Should I be importing / exporting the mesh differently to preserve UV maps? Should I be using .obj instead of fbx and if so how can I change this without losing the work I've done? Or is there a way to export the new maps that I could then update my mesh with? (noting that when I export mesh from Painter it seems to keep the original UV maps and so is still misaligned.)

 

Please help! I've been trying to figure this out for a week now and I am completely lost.

TOPICS
Automatic UV unwrapping , Import & Export , UV Tiles

Views

53

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 26, 2022 Sep 26, 2022

Copy link to clipboard

Copied

When you import to Substance Painter, ensure 'Auto-Unwrap' is unchecked. Also if using UDIMs ensure 'Use UV Tile Workflow' is checked. Both are in New Project settings

 

Dave

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 26, 2022 Sep 26, 2022

Copy link to clipboard

Copied

Thanks Dave, auto unwrap was unchecked and I am using UV tile workflow, I also tried reimporting the mesh through the project configuration window with preserve stroke positions on mesh but got the same result. I just tried the whole process again with new files and I am getting the same problem - including applying modifiers beforehand and not, a new UV layout (same issues) and tried with fbx and obj files, same result. It's devastating because I've already spent so much time on this project and paid for substance painter just for this project! I just can't even figure out where the problem lies.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 27, 2022 Sep 27, 2022

Copy link to clipboard

Copied

LATEST

Can you post the Blender file (or a link to it) and I'll try it here. You can PM me if you prefer

 

Dave

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources