• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Setting colorspace on export

New Here ,
Dec 21, 2021 Dec 21, 2021

Copy link to clipboard

Copied

I have ACES enabled. But when I export my textures, only the Glow channel is converted to ACEScg, not the other color channels (diffuse and facecolor).

Any ideas where I can change this setting in the template?

TOPICS
Color Management

Views

157

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 21, 2021 Dec 21, 2021

Copy link to clipboard

Copied

Forgot the screenshots

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 13, 2022 Jan 13, 2022

Copy link to clipboard

Copied

How is you custom export preset/template configured ?

 

The Raw "color space" is assigned to User channel which are not color managed and other data channel (like roughness, metallic, etc). Only specific channels are color managed, as listed here: https://substance3d.adobe.com/documentation/spdoc/color-management-223053233.html#section5

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 13, 2022 Jan 13, 2022

Copy link to clipboard

Copied

Hey Fabrice,

So it looks like there is an error in the Renderman (PxrSurface) preset. I checked a few presets and they look correct. You can see below for instance that in the Redshift metallic-roughness preset, the base color and specular color are indeed color managed. The same is true for the Renderman (Disney) preset.

 

But when you look at the Renderman (PxrSurface) preset, only the emission is processed. Base Color and Face Color, both color channels, are listed as RAW.

 

My preset is really just a duplicate of that. Is there a way to alter the Renderman or my custom present so that those two channels are processed?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 14, 2022 Jan 14, 2022

Copy link to clipboard

Copied

It seems to work fine on my side with the preset you mentionned. Could you attach a log file ? I would like to check a few things related to your current build. See: https://substance3d.adobe.com/documentation/spdoc/exporting-the-log-file-128745475.html

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 14, 2022 Jan 14, 2022

Copy link to clipboard

Copied

Thanks Fabrice. Here's a log.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 14, 2022 Jan 14, 2022

Copy link to clipboard

Copied

Could you try to update to 7.4.1 ?

We did some fixes for Color Management, including around the export, in this bugfix. While I feel your issue was fixed before we shipped 7.4.0, it could be a side effect of something else. So it's worth updating to be sure if a new one.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 14, 2022 Jan 14, 2022

Copy link to clipboard

Copied

Thanks, Fabrice. That update seems to have fixed it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 16, 2022 Jan 16, 2022

Copy link to clipboard

Copied

Hey Fabrice,

There still seems to be a problem (either on my system or in this update). The Renderman PxrSurface output now "says" that those color channels are being converted, I don't think they actually are.

 

I took the same project and exported everything with the Redshift, Renderman (Disney), and Renderman (PxrSurface) presets. The RS and Disney ones seem to convert fine, but the PxrSurface one says it was converted, but if you bring it into Nuke, it doesn't match the others. If I interpret it as Utility - Texture - sRGB it seems closest.

 

I'm going to try to make a custom preset that works around this, but I'd prefer to get it sorted out so I can have a bit more confidence in the Substance Painter color management than I do at the moment. Thanks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 16, 2022 Jan 16, 2022

Copy link to clipboard

Copied

Just a quick update: I played around with trying to build a workaround custom set up and I noticed that all the problems seem to revolve around the "converted maps" in the export settings. Is it possible that they are not being calculated correctly? Maybe because in the case of "diffuse" and "specular" because a channel that is begin color managed (Base color) is being multiplied by a channel that is not (Metal)? Just a thought...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 24, 2022 Jan 24, 2022

Copy link to clipboard

Copied

Hi, we have an internal bug ticket on this exact issue. We plan to have a fix in our next bugfix version. 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 24, 2022 Jan 24, 2022

Copy link to clipboard

Copied

LATEST

Thanks, I'll keep a look out for it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources