• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Smart masks not working with meshes i make and import (made in blender)

New Here ,
Nov 29, 2022 Nov 29, 2022

Copy link to clipboard

Copied

i understand blender is a bit of a reble in terms of easily exporting models on any standart, i have that into account and i have made everything in my mesh as good as it can be to avoid this kind of errors (applying scale and rotation, making good uv unwraps, checking face orientation, etc...); however there are still things that are failing, and i'm no longer sure if the faulty here is the program or my meshes.

i just spotted what could be my problem for AT LEAST PART of the smart materials:

TheThouZands_0-1669743027486.png

However i don't know if that is normal or not, and for now all of my meshes just look as if the mask was globaly 0.5, which cause it to look like a perfect mix of both layers (i'm using here dirt ground smart mask, which is the only mask that works in SAMPLE meshes)

 

another problem i have, that bases off of precisely this, is that smart materials do not work at all, it just looks like the top-most layer they have, and for some reason, if i do this with simple surface layers, it completely breaks them

TheThouZands_1-1669743295349.png

i'm sticking to trying to use painter because it is the only software that has good masking, likewise in mixer i've had similar problems, but worse and texturing in blender is not practical because there is no real time view for functions that can create masks similar to those ones here.

i will attach the fbx here.

TOPICS
Bugs & Crashes , Import & Export

Views

167

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Nov 29, 2022 Nov 29, 2022

Your first screenshot indicates you have not yet baked the meshmaps. You need to do that after importing the mesh so that they are available for the generator in your smart material

https://helpx.adobe.com/uk/substance-3d-painter/using/baking.html

 

Dave

Likes

Translate

Translate
Community Expert ,
Nov 29, 2022 Nov 29, 2022

Copy link to clipboard

Copied

Your first screenshot indicates you have not yet baked the meshmaps. You need to do that after importing the mesh so that they are available for the generator in your smart material

https://helpx.adobe.com/uk/substance-3d-painter/using/baking.html

 

Dave

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 29, 2022 Nov 29, 2022

Copy link to clipboard

Copied

LATEST

Thank you very much, it worked. i never saw that in tutorials so i assumed it was another thing 😄

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources