• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Substance Painter crashing on MULTI monitor startup

New Here ,
Nov 08, 2021 Nov 08, 2021

Copy link to clipboard

Copied

Is there any fix for this yet???

I been using an older substance painter  for months now cause I dont want to deal with going into display setting and turning off extend display to 2 of my monitors  opening substance up then going back to display settings turning back on extend display to them both. This is to time consuming the last version that worked for me was 2020.1.3 the one that still had the substance logo not adobe version.

I dont think its my computer cause older version still workes fine.   I would like to use the new features and not  have to deal wit this.

TOPICS
Bugs & Crashes

Views

315

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 08, 2021 Nov 08, 2021

Copy link to clipboard

Copied

I use Substance Painter v7.3.0 on two monitors here without issue. Both are connected to the same GPU (RTX3090) using NVidia Studio Driver 472.12 on Windows 10 (v21H1) . I get no crashes.

 

Dave

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 09, 2021 Nov 09, 2021

Copy link to clipboard

Copied

Well last time I posted on the old Substance forums a staff said it was a know issue and will be fix with a next patch was months ago nothing. I have a 1080ti and only one gpu so the 3 monitors  are plugged into that gpu. Turning off screens in setting then turning them back on after app opens is the only fix and it sucks. or using older version of  Substance painter.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 09, 2021 Nov 09, 2021

Copy link to clipboard

Copied

I have the Gmae ready drivers Ill try  NVidia Studio Drivers

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 09, 2021 Nov 09, 2021

Copy link to clipboard

Copied

did not work 😕

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 30, 2022 Nov 30, 2022

Copy link to clipboard

Copied

LATEST

Hey,

The same issue has been bugging me for three years now, and it happen to that I found a fix just today.
The issue seems to come from the Nahimic proccess, you need to disable it :

- in the windows search bar type "services"

- in "Services" tab search for "Nahimic service", right click on it and open the properties

- change the "Startup type" from "automatic" to "manual" (or "disabled" it works too), then click apply, close the properties tab

- right click once again on"Nahimic service" and select "Stop", to stop the current execution
- try to open SP on your secondary monitor

 

Hopefully it works for you !

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources