• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

The materials on viewport appear green

New Here ,
Sep 22, 2022 Sep 22, 2022

Copy link to clipboard

Copied

As you can in the attached screenshot, no matter what material I use it looks green. It looks normal in iray renderer but green in viewport. The material I was using should look red.

 

please help me fix this. what am I doing wrong?

 

I have attached a log file and screenshot.

To demonstrate the problem I used a simple cube exported from maya, this problem is in all the new projects but not in the older ones.

TOPICS
Bugs & Crashes , Discussion

Views

3.2K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 22, 2022 Sep 22, 2022

Copy link to clipboard

Copied

Have you tried updating the shader? Click the shader settings icon (2nd down at the top right) and see if there is an update.

 

Dave

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 26, 2022 Oct 26, 2022

Copy link to clipboard

Copied

I have the same problem, I have already tried the solution you mention, but it still doesn't work. When I disable the Height map the green color disappears

 

juanjosec58014372_0-1666800947664.pngjuanjosec58014372_1-1666800990261.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 18, 2022 Nov 18, 2022

Copy link to clipboard

Copied

For some odd reason "Or obvious" asm-metalic-shader paints everything as black/green in height map while in Iray everything is fine

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 26, 2023 Jun 26, 2023

Copy link to clipboard

Copied

On Material preview make sure its on default if it's not click the x to change to default, it will ask you do you want to restart now select no and close program.  After that  then go to C:\Users\username\AppData\Roaming\Adobe\Adobe Substance 3D Painter\previews and delete everything inside. then start substance painter. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 18, 2022 Nov 18, 2022

Copy link to clipboard

Copied

Change it to Dota 2 Shader, this fixed it for me

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 18, 2022 Nov 18, 2022

Copy link to clipboard

Copied

Or actually change to any other server

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 20, 2022 Nov 20, 2022

Copy link to clipboard

Copied

how to change dota 2 shader,its really annoying to swtich render view to view port.kindly suggest.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 20, 2022 Nov 20, 2022

Copy link to clipboard

Copied

Shader settings in top right corner "Side bard" and under Undo/Redo button there is "asm-shader" change it to dota or any other metalic shader
Note thet Im on SB 2021 so it might be placed in a different spot but I believe it works the same for every version

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 04, 2022 Dec 04, 2022

Copy link to clipboard

Copied

Saved me! 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 12, 2022 Dec 12, 2022

Copy link to clipboard

Copied

This worked for me -- thank you!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 25, 2023 Feb 25, 2023

Copy link to clipboard

Copied

Thank you so much for the tip. It helped!

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 26, 2023 Jun 26, 2023

Copy link to clipboard

Copied

LATEST

On Material preview make sure its on default if it's not click the x to change to default, it will ask you do you want to restart now select no and close program.  After that  then go to C:\Users\username\AppData\Roaming\Adobe\Adobe Substance 3D Painter\previews and delete everything inside. then start substance painter. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources