Unable to rotate using a wacom pen

Community Beginner ,
Aug 05, 2021 Aug 05, 2021

Copy link to clipboard

Copied

Hi there.

I'm using a wacom pen to paint in SP. However, all of a sudden yesterday, Im now unable to use the rotate function which Ive set to one of my pens buttons. Why is this? The rotate function works in other softwares, like Blender. Any idea why this might be?

I'm using a Wacom Intuos Pro M.

TOPICS
Bugs & Crashes

Views

516

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Aug 24, 2021 Aug 24, 2021
This looks like there is an issue with the latest Wacom drivers (6.3.44). Make sure to downgrade your drivers to the 6.3.43 and the issue should go away.

Likes

Translate

Translate
Community Beginner ,
Aug 06, 2021 Aug 06, 2021

Copy link to clipboard

Copied

Worth noting that the button I have assigned to my pen is Middle Mouse Button. If I switch it to something else, say ALt + Right Mouse Button, it works. However, I wish to keep it as MMB. Why is the MMB giving issues in SP?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 18, 2021 Aug 18, 2021

Copy link to clipboard

Copied

My friend and I have encountered the same problem. Only substance painter 3D Adobe version won't give MMB pan, we also followed the link above with setting painter in tablet settings.

Reverted to pre-Adobe substance painter and now its also broken, can't mmb pan...sad days

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 18, 2021 Aug 18, 2021

Copy link to clipboard

Copied

I want to add also that the mmb, pan works in other programs, Maya, 3dcoat, Zbrush, something happened with substance painter

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 06, 2021 Aug 06, 2021

Copy link to clipboard

Copied

Just to be sure, have you followed our configuration guide already ?
See: https://substance3d.adobe.com/documentation/spdoc/configuring-pens-and-tablets-188974256.html

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 09, 2021 Aug 09, 2021

Copy link to clipboard

Copied

I've followed the configuration guide, and am having the same issue.  The middle mouse button using a stylus works correctly one time when another application is open and then the middle mouse button is used in Substance Painter, but after performing another camera operation or painting one paint stroke, the middle mouse button no longer works properly.  This makes Substance Painter very difficult and frustrating to use, and this behavior did not happen previously.  Please fix this issue as switching to a mouse just to rotate or pan the camera (depending on user settings) is a horrible workflow and will lead to users getting carpal tunnel syndrome!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 09, 2021 Aug 09, 2021

Copy link to clipboard

Copied

AFAIK nothing has changed in the way we handle tablet button inputs. What driver version are you suing for your Wacom tablet?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 09, 2021 Aug 09, 2021

Copy link to clipboard

Copied

The latest, 6.3.44-1.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 09, 2021 Aug 09, 2021

Copy link to clipboard

Copied

Im glad to hear im not the only one with this issue. My fix for now is to set the rotation/pan/translate to other hotkeys, however, this is confusing in the long run while switching between apps.

Im unsure why this has happened really.

Im using SP version 7.2.2 and Wacom Intuos Pro M version 6.3.44-1 as well.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 19, 2021 Aug 19, 2021

Copy link to clipboard

Copied

have same problem...this is affecting the way I work I have to click on the mouse 

mmb to pan around object...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 19, 2021 Aug 19, 2021

Copy link to clipboard

Copied

as a workaround... had to resort to use ctrl+alt click drag vs mmb drag to pan...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 19, 2021 Aug 19, 2021

Copy link to clipboard

Copied

Yes this is what I did as well.  It's just a little mind boggling that a program as widely used as Substance Painter would have issues with something as basic as the middle mouse button.  With all the money collected from all of us every month?  Come on Adobe, fix yo stuff!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 24, 2021 Aug 24, 2021

Copy link to clipboard

Copied

This is a decent workaround but still cannot use MMBC on Stencils.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 24, 2021 Aug 24, 2021

Copy link to clipboard

Copied

i'd guess i'd have to use a mouse mmb like a caveman...i dont wanna blame adobe but...i started having this bug on the new painter... might try to downgrade to lower versions pre-adobe and see what happens

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 24, 2021 Aug 24, 2021

Copy link to clipboard

Copied

I am also having this same issue. It is not a driver issue it is a Substance Painter issue. Is this the start of the Adobe takeover now. Nice! Please fix this ASAP Adobe. Thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 24, 2021 Aug 24, 2021

Copy link to clipboard

Copied

im pretty sure this should be a high priority fix...middle mouse button on pen and panning around is key...plus the mmb combos... fix itt plssss

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 24, 2021 Aug 24, 2021

Copy link to clipboard

Copied

Yes I cannot use the stencil feature now since the the MMB cannot be mapped to my wacom pen. I am using the Intuos Pro M. Latest drivers. Not an issue in any other software. This is really frustrating and ruining my workflow. "Use the mouse, line up the stencil, now take out the pen and paint'. Now use the mouse to pan around the scene, now take out the pen to paint' Ok, nice caveman workflow there. And I bet this will take months to fix. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 24, 2021 Aug 24, 2021

Copy link to clipboard

Copied

This looks like there is an issue with the latest Wacom drivers (6.3.44). Make sure to downgrade your drivers to the 6.3.43 and the issue should go away.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 25, 2021 Aug 25, 2021

Copy link to clipboard

Copied

LATEST

Ty, this fixed my issue!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources