• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

USD export does not include all 5 textures

Community Beginner ,
Oct 22, 2022 Oct 22, 2022

Copy link to clipboard

Copied

I am trying to export textures to use in USD (Apple reality converter).

I select the built in "USD PBR Metal Roughness" preset:

james0001_0-1666464174282.png

In the documentation it states that this is supposed to:

Five texture files are created and saved (base color, metallic, normal, occlusion and roughness)

This would be perfect!

However, in the "List of exports" tab I only get 2 or in some texture sets, 1 file:

james0001_1-1666464435380.png

And sadly, when I export textures, this is exactly what I get.

 

Any tips for getting all 5 textures (and the usdz) from SB would be awesome?

 

Notes:

- I'm not using UDIMs

- I haven't overridden any settings in individual texture sets

- Substance Painter 8.2.0 on win10

TOPICS
Bugs & Crashes , Import & Export

Views

44

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Oct 23, 2022 Oct 23, 2022

I think I've found the solution:

 

1. Change the Shader settings to pbr-metal-rough-with-alpha-blending (I have some glass in my model):

james0001_0-1666536755122.png

 

2. within each texture set add the relevant channels (e.g. Basecolor, roughness etc):

james0001_1-1666537222246.png

 

I have no idea why it was set up this way but hopefully this helps anyone else with the same issues in the future.

Likes

Translate

Translate
Community Expert ,
Oct 22, 2022 Oct 22, 2022

Copy link to clipboard

Copied

Have you got all 5 maps in your texture set - either in the material or in the baked maps? If the channels are disabled or not present there will be no output map.

I've just tested here and I see all five, provided they are present in the texture set to output.

 

Dave

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 23, 2022 Oct 23, 2022

Copy link to clipboard

Copied

Thanks Dave,

I think so...here's an example texture set that is only exporting Normal and Occlusion textures.

james0001_0-1666534347866.png

Perhaps a clue is that if I go into "+" under channels, Base color is only under Unsupported by Shader:

james0001_3-1666534640949.png

Any tips would be super-helpful...I've clearly set this project up incorrectly somehow!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 23, 2022 Oct 23, 2022

Copy link to clipboard

Copied

I think I've found the solution:

 

1. Change the Shader settings to pbr-metal-rough-with-alpha-blending (I have some glass in my model):

james0001_0-1666536755122.png

 

2. within each texture set add the relevant channels (e.g. Basecolor, roughness etc):

james0001_1-1666537222246.png

 

I have no idea why it was set up this way but hopefully this helps anyone else with the same issues in the future.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 23, 2022 Oct 23, 2022

Copy link to clipboard

Copied

LATEST

The export preset was looking for Base, Metal, roughness channels whereas you were using a Diffuse, Specular, Gloss workflow.

Dave

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources