Why Is displacement affecting all the layers on my file.

New Here ,
Jul 21, 2021 Jul 21, 2021

Copy link to clipboard

Copied

Hello, wanted to use displacement to simulate fur in a specific area of my character, but the displacement seems to affect all the layers even when those layer don't have displacemnt activated. Someone knows how to fix it. I can't find documentation whit a similar situation.

Thank you.

Here the displacement works fine.

Sebacho79_0-1626921095665.png

 

Displacement ON

Sebacho79_1-1626921119284.png

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Displacement OFF

Sebacho79_0-1626921438994.png

 

TOPICS
Bugs & Crashes, Discussion

Views

40

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 22, 2021 Jul 22, 2021

Copy link to clipboard

Copied

Are all those part of a same texture set? If they are, and you only want displacement on that part, make sure you add a displacement channel and use that channel for the fur effect. By default, the displacement option in the shader will use the height channel, which I assume is used in many other places in your project in this case.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 23, 2021 Jul 23, 2021

Copy link to clipboard

Copied

Hello Jeremie. The little octopus is the only part that has a Displacement channel enable. I try to add a displacement layer wondering if I can inver the shared displacement but didn't wok sending a screenshot of my layers. 

Sebacho79_0-1627091066195.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 24, 2021 Jul 24, 2021

Copy link to clipboard

Copied

LATEST

Did you alter the shader settings to use the displacement map instead of height or are you still using height?

 

Go to the shader settings and either :

Enable Parallax Occlusion mapping - adjust the strength

or

Set the displacement input to Displacement instead of height and adjust the Tessellation subdivision

 

Dave

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources