• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Blender Add-On: Presets Out of Order

New Here ,
Feb 26, 2024 Feb 26, 2024

Copy link to clipboard

Copied

The Presets are in the correct order when opening the SBS in Designer.

When loading the published SBSAR in Blender (3.6 LTS Current Version) using the Substance add-on (2.0.0) the Presets are visible but out of order, in that the presets are associated with the wrong parameters, specifically Base Color.

Also, some of the preset parameter values are not being retained when loading in the Substance add-on.

Wondering if anyone has seen this or may know of something I'm doing wrong to resolve this issue.

TOPICS
Bugs & Crashes

Views

85

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 26, 2024 Feb 26, 2024

Copy link to clipboard

Copied

For some additional context:

When setting the Default preset to the parameters I wanted for the additional presets, I had no issues with the additional presets having a parameter mis-match (In this case, Scratch intensity/density. Default orignally set to 0.1/0.1, additional presets @ 0. Default is now 0, all presets match).

The ordering issue has a pattern.

Screenshot 2024-02-26 145816.png


The circled Preset's Base Color is being trasferred to the destination of the Arrow.

Because the incorrect ordering isn't random, I can work around it. But something is definitely funky. Maybe specific to the way the add-on lists presets by order? I just don't have this issue with official sbsar mats, it only happens with custom ones.

Hmm.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 27, 2024 Feb 27, 2024

Copy link to clipboard

Copied

LATEST

Hi @devins94630799  thanks for bringing this to our attention, it looks like a new bug. We'll look into this. Would you be able to share the .sbs files from Designer to help us diagnose this isssue?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
Documentation
Download Latest Versions