• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

Substance for Maya: Animated parameters are not showing up in renders

New Here ,
Oct 14, 2021 Oct 14, 2021

Copy link to clipboard

Copied

Hello, I'm having an issue where I'm not able to see my animated SBSAR materials inside of Substance for Maya. I can change the values of exposed parameters, however when I animate those values none of those changes are reflected in the batch render. I've been told that it's possible to keyframe your SBSAR parameters in Maya, but so far it doesn't seem to work in the render. Is this a known issue? Are others having any luck animating their SBSAR materials in Maya? 

 

I'm running Maya 2022 with the latest version of Substance for Maya installed.

TOPICS
Autodesk Maya , Bugs & Crashes , Question

Views

528

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Participant , Sep 02, 2023 Sep 02, 2023

Couldn't find that setting.

Maya 2024.1

Substance to Maya 2.3.2

 

Votes

Translate

Translate
New Here ,
Oct 26, 2021 Oct 26, 2021

Copy link to clipboard

Copied

I'm having the same issue.  I'm in Maya 2018, Substance Plugin, Arnold 2018.4.  If I scrub my viewport timeline it will work but I get no results in 'batch render' or 'render sequence' would love to use this feature.  Everything looks hooked up correctly.  When I render it will just render my current viewport frame over and over.  My only other lead is an Substance rep talking about rendering being synchronoous or asynchronous, but I can't find any documentation on how to test those modes.  Thanks in advance for any help.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 26, 2021 Oct 26, 2021

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 02, 2021 Nov 02, 2021

Copy link to clipboard

Copied

If you check in the settings dialog, which can be accessed from either the shelf or the top Substance menu, you should be able to set it to synchronous renders. It defaults to asynchronous, which is going to make it not wait for the Substance Engine to compute, which isn't what you want for trying to keyframe things. You may need to restart Maya after setting it to that.

 

If that still doesn't work, we can try to reproduce it and see if we can fix it for a future version.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Sep 02, 2023 Sep 02, 2023

Copy link to clipboard

Copied

Couldn't find that setting.

Maya 2024.1

Substance to Maya 2.3.2

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 05, 2023 Sep 05, 2023

Copy link to clipboard

Copied

Hi @Ayush Bakshi , This setting should be the called Blocking Renders option, and appears as a checkbox in the Substance Engine section of the Settings.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 07, 2023 Nov 07, 2023

Copy link to clipboard

Copied

Thank you! That worked.

Though there are still issues in the way like Maya rendering sbsar nodes in a loop causing slowdows.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 14, 2023 Nov 14, 2023

Copy link to clipboard

Copied

LATEST

Glad to hear that worked!
Could you tell me more about the slowdowns due to re-rendered nodes? When is this re-rendering occuring and do you see any console messages related to the sbsar nodes?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
Documentation
Download Latest Versions