• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

Substance plugin 4.27 swaps red & blue channels on base colour output when using image inputs

New Here ,
Mar 14, 2022 Mar 14, 2022

Copy link to clipboard

Copied

The Red and blue channels randomly switch when using the image input in the ue4 plugin. Can reliably recreate this with the image input but also sometimes occurs when using a multi switch for baked images & no image input. This happens even with the image input hooked directly to the base colour output node as well. 

Dan235766757icn_7-1647266910363.png

 

Set up used for the below images:

Dan235766757icn_9-1647266996286.png

 

We were able to test this by simply switching to the image input & back again causing it to go blue.

Dan235766757icn_5-1647264902129.png

If I create a "MakeFloat4" node & swap the red/blue channels it outputs the intended base colour. 

Dan235766757icn_6-1647265002317.png

This isn't a solution as when making other unrelated changes (e.g. texture resolution) & the texture updates everything & outputs the correct channels as intended originally so that change in the material would then make the texture go blue when working correctly. Any help greatly appreciated

 

TOPICS
Bugs & Crashes , Question , UE4

Views

289

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 19, 2022 Apr 19, 2022

Copy link to clipboard

Copied

Thanks for reporting this issue. It's currently in our product backlog and we will be investigating this issue further. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 30, 2022 Apr 30, 2022

Copy link to clipboard

Copied

Hi, I am also having this issue. When is it expected to be fixed?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 27, 2022 May 27, 2022

Copy link to clipboard

Copied

This issue is now fixed both on UE 4.27 and UE 5 versions. Please download the latest version of the plugin on the UE marketplace. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 23, 2022 Apr 23, 2022

Copy link to clipboard

Copied

This issue is major! My project will remain halted until this is resolved so fingers crossed for a quick solution.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 27, 2022 May 27, 2022

Copy link to clipboard

Copied

LATEST

This issue is now fixed both on UE 4.27 and UE 5 versions. Please download the latest version of the plugin on the UE marketplace. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
Documentation
Download Latest Versions