• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

GPU (RTX 4090 Laptop) Rendering Disabled

New Here ,
Jun 11, 2023 Jun 11, 2023

Copy link to clipboard

Copied

I was wondering if anyone had any suggestions besides ensuring the correct GPU is selected in the Windows and Nvidia environment.  I have tried the latest studio and gaming drivers with a clean install each time.  I assume its still defaulting to the integrated card, but unsure where else I might alter the settings.  Log file included.

Views

162

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 12, 2023 Jun 12, 2023

Copy link to clipboard

Copied

I had it "choosing" selectively between CPU and GPU randomly when I started using Stager. Ultimately I seem to have been able to resolve the issue by gouing to the NVidia control panel in the "per program" list of the 3D options...

Imaginerie_0-1686575866682.png

 

 

There are also another instance where you can choose a specific GPU over the global settings

Imaginerie_1-1686575923387.png

See if that resolves it...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 19, 2023 Jun 19, 2023

Copy link to clipboard

Copied

LATEST

Given the specs of your laptop, I'm guessing you're running Windows 11 because that's a very new machine. Win 11 controls GPU selection in Settings instead of the NVidia control panel, so do this:

  1. Go to Settings, open System>Display>Graphics.
  2. Under "Custom options for apps" choose Desktop app in the dropdown and click Browse. Navigate to Program Files\Adobe\Adobe Substance 3D Stager and select the Stager executable.
  3. In the dialog that opens, click "Options" and choose the High performance radio button.

This will ensure that Windows only uses the discrete GPU, and you should be good to go.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources