Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Forum no more shows syntax highlighting for code blocks

Enthusiast ,
Feb 08, 2021 Feb 08, 2021

Copy link to clipboard

Copied

Views

139

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 09, 2021 Feb 09, 2021

Copy link to clipboard

Copied

This forum platform (Khoros) has NEVER had code syntax highlighting.   All code styles are wiped on submit.  It has been that way ever since Khoros launched.

 

Nancy O'Shea, Adobe Product User & Community Professional
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 09, 2021 Feb 09, 2021

Copy link to clipboard

Copied


@Nancy OShea wrote:

This forum platform (Khoros) has NEVER had code syntax highlighting.


This is absolutely not true!

The effect appears about since mid January 2021. Before that syntax highlighting was present in submitted posts.

Unfortunately I do not have any pdf to prove.

 

"...and if it were so, it was gracious fault, and grieciously ha Cesar answered it.." [Shakespeare]
Why then should we waste our time in editing selecting a pgm-language tu influence the syntax highlighting?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 09, 2021 Feb 09, 2021

Copy link to clipboard

Copied

I'm sorry  but I must respectfully disagree.  This platform has NEVER supported syntax highlighting on submit, at least not from any of my desktop browsers and not with any code that I've inserted from the </> icon including HTML, CSS, XML/SVG, JavaScript, PHP, etc...

 

If you did see syntax highlighting, perhaps it came from another source -- a screenshot, code pen or js fiddle.

 

Nancy O'Shea, Adobe Product User & Community Professional
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 09, 2021 Feb 09, 2021

Copy link to clipboard

Copied

The only time I've had the syntax highlighting show since the Khoros forum was launched is when composing a post. Once it's posted, I've only ever seen black text.

 

Which is unfortunate, given the weight of loading the syntax highlighting javascript for every page. 😞

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 09, 2021 Feb 09, 2021

Copy link to clipboard

Copied

LATEST

Once it's posted, I've only ever seen black text.

=============

Yes, @Amebr,  that's correct.  Once the submit button is clicked, all code styles vanish for some mysterious reason that's never been fully explained. This forum platform is leased from a 3rd party; not made by Adobe.  Since there are other more pressing issues, I guess code formatting is not a big priority.

 

Nancy O'Shea, Adobe Product User & Community Professional
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines