Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Unable to translate post into English

Adobe Community Professional ,
Nov 08, 2019 Nov 08, 2019

Copy link to clipboard

Copied

. . .  because the English option is at the top of the list and is off screen (in Firefox). Zooming the post out does not help. And this doesn't seem to be related to the fact that translation doesn't work where the Conversation title is in English.

 

 

Ashampoo_Snap_2019.11.08_11h09m44s_001_.png

TOPICS
Bug

Views

546

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Nov 14, 2019 Nov 14, 2019
>> because the English option is at the top of the list and is off screen Looks like this was fixed in the Nov 11 update. Accessing the English option at the top of the menu works OK for me now. https://community.adobe.com/t5/Community-Feedback/November-11th-Release-Notes/td-p/10739478 "Bug: Translation menu should no longer show above button and should no longer hide the English option." However, no error message appears when the Subject language = target translation language but the body...

Likes

Translate

Translate
Adobe Community Professional ,
Nov 08, 2019 Nov 08, 2019

Copy link to clipboard

Copied

Yes known issue.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 08, 2019 Nov 08, 2019

Copy link to clipboard

Copied

When this happens to me, I am able to scroll the browser window down to reveal the English option at the top of the menu.

 

No clicking or the menu disappears. Just scroll up or down on my mouse wheel or track pad.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 08, 2019 Nov 08, 2019

Copy link to clipboard

Copied

John, normally I can do that too.  But in this case, I am at the top of the browser window and can't scroll any further.  The pop up menu doesn't extend beyond the window in view.  Here is a link to the thread, if anyone wants to try it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 08, 2019 Nov 08, 2019

Copy link to clipboard

Copied

It works OK for me.  Desktop Firefox. 

 

image.png

Nancy O'Shea, Adobe Product User & Community Professional
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 08, 2019 Nov 08, 2019

Copy link to clipboard

Copied

Shrink your browser window to force the menu to appear above the Translate button, Nancy. You can see the top and bottom of the browser viewport in Greg's screenshot.

 

Then the English option at the top is inaccessible.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 08, 2019 Nov 08, 2019

Copy link to clipboard

Copied

John,

I'm aware of the problems especially on short posts on short screens.  It takes a lot of browser finesse to do the simplest things. 

 

Another fly in the ointment is the character limit.  If somebody posts a book as happened yesterday, nobody can translate it.  

Nancy O'Shea, Adobe Product User & Community Professional
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 08, 2019 Nov 08, 2019

Copy link to clipboard

Copied

Yes, same behaviour here for that particular post on a small screen. Unable to scroll to top of menu.

 

When I set my hi-res monitor to full screen browsing, the menu appears below the Translate button. Seems like the script which fires the menu needs tweaking to improve menu positioning.

The irony here is that Translate to English still doesn't work because the Subject header is deemed to already be in English.

pse-translate-menu.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 08, 2019 Nov 08, 2019

Copy link to clipboard

Copied

OK, the workaround I just found is to counter-intuitively zoom IN to the post (several times from my normal viewing ratio).  I have my Windows display scale and layout set to 125%. Changing it to 100% had no effect.  It was only when I hit Ctrl+ several times in my browser that the top of the menu showed up.

 

Added:  And the behavior of the menu has also changed.  There is no warning message that the target language is the same as the post.  Such a warning would pop up previously if the subject line is in English.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 12, 2019 Nov 12, 2019

Copy link to clipboard

Copied

I saw exactly that here on Chrome Mac. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 14, 2019 Nov 14, 2019

Copy link to clipboard

Copied

>> because the English option is at the top of the list and is off screen

 

Looks like this was fixed in the Nov 11 update. Accessing the English option at the top of the menu works OK for me now.

https://community.adobe.com/t5/Community-Feedback/November-11th-Release-Notes/td-p/10739478

 

"Bug: Translation menu should no longer show above button and should no longer hide the English option."

 

However, no error message appears when the Subject language = target translation language but the body text still requires translation. In that case now, the Translation option just does nothing. I preferred the error message. At least we knew what was going on then.

 

Surely all they need to do is extend the script fired by the Translate button to check the language for both Subject and body? Or ignore the Subject entirely and check the body text?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 19, 2019 Nov 19, 2019

Copy link to clipboard

Copied

Hi John, in regards to the translation issues: yes, we're aware of the issue you're talking about and are finding ways to solve it. For the translation menu, you're correct that it was fixed in the November 11th release.

Melissa Rios, Product Manager, Community Experience & Platform | Adobe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 19, 2019 Nov 19, 2019

Copy link to clipboard

Copied

Thanks for the feedback, Melissa.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 22, 2019 Nov 22, 2019

Copy link to clipboard

Copied

As a moderator, what I do in such cases is add the language name in square brackets to the start of the title text (eg. "[Español]"). It then becomes possible to translate it, as the translation engine picks it up and knows what the source language is.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 24, 2019 Nov 24, 2019

Copy link to clipboard

Copied

LATEST

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines