Blanks inserted into certain hyperlinks

LEGEND ,
Jun 02, 2009 Jun 02, 2009

Copy link to clipboard

Copied

I've seen this a number of times, but I thought it may have been copy & paste errors.  But they are not.

See this post http://forums.adobe.com/message/2008300#2008300

I have inserted two download links, and each of them has a blank inserted near the end of the string (install_flash_player_ax.exe, install_flash_player.exe - blanks marked red).

The hyperlink itself works fine, but if somebody copys that string into a new post, the hyperlink won't work any longer.

Views

2.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Jun 03, 2009 Jun 03, 2009

Copy link to clipboard

Copied

I have seen that symptom many times! As you said, the link works anyway - and it appears fine even in the email notifications, but it is disfunctional for copy/paste from the Web forum.

The following is not exactly the same, and I don't know enough about the Jive app to determine if it needs its own thread or if the Jive code that does this is in the same module, so I thought I should add it here.

I've seen spaces arbitrarily inserted into code blocks as well via >>Insert->Syntax Highlighting->Plain

For example, http://forums.adobe.com/message/2004585#2004585 .

P1_Prod_Version=Shoc kwaveFlash

should be:

P1_Prod_Version=ShockwaveFlash

While I did not post that particular block, I have seen it happen in code blocks that I did post.

It is even worse in code blocks when people paste code with tabs AND spaces in the indentations. Jive seems to modify such spaces with several bogus variations of an HTML non-breaking space. Literally inserting spaces and showing them in the code as & npsp; &n bsp; &nb sp; and others. Just as a for instance, the following line from a code block in a different message (I have no idea what it will do with this paste, but will come back to confirm/deny its accuracy).

             & nbsp;      var correct = temp3=temp2.options[temp2.selectedIndex].text;     &nb sp;            &nbsp ; { & nbsp;      var correct = temp3=temp2.options[temp2.selectedIndex].text;     &nb sp;            &nbsp ; {

Jive should not munge code in forums about code in any apparent way. It makes it hard to impossible to deal with, whether one is posting a question or a solution. The email interface is even worse in this regard (mentioned in other threads), but I would like to think that the Web interface should be easy enough to fix.

[Edit]

Yes, that code block is an accurate representation of what I saw in another thread.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 18, 2009 Jun 18, 2009

Copy link to clipboard

Copied

This keeps being a problem, see http://forums.adobe.com/message/2048580#2048580 for instance (note the blank characters in http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_ax.exe and http://download.macromedia.com/pub/flashplayer/current/uninstall_flash_player.exe).

I keep giving download or other links to people, and ever so often I get the reply that my links do "not work". Of course they do not work if blanks are inserted randomly.

Is this treated as a known bug?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Jun 18, 2009 Jun 18, 2009

Copy link to clipboard

Copied

noted the same thing when i posted the afplonkjive script.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Mentor ,
Jun 26, 2009 Jun 26, 2009

Copy link to clipboard

Copied

Here is a test link:

http://www.phillipmjones.net

See if it works, I'm on a Mac platform (FreeBSD Unix underneath the hood)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Jun 26, 2009 Jun 26, 2009

Copy link to clipboard

Copied

PjonesCET wrote:

See if it works, I'm on a Mac platform (FreeBSD Unix underneath the hood)

BSD? Blue Screen of Death???

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Mentor ,
Jun 26, 2009 Jun 26, 2009

Copy link to clipboard

Copied

LATEST

Berkley Systems Development. The orgininal BSD UNIX was developed at Berkley University in California.

FreeBSD is a derivative that use a Open source License.

The original BSD which as a heavy liscencing Fee was usede for OSX.1 , 2, 3 and the switched to FreeBSD in OSX.4.

I have no idea what version of UNIX is used is used in Intel Mac's  Could be some X based (XFree?) primarily designed for windows machines.

Or they might still used a form of BSD UNIX.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 25, 2009 Jun 25, 2009

Copy link to clipboard

Copied

Really!!

I keep posting links (using the Insert Link button), and people reply that they are getting 404 because of the blanks inserted into the links!

I have noticed that the forum software often inserts a blank character after a full-stop character, e.g. here in this registry key: HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{CA8A9780-280D-11CF-A24D-444553540000}\EnableFullPage\.xfdf

But in case of the hyperlinks, it is always somewhere near the end.

Can't this software be stopped to insert blank characters in places where these are not wanted?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines