Forum font blurry in FireFox 45.0

Most Valuable Participant ,
Mar 10, 2016 Mar 10, 2016

Copy link to clipboard

Copied

Just wanted to ask if anyone else is experiencing a very blurry font in these forums after upgrading to Firefox 45.0? And if anyone know of a solution, of course...

Views

4.0K

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Mar 11, 2016 Mar 11, 2016

Copy link to clipboard

Copied

I'm seeing a font weight difference (FF45 is rendering heavier). Can't yet tell if it's a Firefox problem or a glitch with the Typekit data, but nobody's opened a bug at Mozilla.

Here's a comparison, FF45 and Chrome 50 (click to zoom):

fonts.png

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Mar 11, 2016 Mar 11, 2016

Copy link to clipboard

Copied

One potential solution - in Firefox open about:config and change gfx.font_rendering.cleartype_params.rendering_mode to 0. That forces Cleartype to kick in for every font.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Mar 11, 2016 Mar 11, 2016

Copy link to clipboard

Copied

Trying it now... Thanks!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 11, 2016 Mar 11, 2016

Copy link to clipboard

Copied

Yes, been bothering me too, and I was about to send off a similar post when I saw this.

Will try the clear type setting. Other than that I hope the next FF update fixes it.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Mar 11, 2016 Mar 11, 2016

Copy link to clipboard

Copied

It didn't really help me, I have to say...

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 11, 2016 Mar 11, 2016

Copy link to clipboard

Copied

Nope, didn't do anything.

I'm out of my comfort zone on this, but if the forum site is supposed to load a Typekit font, I get a vague feeling that's not happening. The font I see in Firefox now (badly at that) seems different from what I see in other browsers.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 24, 2016 Mar 24, 2016

Copy link to clipboard

Copied

Slightly better now (45.0.1), but there's still something funny going on.

No ClearType even though it's turned on in system, and the kerning is shot to h*ll. And what's with the "d"s?:

ff_fonts.png

So all in all it's readable, but still annoying. Does anyone know what's going on here?

All default settings in Firefox's font rendering.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Mar 26, 2016 Mar 26, 2016

Copy link to clipboard

Copied

And I thought it was just me. (I've always had this ego problem.)

The only solution I've found is to go into Options (about:preferences#content), click Fonts & Colors > Advanced and uncheck "Allow pages to choose their own fonts, instead of my selections above".

A is with it checked, B unchecked.

FF45-fonts.png

Bit of a pain for one set of forums...

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Mar 26, 2016 Mar 26, 2016

Copy link to clipboard

Copied

The problem is that that screws up a bunch of other sites...

On Sat, Mar 26, 2016 at 7:32 PM, PBArtattack <forums_noreply@adobe.com>

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Mar 26, 2016 Mar 26, 2016

Copy link to clipboard

Copied

Agreed. So I have belled the cat by submitting a question to Mozilla. Go here for all the exciting developments — https://support.mozilla.org/en-US/questions/1115893 .

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Mar 26, 2016 Mar 26, 2016

Copy link to clipboard

Copied

Good idea... I +1 it.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Mar 27, 2016 Mar 27, 2016

Copy link to clipboard

Copied

There is a solution to the Forum fonts problem — it involves installing the Stylish extension and then installing a script that the gentleman who was helping me came up with. It basically replaces the remote Adobe fonts with whatever your browser's fallback font is, Arial or Helvetica Neue. It works as if you were unchecking the "Allow pages to choose their own fonts..." option, but only for Adobe Forum pages, nothing else. Go to Font rendering problem in Firefox 45.* | Firefox Support Forum | Mozilla Support and check it out.

Why Firefox is doing this remains a mystery, but at least there's a workaround.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Mar 27, 2016 Mar 27, 2016

Copy link to clipboard

Copied

I can confirm that installing Stylish and the font definitions posted by jscher2000 does indeed solve the problem (at least on these forums).

Thanks for the update!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Mar 27, 2016 Mar 27, 2016

Copy link to clipboard

Copied

You're welcome!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 28, 2016 Mar 28, 2016

Copy link to clipboard

Copied

Thank you - haven't tried it yet, but I will. Good to know there is a workaround. Although I still hope for a future FF update to fix it permanently.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Mar 28, 2016 Mar 28, 2016

Copy link to clipboard

Copied

It occured to me that you don't actually have to install the Stylish extension. Since jscher2000's code is a Cascading Style Sheet and he made the whole script available in that thread on the Mozilla site, all you have to do is copy and paste it into your userChrome. This isn't idle surmise; I disabled Stylish and did it just to see what happens. It works.

Apparently this bug only affects the forums; I haven't seen it happening anywhere else. Are these the only sites that use Adobe Clear? Are we the only individuals impacted? I haven't seen anyone else chiming in anywhere.

This leads me to suspect there won't be a fix anytime soon, if ever. The natives aren't sufficiently restless.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Mar 28, 2016 Mar 28, 2016

Copy link to clipboard

Copied

My guess is that it's some kind of proprietary font of Adobe, so if it's not used in other sites and the problem doesn't affect other fonts then it probably won't be solved. I'm happy with the current solution, though (although the new Arial font is a bid thin, but I can play around with the CSS definitions to fix it).

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Mar 28, 2016 Mar 28, 2016

Copy link to clipboard

Copied

Adobe Clean is the corporate font. It's used in all Adobe websites and served via Typekit, published with a domain lock. Nobody else can use it.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Apr 22, 2016 Apr 22, 2016

Copy link to clipboard

Copied

Has anyone noticed you no longer need jscher2000's CSS defs since the Forum update?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Apr 22, 2016 Apr 22, 2016

Copy link to clipboard

Copied

I tried it after the update but it's still quite blurry.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Apr 22, 2016 Apr 22, 2016

Copy link to clipboard

Copied

Interesting. I deleted the CSS from userChrome (I'd decided to disable Stylish) and print in the Forums looks clean in my browser.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 23, 2016 Apr 23, 2016

Copy link to clipboard

Copied

Still looks bad in Firefox / Win 7 (two independent desktop systems).

BUT looks good in Firefox / Win 10 on a laptop.

Firefox set to auto-update everywhere, so all latest versions. No idea what's going on here.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Apr 23, 2016 Apr 23, 2016

Copy link to clipboard

Copied

Yeah, I'm on Win 7 as well and it still looks the same with the latest

version of Firefox.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines