Premiere Pro using Integrated and not Dedicated Graphics Card

Explorer ,
Nov 13, 2017 Nov 13, 2017

Copy link to clipboard

Copied

Hello all, I have a quick, but important question about Premiere Pro CC 2018. It seems that Premiere Pro is using my integrated graphics on my CPU rather than using my installed and working dedicated graphics card to render GPU accelerated effects and such. I am running a fresh install of Windows 10 with the latest updates. I also have a fully updated Creative Suite. Below I have listed my system specs and screenshots for reference to the issue. Notice that under GPU Engine in Task Manager, it lists GPU 0, my integrated graphics. I have also done some research of my own, and I have come across adding the "cuda_supported_cards.txt" into Premiere Pro's installation directory. I have done that, and I have tried both typing "GeForce GTX 1060" and "GeForce GTX 1060 6GB" into the document, but its the same story for both cases: it uses my integrated graphics. The file currently lists "GeForce GTX 1060".

Thank for any and all help,

Ryan

System:

7th Gen Intel i7-7700K Processor (No current overclock)

nVIDIA GeForce GTX 1060 6GB

256GB M.2 SSD

2TB 7200 RPM HDD

16GB of 2400MHz DDR4 Memory

Windows 10 Pro 64-bit

Screenshots (Idle, Premiere Pro loaded and open, not rendering):

idle.PNG

idle 2.PNG

Screenshots (Premiere running, Rendering previews for a project of mine):

render.PNG

render 2.PNG

render 3.PNG

render 4.PNG

render 5.PNG

Text Document:

cuda.PNG

cuda 2.PNG

[Moderator note: moved to best forum for technical issues.]

TOPICS
Hardware or GPU

Views

371.0K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Feb 22, 2021 Feb 22, 2021
We created a video on how to optimize your GPU for Adobe apps here! Take it with a grain of salt, if you have an Intel GPU using QuickSync, you're best off using that GPU for H.264 and HEVC (H.265).  Caroline

Likes

Translate

Translate
replies 158 Replies 158
New Here ,
Jun 05, 2019 Jun 05, 2019

Copy link to clipboard

Copied

Yup, give the author "Vouk" Daniel some coin. Man doing good work!!

https://forums.adobe.com/people/Billy+Cao  wrote

Sure. Happy to see my suggestion helped

For a 4 min 4k video

What I was getting:

  1. Intel i6700k  - 30 minutes
  2. iGPU HD530 - 11 minutes

GitHub - Vouk/voukoder: Use FFMpeg encoders directly in Adobe Premiere codec:

  1. GTX 1070 - 6 minutes

Ingest setting was transcode BTW.

And when I try to change the name...it crashes. Could be an Adobe issue though.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 26, 2019 Jan 26, 2019

Copy link to clipboard

Copied

It works and is somewhat faster, but it does use more CPU.

Before Voukoder:

CPU 25%, GPU 0 75%

After Voukoder:

CPU 55%, GPU 1 50%

I'll play with it some more

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 07, 2019 Feb 07, 2019

Copy link to clipboard

Copied

cool. my gpu can run like 20-30% with it. but cpu still 100%

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 08, 2019 Jan 08, 2019

Copy link to clipboard

Copied

i can't fathom this is still an issue...

my 3.200 euro Surface Book 2 have been shit from day because of this issue...

All Adobe applications run like shit on it because of extremely poor GPU behaviour

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 12, 2019 Jan 12, 2019

Copy link to clipboard

Copied

I have a similar set-up to you (notebook with integrated GPU (Nvidia MX150).

I had previously been able to use Premiere Pro (both 2017 and 2018) with no problems and then, all of a sudden, it stopped working for me. This had happened previously and I managed to fix it (only for it to randomly happen again).

I could not remember the solution the first time this happened, months ago ... I'm sure it involved looking at this thread and banging head against the wall then, too! I had installed myrad different versions of the integrated Intel HD 620 GPU and the Nvidia dGPU, with various combinations, in the bid to find a solution. No dice!

However, I've created an account here to see if it might work for you guys (and in case I need to see this post again, when PP inevitably screws up for no apparent reason once more!).

I think the main solution for me was that I went into Preferences>Media>Unchecked the option for "Enable accelerated Intel h.264 decording (restart required)".

I had also done a step prior to that before restarting so it could also be this: (or a comination of this technique and the unchecking accelerated decoding option).

Start>Command Prompt (type cmd and enter)>regedit (type, hit enter)>HKEY_LOCAL_MACHINE>SOFTWARE>Khronos>OpenCL>Vendors> Right click on the REG_DWORD option(s) and select "modify">Change the "Value data" from 0 to 1 [this disabled OpenCL, I believe - must help make Premiere Pro choose the CUDA of NVidia?]

I restarted after performing the above two actions and, voila, it started to work again.

I have no blooming idea why PP stopped working when it previously had no issue with the iGPU nor dGPU ... I'm guessing some automatic background updates that were performed to update the drivers, or the PP software, messed things up.

I hope this works for people!

Edit: Another potential option that I also did was I changed my battery settings. It was previously on power saving mode, so perhaps there was an issue there?? something else to think about!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 14, 2019 Jan 14, 2019

Copy link to clipboard

Copied

"Battery saving mode" and "NLE" are not good combinations. Make sure any laptop used while editing with Pr has that turned off! The first thing that typically does is bypass a full GPU to use the lower-power-consuming on-board chip.

Neil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 04, 2019 Mar 04, 2019

Copy link to clipboard

Copied

Just want to share that i am doing fine with CUDA rendering on PrPro CC 2018 latest update. There is no problem with GPU not being used for rendering. AS you can see, my GPU is 1060 MaxQ (I am using notebook, Dell 7577) is at 100%, and low CPU usage.

GPU 100%.png

There is also times that the dedicated GPU is not fully used because the content is not 'accelerate-able', especially when exporting to H.264 codec and not so much effect.

GPU 32%.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 01, 2019 Jun 01, 2019

Copy link to clipboard

Copied

Hi everyone,

I've been looking into this matter as I have experienced this too for quite some time now....well, more like as soon as I started using the Premiere Pro. Last night, I was rendering a 9-minute video and it was using about 90-99% Intel GPU. Render setting was my usual resolution and VBR 2, and it was taking longer to render, and I have experienced faster render with similar length videos.

This morning, I tried rendering a new one as I had to revise some details in the video and I tried the CBR, and wouldn't you know it, it started using the Nvidia GPU and improved rendering speed. I normally use VBR 1 for my clients as the videos I do are mostly are published online, VBR is normally better for compression.

*Extra.... I just did another rendering and I found out that if my laptop was plugged in while rendering, it was only using 20ish% of the dedicated GPU. My adapter was becoming a little bit hot so I unplugged it and the dedicated GPU usage jumped to about the same as in the picture.

test render.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 07, 2019 Jun 07, 2019

Copy link to clipboard

Copied

Hello,

What are you encoding to and from? What (if any) effects are on the timeline?

Thanks,

Nate

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 11, 2019 Jun 11, 2019

Copy link to clipboard

Copied

2 adjustment layers. 1 for exposure and colour correction, and then 1 for a LUT.

And then I have several animated text graphics and an overlayed b-rolls spread across the timeline.

I'm encoding it to a .h264, 1920x1080, 23.976 fps, CBR 15mbps.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 11, 2019 Jun 11, 2019

Copy link to clipboard

Copied

The Nvidia GPU will accelerate the effects, the Intel chip accelerates H.264 encoding. What version of Premiere are you using? 13.1.2?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 11, 2019 Jun 11, 2019

Copy link to clipboard

Copied

I am having the same issue with my Microsoft Surface Book 2 15 inch with the GTX1060 GPU. As of this post, 6/11/19, everything is up to date i.e. lastest version of Windows 10 and Creative Cloud apps Premiere Pro and Media Encoder. This is total BS.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 23, 2019 Jul 23, 2019

Copy link to clipboard

Copied

After a lot of messing around with my Alienware (Dell) laptop I finally got this sorted, or so it appears!

Go into the Windows 10 Graphics Settings & set the graphics for each app you need to High Performance. Photoshop, Lightroom & Premiere Pro are now working consistently for me. In PP I still get the System Compatibility error message at startup & you do need to have this following option set.

File> Project Settings> General> Renderer> Mercury Playback Engine GPU Acceleration CUDA

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 04, 2019 Aug 04, 2019

Copy link to clipboard

Copied

This seems to have worked for me as well. After making the above change in Settings>System>Display>Graphics Settings, I notice a spike in my Nvidia GPU activity in Task Manager when I play back realtime effects in the timeline.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 06, 2019 Aug 06, 2019

Copy link to clipboard

Copied

I am having the same issue everyone else is reporting. Even just trying to play back video before rendering, premiere is relying solely on CPU, and not using my graphics card at all. I have followed everyone's suggestions to no avail.

Intel 7700k

GTX 1080

64GB Ram

CPU Usage.pngGPU Usage.pngPRoject Settings.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 06, 2019 Aug 06, 2019

Copy link to clipboard

Copied

I am having the same issue everyone else is reporting. Even just trying to play back video before rendering, premiere is relying solely on CPU, and not using my graphics card at all. I have followed everyone's suggestions to no avail.

Well ... I don't know how many times it needs to be said ... Premiere does NOT use the GPU very much if at all for general playback ... the GPU is primarily used for those things on the GPU Accelerated Effects List ...

GPU Accelerated Effects: https://helpx.adobe.com/premiere-pro/using/effects.html

Period. As with any video-post-processing app, the engineers have designed a system to what they think best uses the system resources over the various needs and demands of the main user-base. Some apps code certain things more for GPU, some CPU ... they all vary.

And they all are built by looking at what effect using some part of the system resources for X purpose will have under thirty different scenarios. The engineers make choices based again on the overall needs of the various code sections for hardware support.

It's always trade-offs. Which is ... Life.

Neil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 17, 2019 Sep 17, 2019

Copy link to clipboard

Copied

I'm having the same issue here, and I found some workaround by now. I don't know if at this point things are working as it should be, but I thought sharing with you might help since I noticed some improving.

 

I have an Dell Inspiron 3000 series laptop, with the following config:

 

Core i7 8th gen

8GB RAM

Integrated Intel 620 GPU

Dedicated AMD ATI Radeon 520 2GB RAM

 

Same as you all, Premiere cc 2019 was exporting .mp4 (H264) video using a lot of processor capabilites and Intel integrated GPU. I've tried setting Radeon software to optimize performance and force Premiere to use Radeon GPU, with no effect. Then I've tried in Windows 10 (1903) Settings>System>Video>Advanced graphics config (or something like it, since my OS is in Brazilian Portuguese) adding Premiere Pro CC 2019 to a list and then setting it to High performance (fisrt through Search button, then options in Premiere once added to the list). No improve observed.

 

Following, I've foud a Intel Graphics Control Panel (in Start menu) and in the Energy tab I set on battery and plugged to Highest performance (or something equivalent). That finally triggered the Radeon GPU. While exporting video in Premiere, the processor usage dropped to 65-75%, Intel GPU remained the same ~95% and Radeon went to 12-14% (a small victory, but better than nothing).

 

One additional detail may be of interest. I was using the laptop on battery. When I plugged it back to the power, Radeon GPU dropped to 2% and processor went back to 100% instantly! To make a long story short, in Control Panel>Power Options (maybe energy?)>Change Power Plan Settings>Change advanced power plan settings - I found through the settings an item called Power settings of AMD graphic card (maybe wrong translation)>AMD Powerplay settings - On Battery was set to Enhance battery life and Plugged was set to Enhance Performance (mind translation errors). Curiously, enhance performance makes the CPU usage go to the roof and Radeon GPU usage drop to minimum. Changing config from both (on battery and plugged) confirmed it. It works like a switch both if I plug or unplug the AC adapter or if I alternante settings DURING video encoding. The performance of processor and GPU change immediately. I assumed that an enhanced battery life, in this case, means use less CPU (more power consuming?) and more GPU (less power consuming?).

 

Also I noted a difference between Intel and Radeon GPU usage when both are required. Intel processes 3D and copy, while Radeon does computing.

 

Bottom line: (1) Setting Premiere to Highest performance in Intel Graphics Control Panel and (2) setting AMD Powerplay (in advanced power plan settings) to enhance battery life triggered some usage of Radeon GPU while exporting video.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 12, 2019 Sep 12, 2019

Copy link to clipboard

Copied

I was using window 7 machine with Premiere pro cc 2018 and that machine had no graphics card, but when I migrated to window 10 with a different machine with NVDIA graphics card, with same software version  Premiere pro cc 2018 and opening old premiere files on this every time I am facing the crash issue. and whenever I am choosing the integrated graphics option in NVIDA  graphics setting the old files working fine but with NVIDIA Auto Global setting or high end setting not supporting, switching to these options I am again getting the crash issue.

For working on old file i have to switch to interrogated graphics option which is very annoying. is there any way to get rid of this.

 

If anyone has a solution for this please help.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 29, 2019 Sep 29, 2019

Copy link to clipboard

Copied

Lalit,

Sorry for this issue. See if this remedy from another user might work:

 

  1. Go into the Windows 10 Graphics Settings & set the graphics for each app you need to High Performance.
  2. Photoshop, Lightroom & Premiere Pro are now working consistently for me.
  3. In PP you will still get the System Compatibility error message at startup & you do need to have this following option set: File> Project Settings> General> Renderer> Mercury Playback Engine GPU Acceleration CUDA.

 

Let us know if that helps.

Thank You,
Kevin Monahan

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 07, 2019 Nov 07, 2019

Copy link to clipboard

Copied

Hi,

 

I was suffering from this problem exporting gameplay and the export time was over 8 hours and I searched everywhere on how to reduce export time and came to know about GPU rendering. So, I will clear you out 1st, I found out that software uses CPU/Integrated GPU only if the effects on your video does not use GPU acceleration. But if you have any effects on your video that uses this feature then search and turn it on. But if it does not then it will use CPU no matter what. I was using RSMB on my CODM video. After turning the GPU acceleration checkbox, my render time was reduced by almost 10 times. So, please check if you have any effects. 

 

Note: Simply color corrections, transitions, audio effects won't use GPU unless it has that feature.

 

I hope it helps you. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 12, 2019 Nov 12, 2019

Copy link to clipboard

Copied

So this is obviously a pretty long thread, so TLDR... but from what it seems is that Adobe Premiere simply doesn't use GPU over integrated graphics... for whatever reason.

Literally all my other graphics and creative apps use my Quadro RTX 5000 card on this laptop.. except Adobe. So can an Adobe representative explain why exactly? It just boggles my mind that this $4,000 creative laptop spits out 4k Premiere Pro videos almost the same amount of time that my $1,000 laptop does.

Even Firefox is utilizes my GPU over the Integrated when *I specify* it to.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 12, 2019 Nov 12, 2019

Copy link to clipboard

Copied

Hi there,

 

After banging my head in numerous forums regarding the same issue, I believe I have come across the solution or rather a discovery.

 

First of all, are you having any performace lag while doing this or are you just curious about the values showing up in task manager?

I ask this because, it always bothered me even if the performance was okay.

So, Adobe is getting a lot of trash for this issue while in actuality, it seems to be a Windows problem, at least for me.

As it stands, the task manager is inaccurate.

I realized this while undervolting my cpu and by sheer luck working with HW monitor which showed awesome gpu usage values while using premiere pro. To cross check I also ran GPU-Z and showed results closer to HW monitor while task manager's value was way off.

 

So, I suggest to use some reputable third party monitoring tools to see if it is using the GPU.

 

Adobe is getting a lot of crap for this issue while it was windows fault. But again it is really disappointing that Adobe wasn't able to discover this.

Hope this helps and please let us know.

 

Cheers.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 17, 2019 Dec 17, 2019

Copy link to clipboard

Copied

After having some issues with the new Premiere options, in my case, my Motherboard is kinda old so the Intel Integrated one was not compatible with Premiere and it was giving me an error message. My GPU is an Nvidia RTX 2080, so what was the deal?

 

I read some comments and checked out my pc spects using HWinfo software. It was showing two GPUs, the Intel as the first and Nvidia as the second one. Knowing that I tried to find a way to change Premiere main GPU on windows and even on Nvidia Control Panel. It did not fix it.

 

The last thing I did was to get into my BIOS and look to find a way to change this priorities. I couldn't find it but I found a setting showing:

Intel Processor Graphics: ENABLE

After disabling it, voilà, Premiere loaded without any problems.

Hope that helps you guys.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Dec 17, 2019 Dec 17, 2019

Copy link to clipboard

Copied

Just disable the Intel GPU in BIOS

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 09, 2020 Mar 09, 2020

Copy link to clipboard

Copied

  • The iGPU assisting encoding is actually the correct behavior for exporting HEVC and H.264 files.
  • The iGPU uses a technology requested by users for some years now: Quick Sync technology.
  • Quick Sync speeds up the decoding (assisting playback) and encoding (assisting exporting) for H.264 and HEVC files. 
  • Quick Sync technology is found only on Intel CPUs. There is currently no equivalent for AMD CPUs.
  • The discrete GPU assists the CPU for certain effects processing (scaling, color space, frame rate changes, etc.) and accelerated GPU effects, no matter the format.
  • If the discrete GPU is not functioning on export, it only means the iGPU (or CPU) is doing all the encoding work and the GPU is not currently required (perhaps there is no effects processing required nor GPU accelerated effects applied)—which is quite common, actually.
  • The discrete GPU does not assist the encoding of files whatsoever, it only works with effects processing and GPU accelerated effects. It should work in tandem with an iGPU if working with H.264/HEVC files that require effects processing or have GPU accelerated effects applied.

 

So, do not worry, Your system is just fine. Don't go crazy trying to disable the iGPU if H.264 is your target. You want that working and do not want to disable it if you export H.264 or HEVC.

 

Thanks,
Kevin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines