Premiere Pro using Integrated and not Dedicated Graphics Card

Explorer ,
Nov 13, 2017 Nov 13, 2017

Copy link to clipboard

Copied

Hello all, I have a quick, but important question about Premiere Pro CC 2018. It seems that Premiere Pro is using my integrated graphics on my CPU rather than using my installed and working dedicated graphics card to render GPU accelerated effects and such. I am running a fresh install of Windows 10 with the latest updates. I also have a fully updated Creative Suite. Below I have listed my system specs and screenshots for reference to the issue. Notice that under GPU Engine in Task Manager, it lists GPU 0, my integrated graphics. I have also done some research of my own, and I have come across adding the "cuda_supported_cards.txt" into Premiere Pro's installation directory. I have done that, and I have tried both typing "GeForce GTX 1060" and "GeForce GTX 1060 6GB" into the document, but its the same story for both cases: it uses my integrated graphics. The file currently lists "GeForce GTX 1060".

Thank for any and all help,

Ryan

System:

7th Gen Intel i7-7700K Processor (No current overclock)

nVIDIA GeForce GTX 1060 6GB

256GB M.2 SSD

2TB 7200 RPM HDD

16GB of 2400MHz DDR4 Memory

Windows 10 Pro 64-bit

Screenshots (Idle, Premiere Pro loaded and open, not rendering):

idle.PNG

idle 2.PNG

Screenshots (Premiere running, Rendering previews for a project of mine):

render.PNG

render 2.PNG

render 3.PNG

render 4.PNG

render 5.PNG

Text Document:

cuda.PNG

cuda 2.PNG

[Moderator note: moved to best forum for technical issues.]

TOPICS
Hardware or GPU

Views

334.5K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Employee , Feb 22, 2021 Feb 22, 2021
We created a video on how to optimize your GPU for Adobe apps here! Take it with a grain of salt, if you have an Intel GPU using QuickSync, you're best off using that GPU for H.264 and HEVC (H.265).  Caroline

Likes

Translate

Translate
replies 152 Replies 152
Adobe Community Professional ,
Nov 13, 2017 Nov 13, 2017

Copy link to clipboard

Copied

Do you have Mercury Playback enabled in the Project Settings panel? File/Project Settings/General?

Mercury Playback CUDA.PNG

And the whole CUDA supported list was from the CS6 days, a long, long time ago. Not used in years.

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 13, 2017 Nov 13, 2017

Copy link to clipboard

Copied

Yes. I have set that in both Premiere and in Adobe Media Encoder, both still use the integrated graphics.

playback engine.PNG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 13, 2017 Nov 13, 2017

Copy link to clipboard

Copied

For a desktop, you might go ahead and disable the onboard GPU. That 1060 would blow off anything the onboard can do.

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 13, 2017 Nov 13, 2017

Copy link to clipboard

Copied

I am using a desktop... however it is a Dell Prebuilt. As the mobo and BIOS/UEFI is just plain crappy and useless, there is no such option to disable it there. Do you know of another way to disable it?

Thanks,

Ryan

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 13, 2017 Nov 13, 2017

Copy link to clipboard

Copied

Back in the old days, one could disable the onboard graphics in the Device control panel, but that doesn't seem an option in Win10, so shiny new & improved.

Let's get Vidya Sagar​ or SAFEHARBOR11​ in here if possible ...

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 01, 2020 Jan 01, 2020

Copy link to clipboard

Copied

I have the same issue, but if I disable the onboard GPU, Premiere only allows me to choose Software Rendering despite having a dedicated graphics card running the latest drivers.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 27, 2017 Nov 27, 2017

Copy link to clipboard

Copied

I'm noticing the same thing with a 6700k and GTX 1080 on Windows Fall update.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 28, 2017 Nov 28, 2017

Copy link to clipboard

Copied

Do you think it is a Windows issue then? Thanks for your reply.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 26, 2017 Dec 26, 2017

Copy link to clipboard

Copied

Hi ,

Go to Nvidia control panel / under 3D setting / Manage 3d setting / Program setting tab /

Select a program to customize ( premier pro cc )

After that at the right bottom corner / click apply

Your Gpu gonna work try test render

Cheer !

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 28, 2017 Dec 28, 2017

Copy link to clipboard

Copied

I'm not sure where the "apply" button is at the bottom right corner. Below is what I see.

Capture.PNG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 28, 2017 Dec 28, 2017

Copy link to clipboard

Copied

In the CUDA - GPU's line, click on the setting section and see what is set. If it's listing both, see if you've an option to use the GPU only.

Neil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 29, 2017 Dec 29, 2017

Copy link to clipboard

Copied

rmthompson902 ,

You just need to change some setting . ( Apply ) buttom will appear .

And bare in mind that GPU will work fx feature rendering .

Some clip rendering  , still work with only CPU .

Untitled-1.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 29, 2017 Dec 29, 2017

Copy link to clipboard

Copied

Okay. I did know about how the burden of the render is on the CPU, but I guess I just figured the GPU would be used more during a render.

I did look under CUDA -GPU's line, but only my 1060 was listed, not the integrated graphics. So nothing was really changed there. I did hit apply.

I did do another test render, but the integrated graphics and CPU were definitely doing most of the work still. I guess I have to accept that I could have saved a buck and gone with a slightly lesser GPU, as I have learned that the CPU does most of the work.

Also, just out of curiosity, I did some more peeking around in Device Manager. For some reason, it now does list the integrated graphics under Display adapters, so there is a way to disable it as seen below. Is this still a viable fix?

Capture.PNG

Ryan

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 16, 2018 Jan 16, 2018

Copy link to clipboard

Copied

So, I haven't tested this myself, but I have had this problem with other types of software that could work so much better with dedicated graphics.

Go to the shortcut, and edit the Target of the shortcut and add the command

-force-opengl

to the end of the target, after the quotations of the shortcut location.

This will force OpenGL library to be used which can only be done by GPUs capable of of rendering 2D and 3D vector graphics, basically telling the integrated graphics that it's not going to work here.

Hope this helps

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 24, 2018 Feb 24, 2018

Copy link to clipboard

Copied

I have the same problem with my new Dell XPS 8930.  I tried all the suggestions listed here and other places.  None of them work.  Here is what I found:

  • Premiere Pro CC 2018 always use integrated GPU (Intel UHD Graphics 630).
  • If I disable integrated GPU, Premiere Pro CC 2018 will use CPU instead of GTX 1080.
  • Have both GPU enabled, there is no difference in setting CUDA in Project Settings in Premiere.  Choosing "Mercury Playback Engine Software Only" would still use internal GPU.

The games are running fine with GTX 1080 on my machine.  I think this is a problem with Premiere Pro CC 2018.  Looks like Premiere is not compatible with GTX 1080.  I sincerely hope Adobe can fix it!

Here is my system:

8th Gen Intel i7-8700K Processor (No overclock)

nVIDIA GeForce GTX 1080 8GB

1TB M.2 SSD

2TB 7200 RPM HDD

64GB of 2400MHz DDR4 Memory

Windows 10 Home 64-bit

Screenshot_022418_075323_AM.jpg

* When both GPUs are enabled.

Screenshot_022418_081438_AM.jpg

* When internal GPU is disabled.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 24, 2018 Feb 24, 2018

Copy link to clipboard

Copied

The exact same thing will occur even if you have an older GPU that's on the "recommended" list.

And since CC 2015.3, when the bug-ridden switchable graphics support was removed, Premiere Pro will now only support GPU0, and will only support GPU1 if it's exactly identical to GPU0 if GPU0 is an OpenCL GPU that doesn't support CUDA. Unfortunately, GPU0 in that system is the integrated Intel graphics – and in that case, no other GPU can be used at all in the same system for GPU acceleration, as far as Adobe is concerned. The suggested fixes for this problem do not work in all systems (specifically, it worked on some but not all systems).

Further complicating matters is that the big-name OEMs offer absolutely no provision whatsoever to disable the integrated Intel graphics (or put it this way, the setting for the integrated graphics is permanently locked at BIOS/EFI level to "Always Enabled"). This means that a driver for the integrated graphics MUST be installed for Windows to even function properly. Unfortunately, this needlessly complicates things for Adobe, which requires its software to always look at GPU0 first, and then stop detecting and reject another company's GPU if an already-primary non-CUDA GPU has been detected. As a result of that, Adobe software will only use OpenCL or software only.

If this were your own PC build rather than a prebuilt, the BIOS/EFI setting for the integrated Intel graphics is by default set to "AUTO", which means that it depends on whether or not something is connected to the video-out port(s) that is/are associated with the iGPU to enable or disable the iGPU. "Disabled" means that the iGPU will always be disabled even if you have anything at all connected to it. "Enabled" means that it will always be enabled even if you have nothing whatsoever connected to it.

Randall

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 25, 2018 Feb 25, 2018

Copy link to clipboard

Copied

I think this is a bug in Adobe applications.  It should be very easy to detect internal GPU and external GPU in C++ or Java code.  All game applications do that.  As a matter of fact, Adobe's own GPUSniffer detects that too.  But Premiere Pro CC 2018 ignored the results of GPUSniffer or it simply doesn't work with GeForce GTX 1080.  As you mentioned, it doesn't work with older GPU that's on the "recommended" list either, so this must be a bug in deciding which GPU to use in Premiere Pro CC application.

Screenshot_022518_080259_AM.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Nov 10, 2018 Nov 10, 2018

Copy link to clipboard

Copied

On my new Dell XPS15, which has both integrated and NVidia graphics, there is a setting in the "display" section under "Graphics" called "Graphics Performance Preference".

This was originally set at the default Intel 630.  You are able to choose apps to set individual preferences - PPro in this case. Add this and click on Options, followed by High performance - The GTX graphics then appears in the list.  Save this setting.

Note that the "with Max-Q Design" where it occurs is an essential part of of the GPU name if CUDA_Supported_cards is used.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 10, 2018 Nov 10, 2018

Copy link to clipboard

Copied

Is this a Laptop setting?  I don't see it under "Windows Settings".

The "Max-Q Design" appears to be specific to Laptops.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 18, 2018 Nov 18, 2018

Copy link to clipboard

Copied

I'm having most of the problems your all talking about, GPU not used at all and sometimes the wrong GPU used. Just discovered a problem in Lightroom tonight after the latest app installed, seems the 1070 card is no longer supported at all even in Lightroom and no way of using it's GPUs for PremPro and AfterEffects according to support 10 mins ago. Makes my Alienware laptop pointless.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 28, 2018 Nov 28, 2018

Copy link to clipboard

Copied

I believe that that behavior is due to the fact that recent versions of Premiere Pro cannot have OpenCL support disabled at all even if CUDA support is enabled; because of this, Premiere Pro's MPE will heavily favor the significantly weaker of the two GPUs (in this case, the integrated Intel HD or UHD Graphics). The only way to completely disable OpenCL support would be to set the renderer to the "software only" mode, which disables both renderers.

Therefore, we really need to have the GPU selector feature in a future release.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 03, 2018 Dec 03, 2018

Copy link to clipboard

Copied

Hi all,

I am using my Dell Inspiron 7000 Gaming (matching GPU/CPU/memory specs to OP) and have been having the same issue with a very large video.
I've loaded the project into Media Encoder cc 2019 and it renders it well along with only using the GPU/GTX1050

Hopefully this can help a few people out for the time being.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 03, 2020 Jan 03, 2020

Copy link to clipboard

Copied

I'm in the same boat. Such a horrible thing. What a waste of money to upgrade to an amazing GPU when Premiere, for 2+ years won't recognize it. Horrible. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 07, 2020 Mar 07, 2020

Copy link to clipboard

Copied

I have solved the problem so that it uses the correct GPU, first you need to right-click the start menu and go to Device Manager, From there select "Display adaptors".  Within "Display adaptors", it should show the two GPU's select the integrated graphics card and right-click it and select "Uninstall device".  The system will need to reboot but now Premiere Pro will only have your prefered graphics card to select from.  This has solved all the issues for me.  Hope this helps.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines