• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

x264 Plug-in For Premiere Pro

LEGEND ,
Jun 19, 2012 Jun 19, 2012

Copy link to clipboard

Copied

A new plug-in for Premiere Pro has been released that uses the x264 encoder to export to H.264 and H.264 Blu-ray.  I've had a chance to use it a fair bit, and the quality is excellent compared to Premiere Pro's built-in MainConcept H.264 encoder.  It's also fast -- as fast as the Premiere Pro plug-in architecture will allow.

Details here:

x264 PRO | Adobe Creative Suite H.264 Encoder

Disclaimer: As a beta tester for this plug-in, I received a license for x264 PRO as a gift.  But I wouldn't announce the plug-in here if it didn't deliver it's promised quality.

Jeff

Views

91.6K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 17, 2014 May 17, 2014

Copy link to clipboard

Copied

Were you trying to queue an export from Pr?  At least one recent version of Premiere Pro (CC or CS6 or both) would call the 32-bit version of the Adobe Media Encoder instead of the 64-bit version of the AME.  The solution is to move, rename or delete the 32-bit AME .exe file.  When Pr can't find it, it switches to the 64-bit version.

EDIT: It was CS6 where I first encountered this bug.  Further, the shortcut to the AME that is created in your Start Menu when you install Premiere Pro also points to the 32-bit version of the AME, so this issue may appear even if you're not queuing the export from Pr.

EDIT AGAIN: You may have to go as far as removing the entire Adobe Media Encoder CS6 folder from the Program Files (x86) folder.

Cheers,

Jeff

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 17, 2014 May 17, 2014

Copy link to clipboard

Copied

Hi! Thanks for your help! Using CS6

The problem was that the menu shortcut will start only the 32bit version.

and what i've done before:

C:\Program Files\Adobe\Adobe Media Encoder CS6\Plug-ins\Common\3am Digital Studios

copy both files from the 3am Digital Studios directory into the common directory above (i wonder because all other plugins are in this common directory).

Now it seems to be working

(when is start AME alone)

BTW: strange idea that the shortcut is only for the 32-bit version.

Edit: ah now i see whats the problem too (as you said) - in AP 64bit starts only the Adobe Encoder with 32-Bit (how strange)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 17, 2014 May 17, 2014

Copy link to clipboard

Copied

I found a way to solve the problem:

rename:

C:\Program Files (x86)\Adobe\Adobe Media Encoder CS6

to:

C:\Program Files (x86)\Adobe\Adobe Media Encoder CS6_old

create a new (empty) folder Adobe Media Encoder CS6


Download this Symlink Tool:

symlinker - Symbolic Link Creator. GUI for mklink, Microsoft Windows symlink utility - Google Projec...

run as admin and enter the following in the picture (right side):

http://abload.de/img/2014-05-17_20-21-20xrkum.png

then press "create link" button -ready!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
May 17, 2014 May 17, 2014

Copy link to clipboard

Copied

Hi all,

To get the 64bit version of AME to run launched from PPro or AE I simply delete the 32bit version - it shouldn't be there anyway.

There is really no point uninstalling it "somehow" because it's a broken configuration, deleting it simply removes all the hassles.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 17, 2014 May 17, 2014

Copy link to clipboard

Copied

Thanks, its easier then my way

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 28, 2014 Jul 28, 2014

Copy link to clipboard

Copied

I'm trying to install this with Adobe Premiere CC 2014 getting an error stating the following:

Installation Error: Didn't auto-detect any Adobe installations. Please email support@3amDigitalStudios.com for instructions to manually install the plug-ins.

I tried copying the plugins form the older Adobe CC but still it fails to work.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 04, 2014 Oct 04, 2014

Copy link to clipboard

Copied

Guys, don't be giving your money away that easily. I've done my own tests and found out that x264 PRO for Premiere is a perfect example of overhyped product. I was really excited to find out someone turned x264 into a Premiere plugin, so I decided to give it a try. Sadly, after a few tests I realized this plugin is a total waste of time. First of all, it's much slower than MainConcept H.264 codec, found in Adobe CC package, and I honestly don't see, how it's better quality-wise. Secondly, it creates more artifacts than original x264 freeware codec. And thirdly, it shifts colors of the material you are encoding. I don't see why anyone would spend 299$ for this thing.

But, I won't waste your time babbling unsubstantiated statements. Alllow me to present you some actual figures. I've converted my recent 12 minutes 12 seconds long 1080p project (STARS Academy at the 18th WCOPA Event on Vimeo) using Adobe Media Encoder CC 2014 v8.0.1.48 (MainConcept and x264 PRO codecs) and MediaCoder v0.8.32.5660 (x264 original codec). The Vimeo version is reduced in quality and size, of course. My conversions were made from nearly lossless Full HD material. All codecs were set to 12 Mbps target bitrate, 24 Mbps maximum bitrate (except original x264, which didn't offer max bitrate setting), High profile, VBR 2-pass encoding, AAC 256 kbps audio. Both x264 codecs were set to Film picture tuning and Very Slow encoding quality, because I wanted to see the best possible result that I can squeeze out of each codec at a given bitrate. Timewise, the results are:

1) MainConcept = 0 hours, 32 minutes

2) x264 original = 1 hour, 34 minutes

3) x264 PRO = 2 hours, 5 minutes

Original x264 completed conversion 25% faster, then x264 PRO, while Adobe's MainConcept implementation did it almost 75% faster! Of course, if I would have set x264 encoding quality to Medium, the difference wouldn't be so substantial. But wait till you see, how these encodes differ quality-wise. Seriously, after comparing the 3 results side by side I became a fan of Adobe's native H.264 encoder. It's super-fast, and it does a great job of preserving fine lines and keeping artifacts to minimum. It does so at a cost of some details becoming washed off. If we are to compare original x264 vs MainConcept, there is room for discussion, which coded and under what circumstances is better. But if we are comparing any of these two against x264 PRO by 3am Digital Studios, the answer is obvious to me. There is nothing about x264 PRO that makes it a winner. It's slow, it shifts colors pretty bad, and it's an excellent artifacts generator.

Let me show you. The following are 100% magnified 720p crops from the 1080p material. In each comparisson I got 10 screenshots that I picked randomly. They're all compressed to nearly lossless JPEG (you wouldn't be able to tell the difference between the original and Photoshop's Save for Web Quality 80). So, just move your mouse cursor over each screenshot to see, how codecs performed against each other.

MainConcept (32 min) vs x264 PRO (125 min)

http://screenshotcomparison.com/comparison/94302

x264 original (94 min) vs x264 PRO (125 min)

http://screenshotcomparison.com/comparison/94303

MainConcept (32 min) vs x264 original (94 min)

http://screenshotcomparison.com/comparison/94304

Obviously, Adobe's MainConcept H264 codec is great. However, I do agree to the common opinion that x264 is a better choice. Even, when I switch it to Medium quality, it takes 34 minutes to encode, while the resulting picture still has more details then MainConcept's result. At the same time there are no ugly encoding artifacts, such as those from 3am Digital Studios implementation. 3am developer(s) should do a better job implementing x264. At the moment it's a waste of time and money.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 30, 2014 Nov 30, 2014

Copy link to clipboard

Copied

Kiukaichi,

we here at 3am Digital Studios respect your opinion however here are some facts you have omitted from your post

1: Quality takes time - x264 is slower to encode than MC. The x264pro Draft mode is approximately the same quality and encode time as MC. Any other comparison is not equal.

2: Adobe Media Encode serves up frames very slowly and often makes mistakes about the colorspace of the Sequence - that is why there is a rec601/rec709 override.

3: Encoding to a lossless DI and then manually converting it with the x264.exe is slower and requires technical knowhow vs the plugin.

4: The plugin uses the v129 x264.exe (renamed x264_PRO_video.exe to make sure the right one is used) so any difference you see is encoding setting differences only.

We have MANY customers, including extremely large media corporations that depend on x264pro every day. I'm sorry that for your scenario it doesn't fit.

3am Digital Studios.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 12, 2014 Dec 12, 2014

Copy link to clipboard

Copied

Edward,

You never answered my e-mails once I presented my facts and comparisons. But I figured people deserve to know the truth, because no matter what large media corps your have among 3am Digital Studios customers, they obviously don't spend too much time testing quality of a codec. I think, for many just seeing "x264" in product's title, or to read impressive commercial texts, is a good enough reason to make up their mind.

I will comment each of your points:

1: If the quality of your codec in its best quality produces more artifacts than MainConcept, what's the point to mention your codec in its draft quality? Yes, it's true that speed-wise you will be equal to MC, but quality-wise - it will be a mess (not even close to "approximately the same quality", as you say). And, as you know, I have video clips to prove that: Download - Inbox Files. The 2nd and the 3rd file, which took same time to encode, compared against each other on Premiere's timeline with 100% magnification show the obvious difference between the two codecs. Also this test reveals another problem that Premiere decodes your files starting only from third frame, which makes them appear two frames short and desynced. So, to make a comparison, x264 PRO clip has to be dragged 2 frames to the right.

2: I don't have clarity about the colorspace thing to comment on that, but I just noticed that for some reason the encodes I made with your codec found under download link in the above paragraph do not have this shifted colors problem, while encodes I made of the full clip, had it. I was encoding from the same CineForm source, so I'm puzzled about why one encode ended up in true colors, while other - in shifted. But I'm not gonna investigate that since the my main disappointment about x264 PRO consists of artifacts and blurriness. It's nice to know, though, that you can somehow avoid shift of colors.

3: This depends on how you encode. It's a known fact that the best quality squeezable out of any AVC codec comes from 2-pass encoding. If, say, you have bunch of effects applied in your project that slow it down (for example, Neat Video for noise reduction, which will drastically reduce a speed of render), 2-pass will mean rendering that "heavy" project twice. So, it may actually be that rendering it in 1 pass to a near lossless codec, such as CineForm or DNxHD, and then encoding this "light" file in 2 passes would be faster than waiting for the "heavy" 2nd pass to finish. Plus, if something turns out to be incorrect in the output file, let's say a glitch in the middle of your project, you don't have to reencode the whole thing to fix that small part. So, to me encoding to CineForm or DNxHD and then to H.264 is the way to go.

But, if we do talk about direct encoding to H.264 via plugin, then certainly MainConcept, built into Adobe's Media Encoder and Premiere, is the way to go, proven by my tests. If someone insists on the best possible quality, then freeware MediaCoder (not to be confused with Media Encoder) with latest x264 included is the way to go. Either you encode into CineForm and then drop these files to MediaCoder, or you can can actually make a direct connection between Adobe (Premiere or Media Encoder) and MediaCoder via the freeware DebugMode FrameServer plugin. It requires a bit of technical knowledge, but really not much. Once DebugMode FrameServer is installed, you can choose it from the codecs list. Exporting to it creates an empty file, which you can drop to MediaCoder and finish exporting to the latest x264. This will produce maximum quality possible up to a bitrate of 16 mbps, which is a limitation of MediaCoder's free version. In case someone wants to try it, I'll give a quick tip about MediaCoder's settings:

  • Video tab: any bitrate you want up to 16000, Rate Mode - 2-pass, Preset - Slow
  • Audio tab: Format - LC-AAC, Rate Mode - CBR, Bitrate/Quality - 256 (you can go with Target Quality 50, but in my experience CBR bitrate is less subject to desync, when played back on various devices or re-compressed in YouTube)
  • Container tab: Container - MP4
  • Picture tab: press the Resize button, change Scale algorithm to Lanczos, close that window, and if you need to downscale or upscale your video, put a tick next Resize button and choose your size.

4: Sorry, didn't get that one. 😃

My main question is: tell me, 3am Digital Studios, if your codec is an implementation of original x264, how come the quality of it differs so noticeably? I can understand the speed problem could be due to mentioned Media Encoder serving up frames very slowly, but what about the compression? I mean just look at that: http://screenshotcomparison.com/comparison/94303. Roll your mouse over each of these 10 stills, compare the encodes I made under download link above and tell me, how can anyone possibly make a grand quality encode with x264 PRO, when even at 12 Mbps we get this kind of artifacts?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 08, 2015 Apr 08, 2015

Copy link to clipboard

Copied

Well, why not use the TMPGEnc x264 plugin then, at a fraction of that price (way too high). It seems it is even more configurable and TMPGEnc (Pegasys) are more than well-known creators of excellent software. Only drawback, it's Windows-only.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 09, 2015 Apr 09, 2015

Copy link to clipboard

Copied

Good tip. Did not know it was sold seperately.

I frameserve to TMPGenc Video Master which now has the x.264 codec.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
May 11, 2015 May 11, 2015

Copy link to clipboard

Copied

On those screen shot comparisons, I prefer the Adobe encodes.

I've been using AME over CinemaCraft encoder about late 2007, when I discovered AME was sharper and more detailed and CinemaCraft was softer and just an overpriced CODEC. So I dropped it and haven't looked back since.

Well, recently, I started beta testing NVENC, and, after tweaking, I must say, I'm impressed with the quality, aside from it being 11X faster than software. Even at 20mb/s, it's really hard to see artifacts that aren't there with AME at 40mb/s. I've dones some 5mb/s encodes for Youtube uploads that look amazing for the low bitrate. The resulting files are variable bitrate and drop nice and low when scene detail is low, while surging high for fast motion or high frequency details. VLC Media Player now has a nice statistics screen with a realtime graph, that shows the bitrate and trend.

For rendering quick window dubs, NVENC is my tool of choice now.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 02, 2015 Aug 02, 2015

Copy link to clipboard

Copied

If you really need x264 for Premiere and Media Encoder, then TMPGEnc Movie Plug-In AVC for Premiere Pro is the way to go. I've just discovered it and I am pleased to find it doesn't have all the drawbacks of x264 PRO codec by 3am Digital Studios. It creates normal files that are well read from start to finish. It preserves colors well. And it has all the endless settings of x264 that you can finetune. Very good implementation.

It's not as fast, as Premiere's native codec, but I found it to be better at preserving overal detail. For example, it can preserve noise patterns in a better way then Adobe's H.264, but this will be at the expense of speed of encode and may be at expense of detail of important objects, such as, for example, lecturer's face on the noisy background. The background noise will be great, but the face will be a little more blurry and less detailed than if you would just use the Adobe's H.264 codec.

So, do you own tests and decide, in which situation which codec does a better job.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Aug 23, 2015 Aug 23, 2015

Copy link to clipboard

Copied

I can also vouch for giving TMPGEnc a go (TMPGEnc Movie Plug-in AVC for Premiere Pro). Adobe AME was giving me artefacts on a frickin 15mbps 1-pass video with just text and static background. TMPGEnc rendered the same video with no noticeable problems and at less than half the size.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 12, 2015 Nov 12, 2015

Copy link to clipboard

Copied

Finding out about x264 Pro here, I thought I would give it a try. It took a few days to get the link to download the trial. Unfortunately their codec just don't work on my system (MacOS 10.8.5, Adobe CC 2014). Whether I make an export within Premiere or in AME, it crashes straight away. Same happens whether I select x264 Pro or x264 Pro BD. This thing just don't work on my system!

As any customer would do, I sent a couple emails to the company for enquiries/tech support. Several days later… not a single word from them. I have no clue why their thing doesn't work and obviously they don't give it a s...

The only thing I did hear from them was that their codec is top notch and the very best thing on the market. But they don't seem to care that it's not working at all for some users!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 20, 2015 Nov 20, 2015

Copy link to clipboard

Copied

HI

I'm trying to use the x264pro encoder on a Mac with OSX 10.9.5 and CS6 but after installing it doesn't show up in the list of formats - either in Premiere or AMC. Apparently it's something to do with CS6 using the 32 bit version and not the 64 bit. 3am have been hopeless in providing support - anyone know how to fix this - deleting the 32 bit version? How?

Thanks

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 20, 2015 Nov 20, 2015

Copy link to clipboard

Copied

On Windows, you delete this folder:

C:\Program Files (x86)\Adobe\Adobe Media Encoder CS6

I don't know exactly where that is on a Mac, but I'd start in your Applicatons folder.

NB: On Windows, the proper 64-bit version is in the C:\Program Files\Adobe\Adobe Media Encoder CS6 folder.  Notice the missing (x86) designation in the proper folder path.

Cheers,

Jeff

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 20, 2015 Nov 20, 2015

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 20, 2015 Nov 20, 2015

Copy link to clipboard

Copied

Thanks Jeff.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 20, 2015 Nov 20, 2015

Copy link to clipboard

Copied

Thanks. I'll dig around in the OS - what could possibly go wrong?!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 20, 2015 Nov 20, 2015

Copy link to clipboard

Copied

Not sure this will reassure you, but I am running CC2014 and x264 pro ain't working at all. Every single time I either select x264pro or x264pro BD, it crashes immediately upon launching the job in AME.

I emailed 3am… several emails with as much tech info/spec details I could provide in order to help them identify the issue. Not one answer!!… until I posted on this forum then I got an email from Edwards in the following couple hours (go figure!).

This is the answer I got (see below). This might help you.

As far as I'm concerned, nothing I could do on my side to make it work.

What a stunning tech support indeed. Basically I understand that it happens their codec won't work and there is nothing they can do about it. It's just due to the way Adobe works with plugins.

This is the worst trial of any software related product I have ever experienced… and totally gave up on keeping hope to try their codec.

For info, there is nothing wrong with my input footage. I just had to use the factory x264 blu-ray codec and it worked like a charm. Maybe not the best codec, but at least it works.

"It happens when there is something wrong with the input footage or a bug in a plugin. We've seen it for years and asked Adobe to fix it. Unfortunately their plugins don't show the error because they have a different way they plug in to the program vs the partner/vendor way. It's often fixed by deleting the project cache and any xml sidecar files (xmpses)."

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 20, 2015 Nov 20, 2015

Copy link to clipboard

Copied

Hmm... doesn't bode well - I'll percivere for a while but thanks for the info.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 19, 2015 Dec 19, 2015

Copy link to clipboard

Copied

As mentioned in previous posts, x264 never worked on my system during the trial period. Now the trial is over I get an error message every single time I launch either Premiere or AME, so I want to uninstall the plugin (x264 Pro and x264 Pro BD). Unfortunately I could not find any useful info how to properly uninstall this on MacOS (the user guide shows there is an uninstall app for Windows, but no info for MacOS).

If someone knows how I can uninstall this from my system, I would highly appreciate.

Thanks very much!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 04, 2016 Jan 04, 2016

Copy link to clipboard

Copied

SPOTS, here's how to delete the trial if you haven't figured it out (or for anyone like me who was plagued by error messages with no obvious way to uninstall): You have to find the 3am digital studios folder (in the folder "application support" in your Library, but since the folder has now vanished from my computer I can't remember the exact name). Inside that folder are several files—find the script that is something-uninstall.sh. Drag that file into a Terminal window and press enter. It will ask for your password. Type in your password and press enter. That should do it (at least that worked for me).

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 05, 2016 Jan 05, 2016

Copy link to clipboard

Copied

LATEST

I had this same issue and Jahwar found the same solution I did.  The script was in my /Applications/x264pro_Utilities/ folder and was named uninstall.sh.  Instead of the drag option, I was able to do the following:


  • Right click on the "uninstall.sh" file and choose "Open With"
  • Click "Other"
  • In the open file dialog, select "All Applications" instead of "Recommended Applications"
  • Choose Terminal from the Applications/Utilities folder
  • Click "Open"


This opens the script in Terminal and as jahwar mentioned, enter your administrator password and hit enter.  The password will only show a single curser character as you type, don't be thrown off as I was.  The password will be accepted even though in Terminal doesn't look like you are typing. 


It looks like I still have some clean up to remove some files including the uninstaller script, but at least the error messages have stopped.


Screen Shot 2016-01-05 at 7.45.29 PM.png

Screen Shot 2016-01-05 at 7.52.37 PM.png

Screen Shot 2016-01-05 at 7.52.55 PM.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines