Adobe PDF printer 'printing' garbage characters

Community Beginner ,
Mar 31, 2012 Mar 31, 2012

Copy link to clipboard

Copied

Acrobat Professional v9.5.0 (Acrobat reports there are no updates available)

Windows 7 Home Premium 64-bit

I print from various applications and web pages to my 'Adobe PDF' printer to save things as PDF files.

Over the last several months, I have begun to have issues with printing to my Adobe PDF printer. This issue happened twice just yesterday, actually.

I will be looking at a web page, and choose to print it to PDF (a purchase receipt for example). I supply the filename and choose to print, and Acrobat will bring up the newly created PDF and it will have garbage characters in various places.

If I try printing it to PDF again, I get the same results.

However, if I print the item to Microsoft XPS format, it works just fine and all the characters are readable.

I don't know what to do. I saw an article about embedding the fonts, but it appears that all the standard 'web safe fonts' are already set to be embedded in PDF files via distiller (if that is what is actually doing the printing to create the PDF). If I have to choose more fonts to embed into the PDF, it seems to be extremely difficult to determine what fonts are being used by each site or application and choosing them all manually to be embedded in the files.

Surely there has to be a simpler solution to this issue.

TOPICS
Create PDFs

Views

39.7K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

New Here , Apr 16, 2012 Apr 16, 2012
I too had this annoying issue, usually printing from https sites, although the site address may be coincidental.What worked for me was: Select Print In the print dialog box, select Adobe PDF and then Preferences. In the Printing Preferences dialog box the tab should be Adobe PDF Settings Uncheck the box next to Rely on system fonts only; do not use document fonts Select OK If the box is already unchecked, it might be caused by something similar. This worked so I went no further. I have not yet c...

Likes

Translate

Translate
LEGEND ,
Mar 31, 2012 Mar 31, 2012

Copy link to clipboard

Copied

Try changing the Settings to print or press. I suspect the characters you are having problems with are not embedding and you do not have them on your system.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 16, 2012 Apr 16, 2012

Copy link to clipboard

Copied

I too had this annoying issue, usually printing from https sites, although the site address may be coincidental.

What worked for me was:

    1. Select Print
    2. In the print dialog box, select Adobe PDF and then Preferences.
    3. In the Printing Preferences dialog box the tab should be Adobe PDF Settings
    4. Uncheck the box next to Rely on system fonts only; do not use document fonts
    5. Select OK

Preferences.jpg

If the box is already unchecked, it might be caused by something similar. This worked so I went no further. I have not yet checked to see if this must be done each time or how to make it default.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 24, 2019 Sep 24, 2019

Copy link to clipboard

Copied

LATEST

Same issue -I  use "Microsoft Print to PDF" as the printer and it works. Use the "Adobe PDF" printer and get garbage in the page as well as some proper text. Only issue with the "Microsoft Print to PDF" printer is that unlike the "Adpbe PDF" printer, it doesn't display the printed page - you have to go find it and open it.

It would be nice to have the "Adobe PDF" printer available.

The post by Bshiffor might work except that I do not get the dialog box he screen shot. Also using MS Edge, Windows 10, so this issue seems to have propogated.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines