• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Adobe Reader 10.1.3 uses max CPU when closed

Community Beginner ,
Jun 13, 2012 Jun 13, 2012

Copy link to clipboard

Copied

We're having the problem where Adobe Reader uses all of a CPU core when a user is closing the program but the .exe file is still running in the background.

We're running 10.1.3 and have been using that since it was released but the problem just recently started. It's running on top of Windows 2008 SP2 with Citrix XenApp 5.0 installed and using DFS.

The trick with denying the user access to the "cRecentFiles" in the registry don't seem to solve the problem.

Anyone who knows a way to solve this?

Views

52.9K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 14, 2012 Jun 14, 2012

Copy link to clipboard

Copied

We are experiencing this same exact problem, but with 32-bit Windows XP PC's.  Looking for a solution.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 14, 2012 Jun 14, 2012

Copy link to clipboard

Copied

Disabling the Welcome screen fixed this for us.

See http://acrobatninja.blogspot.com/2011/09/acrobat-and-adobe-reader-1011.html for details on the registry entry to use.  It is for 10.1.1, but worked with our 10.1.3.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 15, 2012 Jun 15, 2012

Copy link to clipboard

Copied

Our problem was the ReaderMessages files. For more info see this: http://forums.citrix.com/thread.jspa?threadID=308672

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 19, 2012 Jun 19, 2012

Copy link to clipboard

Copied

We are having the same issue on both Win7 64bit and XP 32 bit.  The ReaderMessage file seems to be the issue with incorrect entries in the file as mentioned on page 2 of the above mentioned Citrix forum link.  The issue happens by just opening and closing Reader from the Start - Programs menu.  When it's closed, acrord32.exe stays in memory using 50%+ CPU cycles.  Replacing with a good ReaderMessage file in the user's profiel seems to be a work around.

Anyone from Adobe have a root cause of how we can prevent this corruption so we can proactively stop this from happening on our PCs?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 19, 2012 Jun 19, 2012

Copy link to clipboard

Copied

I think I' ve got the solution to my issue.

http://help.adobe.com/en_US/reader/using/WS4bebcd66a74275c3-7d28390112a81b3ebff-8000.html

Adobe Reader 10 default install allows "Adobe to display in-product marketing messages while you work in the program".  When you launch Reader from start programs, the "open recent documents" window that shows during launch includes ReaderMessages along the bottom of the window.  These message are downloaded from Adobe and probably stored in the ReaderMessages file.  I'm guessing there is corrupt content in one of Adobe recent messages causing Reader 10 to stay in memory or use high CPU.

To stop the issue, we opened Reader and went to Edit - Preferences - General.

We unchecked the box that allows Adobe to "Show Me Messages When I Launch Reader" which is enabled on a standard install.  The first time after setting this option Reader still stays in memory using high CPU after closing it.  After ending the acrord32.exe from memory, Reader functions as expected going forward.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 20, 2012 Jun 20, 2012

Copy link to clipboard

Copied

I implemented the deselection of the "Show Me Messages When I Launch Reader" via a Group Policy logon script.  It's in a registry key (DWORD value) located here:

[HKEY_CURRENT_USER\Software\Adobe\Acrobat Reader\10.0\IPM]

Set/create the DWORD "bShowMsgAtLaunch" to 0 will do the trick going forward. Set/create the DWORD "bDontShowMsgWhenViewingDoc" to 0 as well.

I also delete the ReaderMessages file via the same logon script.  It is located on XP here:

%USERPROFILE%\Application Data\Adobe\Acrobat\10.0\ReaderMessages

and located on Vista/7 here:

%USERPROFILE%\AppData\LocalLow\Adobe\Acrobat\10.0\ReaderMessages

When the reset is implemented via Group Policy, the key gets reset back to 0 if a user messes with it.

Message was edited by: DJFEHRIB

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 21, 2012 Jun 21, 2012

Copy link to clipboard

Copied

If you have Adobe processes (AcroRd32.exe) showing in the task manager after you close the Acrobat Reader that use up a significant amount of processor speed.  This is what you can do to fix it. 

Basically the file that is used by the welcome screen (ReaderMessages) has become corrupted (that file is located here on Windows 7 C:\Users\%UserProfile%\AppData\LocalLow\Adobe\Acrobat\10.0.)   Deleting that file did not help on a long term basis, but by disabling the welcome screen it bypasses that file and will close normally.  Unfortunately Adobe does not have a built in way to disable the welcome screen but you can disable it by making a small addition into the registry.

  1. 1. Open the regeidt and navigate to
    1. a. HKLM\SOFTWARE\Policies\Adobe\Acrobat Reader\10.0\FeatureLockDown

  1. 2. Add the a key with the name
    1. a. cWelcomeScreen

  1. 3. Add a DWORD value to that key
    1. a. bShowWelcomeScreen = 0

It should look like this when your finished

reg.png

The welcome screen should not show when you open Acrobat Reader, and when you close the window the process should close with it.  If this fix does not work for you,  there might be something else causing your problem.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 22, 2012 Jun 22, 2012

Copy link to clipboard

Copied

Thank you.

We ended redoing our reader 10 MST transform file to include the follow keys to disable Reader marketing messages for new installs and we set the same keys on existing PCs in the environment.

HKEY_CURRENT_USER\Software\Adobe\Acrobat Reader\10.0\IPM] 

DWORD "bShowMsgAtLaunch" to 0

DWORD "bDontShowMsgWhenViewingDoc" to 1

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 14, 2012 Aug 14, 2012

Copy link to clipboard

Copied

Our users are having the same issues with Adobe Reader 10.1.3. All of the above (disable all messages, delete message cache, clear recent files and disable Welcome Screen) have been tried and work, but only temporary. After a week or two, the users have the same problem again. Did any of you experience the same behaviour, or does the above mentioned work as a permanent solution?

The only thing that seems to be a permanent solution for us is disabling the protected mode, which we don't want to do. I opened a support case for this, but without a support contract (which we don't have and which doesn't exist for Adobe Reader) they say they cannot help.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 14, 2012 Aug 14, 2012

Copy link to clipboard

Copied

We set both these current user registry keys on all existing computers under the user's context and have not seen any issues.

We also redid our MST to automatically set these registry keys for any new installs.

HKEY_CURRENT_USER\Software\Adobe\Acrobat Reader\10.0\IPM] 

DWORD "bShowMsgAtLaunch" to 0

DWORD "bDontShowMsgWhenViewingDoc" to 1

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 29, 2012 Aug 29, 2012

Copy link to clipboard

Copied

How can you set the Current User keys in the mst for new installs?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 11, 2012 Sep 11, 2012

Copy link to clipboard

Copied

My Regedit does not show Dword:

HKEY_CURRENT_USER\Software\Adobe\Acrobat Reader\10.0\IPM] 

DWORD "bShowMsgAtLaunch" 

DWORD "bDontShowMsgWhenViewingDoc"

But rather shows:

itestpopulation

itestsegemnt

Any thoughts on how to reset values wherein dword does not exist?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 11, 2012 Sep 11, 2012

Copy link to clipboard

Copied

Create them.

But I think you can create the same dword values under HKLM\Software\Policies\Adobe\Acrobat Reader\10.0\IPM and they will apply to all users.

The best way is to use the Adobe customisation wizard to create a transform.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 05, 2014 Feb 05, 2014

Copy link to clipboard

Copied

Hi,

Is somebody still seeing the issue?

Thanks,

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 20, 2014 Jun 20, 2014

Copy link to clipboard

Copied

Yes, I am. The fix(es) provided in this thread have not solved the issue. I created a new post to see if anyone could assist further.

My post

If you have any suggestions it would be greatly appreciated.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 10, 2014 Sep 10, 2014

Copy link to clipboard

Copied

Yes we are too, a couple of machines affected - Windows 7 32bit and 64bit out of 65.

Have gone through the tips here and testing now, these couple of users only see the problem once or twice a week on average.

Will be keeping up with both threads.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 05, 2015 Jul 05, 2015

Copy link to clipboard

Copied

This problem of 100% CPU utilization after closing Adobe Reader (.exe program persists and continues impacting all processes) is still occurring in version 11.0.11 on Win 7 OS.  Adobe can't fix it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 21, 2015 Aug 21, 2015

Copy link to clipboard

Copied

LATEST

Hi there. I've found this that solved the problem in my Windows 10 system:

High CPU usage by Acrobat after closing | Windows 8

The registry entry was path not exactly the same that the one described in the article, but it is very close.

Instead of

Navigate to the key: [HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers]

you should

Navigate to the key: [HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Compatibility Assistant\Store]

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines