• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Adobe ReaderX can not open sharing files on Server

New Here ,
Nov 21, 2010 Nov 21, 2010

Copy link to clipboard

Copied

As my title described, I installed ReaderX successfully, can open local pdf files on my computer ,but when I access files on share server, a popup message shows "There was error opening this files. Access dnied." Surely I have rights accessing those files.

Anybody can help me? Thanks .

Views

98.0K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

New Here , Nov 22, 2010 Nov 22, 2010

I have the same problem. It's apparently a result of the new Protected Mode. Disabling it via Edit--> Preferences-->

"Enable Protected Mode at startup" is a workaround and will allow PDFs to be opened from network shares. Of course that defeats the entire purpose of Adobe's sandbox architecture in X. For now though I don't see an option.

You can disable this through the registry via HKCU\Software\Adobe\Acrobat Reader\10\Priviledged\ by setting bProtectedMode to decimal 0. This can be done through

...

Likes

Translate

Translate
LEGEND ,
Nov 21, 2010 Nov 21, 2010

Copy link to clipboard

Copied

Surely I have rights accessing those files.

Why are you sure?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 21, 2010 Nov 21, 2010

Copy link to clipboard

Copied

I am the Administrator and I can open those files correctly with Reader9.4

Thanks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 21, 2010 Nov 21, 2010

Copy link to clipboard

Copied

Hello!

I have the same problem!

As I recognize this issue only happens with mapped network drives. If I use the UNC-Path directly to the same folder I am able to open the files.

Tried this with administrator and normal user rights.


First I thought it was a problem with hardlinks. But they work also if I use UNC-Paths.

Any help?

Best regards,

Manuel Jungmann

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 22, 2010 Nov 22, 2010

Copy link to clipboard

Copied

That's it!

it's a bug?

I'm preparing to deploy ReaderX in my orgnization, seems i should wait until find out a solution.

Thank you very much!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 22, 2010 Nov 22, 2010

Copy link to clipboard

Copied

Hi,

Can you please tell which OS or server you are using. Also is there any AntiVirus or firewall installed in your system? If so, which one?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 22, 2010 Nov 22, 2010

Copy link to clipboard

Copied

I do have exactly the same problem using Windows XP SP3 when opening PDF files from any network share.

It does not matter whether I use \\server\path\file.pdf  or access it via a mapped network share like  S:\path\file.pdf

I'm using Antivir, but disabling it makes no difference, Adobe Reader X always reports: "There was an error opening this document. Access denied."

I do have sufficient rights, I can open the same file in any text editor, I can modify and delete it.

Windows Firewall (built in) is active but does not block any shares (it also worked just a few minutes ago using Adobe Reader 9.X).

Thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 22, 2010 Nov 22, 2010

Copy link to clipboard

Copied

Hi,

Was there any other Adobe product installed prior to installing Adobe Reader X ( like Acrobat 9 )?

If so please check one detail in Edit -> Preferences -> General menu - 'Press on Select PDF default handler and see which Adobe product is the very first option in the dropdown list.'

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 22, 2010 Nov 22, 2010

Copy link to clipboard

Copied

Hi

Yes, there was a Reader 9.X installed previously (not uninstalled explicitly before installing Reader X but looking at its old install directory, it's empty).

The mentioned button produces a dropdown with just one entry: Adobe Reader X. Selecting it again and pressing OK and waiting for the installer to complete makes to difference. Still the same error

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 22, 2010 Nov 22, 2010

Copy link to clipboard

Copied

I can confirm this. I had Reader 9.4.3, which I uninstalled prior to installing Reader X. I'm running XP/SP2. There are no other Adobe products installed. I've confirmed that Reader X should be the default PDF handler (it's the only entry in the list, but I selected and applied to make sure).

I can only open PDF files on local drives (internal hard drives, external drives connected via USB) but cannot open PDFs from network shares, which do open if copied to a local drive. I've tried using both the mapped-drive and UNC name - no dice either way.

I added the relevant mapped-network directories to the Privileged Locations as well as the hostname of the machine which hosts the file share. Still no dice!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 22, 2010 Nov 22, 2010

Copy link to clipboard

Copied

I have exactly the same problem.

Using this on XP Pro clients in a Win2k8 domain. PDF's on shares will not open. PDF's on local drives will open. I had just updated all our clients - should have tested it first...

Have installed Foxit Reader until this is resolved.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 03, 2020 Aug 03, 2020

Copy link to clipboard

Copied

LATEST

this worked a treat, despite users setting a another version of adobe as default it seems a licensed version was causing an issue , set adobe reader as the default pdf handler from within the software and problem resolved 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 22, 2010 Nov 22, 2010

Copy link to clipboard

Copied

Yep, I'm running into the exact same problems.  I've added both the UNC and drive mapping to my trusted sites, however, every time I try to load a PDF from the network, i get the:

"There was an error opening this document.  Access denied."

If I copy the same PDF to my local machine (desktop, C:\ drive, whatever), I can open it without any problems.

I've tried disabling the Enable Enhanced Security from the Security (Enhanced) preferences, however it doesn't seem to do anything. Also the Privilieged Locations - Automatically trust sites from my Win OS Security zones is checked.  I've also tried adding the full path to the PDF under the Privileged Locations, however, it all results in the same error as above.

Hopefully this gets resolved in a timely manner, as I'd rather not have to downgrade back to 9.4.1.  I'm shocked that this 'bug' got missed by QA.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 22, 2010 Nov 22, 2010

Copy link to clipboard

Copied

We use DFS (Distributed File System). Accessing files (ex. \\abc.com\data\myfile.pdf) it failes with the same message. I can open files locally without any problem and I open them successfully if I browse to the UNC path of the share on the specific server (\\server1\data). The problem only occurs when trying to access the files from a DFS share. I have no problem accessing any other data on the DFS shares.

Need a fix ASAP!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 22, 2010 Nov 22, 2010

Copy link to clipboard

Copied

My apologies, I should have mentioned that we are using DFS shares as well.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 22, 2010 Nov 22, 2010

Copy link to clipboard

Copied

I have the same problem. It's apparently a result of the new Protected Mode. Disabling it via Edit--> Preferences-->

"Enable Protected Mode at startup" is a workaround and will allow PDFs to be opened from network shares. Of course that defeats the entire purpose of Adobe's sandbox architecture in X. For now though I don't see an option.

You can disable this through the registry via HKCU\Software\Adobe\Acrobat Reader\10\Priviledged\ by setting bProtectedMode to decimal 0. This can be done through group policy preferences and would be necessary for every user.

What I find interesting though is that I only have this problem on XP. My Vista and 7 clients seem to open files from UNC shares without any issues. Has anyone had a problem on the newer OSes or is this just a bug with Reader X on XP?

Thanks,

James

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 22, 2010 Nov 22, 2010

Copy link to clipboard

Copied

I only have XP with SP3 in the environments where I have DFS in place. It very well could be an issue with XP in this scenario.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 22, 2010 Nov 22, 2010

Copy link to clipboard

Copied

Disabling the 'Protected Mode' did resolve my issue as well. Hopefully a long term fix will be available soon.

Thanks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 22, 2010 Nov 22, 2010

Copy link to clipboard

Copied

I'm looking to disable protected mode on several workstations via a reg script as a temporary solution to this problem but it looks like the reg hack is a per user only.  Do you know if there is a way to globally change this setting so that the change is in effect for all users?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 22, 2010 Nov 22, 2010

Copy link to clipboard

Copied

If you're using Active Directory, you can push it out via Group Policy.  If your Domain Controllers are 2008, it's super easy:

Group Policy Management Editor

   - Pick a Group Policy that applies to all users or create a new one

   - User Configuration -> Preferences -> Windows Settings -> Registry

      Action: Update

      Hive: HKEY_CURRENT_USER

      Key Path: Software\Adobe\Acrobat Reader\10.0\Privileged

      Value: bProtectedMode

      Value type: REG_DWORD

      Value data: 00000000

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 22, 2010 Nov 22, 2010

Copy link to clipboard

Copied

This is excellent.

Thank you very much James.

Thanks all, everyone!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 02, 2010 Dec 02, 2010

Copy link to clipboard

Copied

I can confirm this behavior. On a Windows XP SP3 on a Windows network using DFS shares I cannot open pdf files stored on network drives that are available to all authenticated users. Turning off the sandbox eliminates the error.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 23, 2010 Nov 23, 2010

Copy link to clipboard

Copied

Solved it yesterday the same way, we're using Windows 2003 TSE Sessions.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 23, 2010 Nov 23, 2010

Copy link to clipboard

Copied

Although this identifies the problem, it does not help - why lower your network's security by disabling one of the main protective features of the reader?

I'll keep Foxit Reader installed on all the affected clients until this is properly fixed.

And, yes - I use DFS on the domain as well.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 23, 2010 Nov 23, 2010

Copy link to clipboard

Copied

I have the same problem. I unistalled AR9 prior to the ARX in

stall. Got error everytime I attempted to open a pdf f

ile on a server. I uninstalled ARX and reinstalled it with Antivir

us off. Did a computer restart. ARX still wouldn't open

pdf files on server. Unistalled ARX and reinstalled AR9

.4. Problem solved. We'll just use AR

9.4 unitl, if, they ever fix ARX.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines