• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Open a pdf directly in IE11 (ACrobat Reader VI, Windows 8.1)

Community Beginner ,
Sep 01, 2014 Sep 01, 2014

Copy link to clipboard

Copied

Hello!

We use Acrobat Reader, Windows 8.1 and IE11 in our company.

Unfortunately no user is able to open a pdf directly with IE11.

Instead of opening the pdf there is a popup which asked what to do with the pdf -open, save or saveas

I couldn't find a way to setup a default action (open)

In earlier versions it was possible to set the option "open in Browser".

This option is missing in AR11.

But why?

How can i set the deafult action?

thx

Views

36.7K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Oct 01, 2014 Oct 01, 2014

Hello together!

the problem was still there, so i decided to modify my search.

Fortunately i found a technet-post, which described our problem.

The following solution worked in our enviroment. PDF-documents will now be opened directly in IE11.

In Windows 7 (also Win8.1!!!!!), there is not the key AttachmentExecute by default. For this reason, Checkbox for "always ask before opening this type of file" is missing in the Download prompt window.
Actually, you can choose to add this key in your Registry b

...

Likes

Translate

Translate
Community Expert ,
Sep 01, 2014 Sep 01, 2014

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 01, 2014 Sep 01, 2014

Copy link to clipboard

Copied

Hi Gilad!

thx for your reply.

The addon is enabled, but before the pdf will be shown, you have to choose between open, save and saveas.

opensave.jpg

There is no checkbox to set open as default, so it seems to be a security feature of Internet Explorer 11.

Anyone else with this "problem" or any suggestions how to solve this issue?

thx in advance!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 02, 2014 Sep 02, 2014

Copy link to clipboard

Copied

found another user in this forum with the same problems:

Re: How do I make IE open PDF inside browser and not prompt?

but there isn't a answer to the problem....

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 02, 2014 Sep 02, 2014

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 02, 2014 Sep 02, 2014

Copy link to clipboard

Copied

I have no problems with html/htm/links. I can open everything.

I saw this problem today also with a *.tif, so it dont seems to be a problem with Acrobat Reader.

But unfortunately the most common files, the users like to view in our Intranet/on other sites are *.pdf...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 02, 2014 Sep 02, 2014

Copy link to clipboard

Copied

I tried posting the link "View as PDF".

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 02, 2014 Sep 02, 2014

Copy link to clipboard

Copied

Are you by any chance running IE as a metro app? Simple test, can you reduce the window size and see other windows?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 02, 2014 Sep 02, 2014

Copy link to clipboard

Copied

Hi!

No we run the DesktopVersion!

I hate the IE, but unfortunately not all Applications are designed for alternative browsers.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 01, 2014 Oct 01, 2014

Copy link to clipboard

Copied

Hello together!

the problem was still there, so i decided to modify my search.

Fortunately i found a technet-post, which described our problem.

The following solution worked in our enviroment. PDF-documents will now be opened directly in IE11.

In Windows 7 (also Win8.1!!!!!), there is not the key AttachmentExecute by default. For this reason, Checkbox for "always ask before opening this type of file" is missing in the Download prompt window.
Actually, you can choose to add this key in your Registry by following txt, Copy them to notepad, then renamed as .reg file. After that, import to Registry.

------------------------------------------------------

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\AttachmentExecute\{0002DF01-0000-0000-C000-000000000046}] 
" AcroPDF.PDF.1"=hex(0):

-------------------------------------------------------------------

Many Thanks to Roger Lu from the technet community support!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 01, 2014 Oct 01, 2014

Copy link to clipboard

Copied

Thank you for posting the solution to the problem!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 25, 2015 Feb 25, 2015

Copy link to clipboard

Copied

Hello,

we`ve IE11 and Adobe Reader XI on Win2k8r2 Terminalservers. The Key did not solve our problem. We want to open PDF`s not in a Browser Window. We`ve disabled the AddOn via GPO. Now the Users gets a prompt (open, save or cancel) but we want that our users can open PDF directly without prompt.

I`ve try the follwing keys:

[HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\AttachmentExecute\{0002DF01-0000-0000- C000-000000000046}] 
" AcroPDF.PDF.1"=hex(0):  // DWORD

[HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\AttachmentExecute\{0002DF01-0000-0000- C000-000000000046}] 
" AcroPDF.PDF.1"=no value  // Binary

[HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\AttachmentExecute\{0002DF01-0000-0000- C000-000000000046}] 
" AcroExch.Document.11"=hex(0):  // DWORD

[HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\AttachmentExecute\{0002DF01-0000-0000- C000-000000000046}] 
" AcroExch.Document.11"=no value  // Binary

Equal which Value or Key is set, everytime a promt to Save or Open the file appears. Any ideas?

Thanks and Regards

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 25, 2015 Feb 25, 2015

Copy link to clipboard

Copied

An other possibility is, PDF`s open in IE11 but in a new IE Tab, not in the same.

How can i implement this?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 19, 2015 Oct 19, 2015

Copy link to clipboard

Copied

I ran into this issue recently. I resolved it using the Adobe customization wizard, the setting can be found here:

adobe-cust-img (1).png

You can also set it after the installation using these registry settings:


Remove Open\Save Dialog

------------------------------------------------------

Windows Registry Editor Version 5.00

[-HKEY_CLASSES_ROOT\AcroPDF.FDF.1]

[HKEY_CLASSES_ROOT\AcroPDF.PDF.1]
"EditFlags"=hex:00,00,01,00

------------------------------------------------------

Add Open\Save Dialog

------------------------------------------------------

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\AcroPDF.FDF.1]
"EditFlags"=hex:00,00,00,00

[HKEY_CLASSES_ROOT\AcroPDF.PDF.1]
"EditFlags"=hex:00,00,00,00

------------------------------------------------------

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 20, 2015 Oct 20, 2015

Copy link to clipboard

Copied

mcdphit,

Thank you so much for sharing! I've been looking for a solution for ages now and didn't even think of looking there.

I ran into an issue importing the key btw since admins only have read-only permissions on the specific values but adding the key to a GPO solved that problem as well.

Cheers!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 11, 2016 Mar 11, 2016

Copy link to clipboard

Copied

Thank you so much!  This is exactly what I have been searching for.  Like notbebe, we had to add the key to a GPO, but it works beautifully.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 24, 2019 Oct 24, 2019

Copy link to clipboard

Copied

LATEST

Thanks for the solution! Confirmed this also works on Windows 10 (1809 Build 17763.805) , Adobe Acrobat Pro DC 2019.012.20034 with IE 11.805.17763

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines