Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


ASSET SHARING BUG: Copies of components are not downloadable on Share Link when marked for doanload

Community Beginner ,
Sep 08, 2020 Sep 08, 2020

Copy link to clipboard

Copied

Hi all.
I am experiencing a bug where I'd make a new instance of a component (just a colour change) and then I just drag a copy of that instance to the side so the 2 instances are next to each other. That copy is auto-checked as a Downloadable Asset.

 

All that said, when you check the newly updated link, the new instance does not appear as downloadable on the Assets list and clicking on it doesn't show a Download option.

 

THIS IS MY CURRENT SOLUTION:

In the doc, I just ungroup that instance and then regroup all it's elements again. Then Mark it for download and update the Share Link again. That fixes it.

 

BUT that said, just because there is this workaround doesn't mean the issue is fixed. Even if I uncheck the downloadable asset option on the new instance and then check it again, it still won't appear as such on the updated link. So clearly there is an issue here of XD not reconciling the new asset as downloadable.

TOPICS
Import and export, Known Issue, Product performance, Share or publish

Views

276

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Sep 14, 2020 Sep 14, 2020
Hi there, I have got an update from the team that the bug is already logged for this issue and they are investigating on it. You will definitely see improvements in the future releases of XD. Hope it helps. Thanks, Harshika

Likes

Translate

Translate
Adobe Employee ,
Sep 08, 2020 Sep 08, 2020

Copy link to clipboard

Copied

Hi there,

 

Thank you for reaching out and using Adobe XD. 

 

Sorry to hear you're having trouble with XD and thanks for sharing the workaround also. We would like to know few more details so that we can investigate the issue-

 

  • Is it happening with all the files and with every components or with some specific ones?
  • What is the OS and XD version of your machine?
  • Is it possible for you to record a video and share with us?

 

We will try our best to help.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 14, 2020 Sep 14, 2020

Copy link to clipboard

Copied

Hi there,

 

I have got an update from the team that the bug is already logged for this issue and they are investigating on it. You will definitely see improvements in the future releases of XD.

 

Hope it helps.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 25, 2021 Jan 25, 2021

Copy link to clipboard

Copied

LATEST

 

Hi 

 

I'm experincing the same issue (is everyone?).

Here's an example

I have a component in my library. I drag over first one instance and then another instance (or copy paste the first already on the board). I make changes like apply different colours maybe drop an image into a container.

I mark them both for export.
I create a share link and can see on the downloadable check box that there are two assets, all looks fine.
But when I preview the link there is only the first instance available to download!
The same will happen if I go through Export > Batch

No matter how many instances you have on the board only the first will export. In code view the remaining instances seem to be applied as cell backgrounds  
eg.
'background: transparent url('img/2.png') 0% 0% no-repeat padding-box;'

 

After a few hours exploration my workaround is to make each instance after the first a group and then they seem to pull through.
But thats not great is it? The whole point is to create many assets from one component with ease. I would hope that this is something considered to be urgent as it without discovery a trick to make it work, it's impossible to export all assets needed through XD.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines