Bug with component

Community Beginner ,
Jul 03, 2020 Jul 03, 2020

Copy link to clipboard

Copied

When I hide a group inside the component, then component size is not behaviour correct.  I am getting correct behaviour after doing something else like changing any text inside the component. Here is the screenshot of the issue.

When I hide the dropdown group from layers panel and result:
Screenshot3.png

Views

124

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Jul 03, 2020 Jul 03, 2020
Yes, I understand. The whole components and states feature has issues like that rather often.It's a good practice to set everything up before making the component, and when you have all the elements ready just show and hide them depending on the state.Working on the elements while they are in a component and you have multiple states is a bad idea and glitches like that happen all the time.

Likes

Translate

Translate
Adobe Community Professional ,
Jul 03, 2020 Jul 03, 2020

Copy link to clipboard

Copied

Can you include the layers panel in the screenshot?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 03, 2020 Jul 03, 2020

Copy link to clipboard

Copied

scree.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 03, 2020 Jul 03, 2020

Copy link to clipboard

Copied

There's a bug I noticed some time ago that happens sometimes.

When you make a component from multiple elements, instead of grouping the elements first, it doesn't change its constraints.

 

Try the following:

1. Ungroup the component.

2. Group all elements in one main group.

3. Make that group into a component.

 

Try hiding some elements and see if it works properly.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 03, 2020 Jul 03, 2020

Copy link to clipboard

Copied

Thank you so much, but unfortunately not working. I am fixing it for example with editing label text, Then this is creating other problems like;
For example, when I resize the master component (on default state) result is being different in the default state (hidden dropdown) and on the new state (visible dropdown). Field responding/resizing correctly in default state but field resizing not effecting on the new state.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 03, 2020 Jul 03, 2020

Copy link to clipboard

Copied

LATEST

Yes, I understand. The whole components and states feature has issues like that rather often.

It's a good practice to set everything up before making the component, and when you have all the elements ready just show and hide them depending on the state.

Working on the elements while they are in a component and you have multiple states is a bad idea and glitches like that happen all the time.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines