• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
3

Unable to execute script at line 20042. After Effects (Beta) error: This color id is invalid.

Community Beginner ,
Mar 27, 2024 Mar 27, 2024

Copy link to clipboard

Copied

Steps to reproduce:
    1. ...
 
Result: ...
Expected: ...
 
System info
    Application: After Effects (Beta) v24.4.0.24

    OS: macOS v14.4.0, RAM: 64.00 GB GB, CPUs (logical): 20


when i try to run duik angela script i get this message, i tried to delete the files and install it again and againg but didn't work still the same message

Bug Investigating
TOPICS
Bug , Error

Views

421

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Pinned Reply

Adobe Employee , Mar 27, 2024 Mar 27, 2024

Hello @ahmed alsaidi 

Thank you for posting the issue you are seeing here. We are working with script creators to both make sure that the new UI works for 3rd party scripts, and also updating some script calls which 3rd party developers use to work with the new UI. We are actively working on this in the beta release and will roll out fixes as they are resolved, tested, and discussed with the scripting community. We will update this post when this issue is resolved.

All the best,
Jessica McMillan
AE

...
Status Investigating

Votes

Translate

Translate
10 Comments
Adobe Employee ,
Mar 27, 2024 Mar 27, 2024

Copy link to clipboard

Copied

Hello @ahmed alsaidi 

Thank you for posting the issue you are seeing here. We are working with script creators to both make sure that the new UI works for 3rd party scripts, and also updating some script calls which 3rd party developers use to work with the new UI. We are actively working on this in the beta release and will roll out fixes as they are resolved, tested, and discussed with the scripting community. We will update this post when this issue is resolved.

All the best,
Jessica McMillan
AE Engineering

Status Investigating

Votes

Translate

Translate

Report

Report
Community Beginner ,
Mar 28, 2024 Mar 28, 2024

Copy link to clipboard

Copied

Hi Ahmed,

 

As stated by Jessica, we're aware of the issue, and an update of Duik will be released next week to fix this issue (along with other fixes and minor improvements).

Cheers!
Duduf

Votes

Translate

Translate

Report

Report
New Here ,
Apr 08, 2024 Apr 08, 2024

Copy link to clipboard

Copied

I've downloaded the update, but I get a new, similar error. This time it is the script at line 2784 that has a invalid color id.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Apr 08, 2024 Apr 08, 2024

Copy link to clipboard

Copied

Hello @Unter freiem Himmel,

We have a new beta build that should be available to you today (a build that is 24.4.0x38 or higher) that might fix the issue you are seeing depending on which function is failing. 

Could you let me know if it is resolved after updating your beta today?

All the best,
Jessica
AE Engineering

Votes

Translate

Translate

Report

Report
New Here ,
Apr 09, 2024 Apr 09, 2024

Copy link to clipboard

Copied

I've just updated to the newest AE beta version and unfortunately, the error still exists. On another machine, where I have not updated the beta for some time (I'm not sure which version is installed there and I can't look it up right now), the newest version of Duik Angela works without errors.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Apr 09, 2024 Apr 09, 2024

Copy link to clipboard

Copied

Hello @Unter freiem Himmel,


Could you verify which version of the application you launched which was still displaying errors? Also if you are using a Mac or Windows system?

Thanks!

Votes

Translate

Translate

Report

Report
New Here ,
Apr 10, 2024 Apr 10, 2024

Copy link to clipboard

Copied

Sorry, was logged in with a different account and don't think that I can delete that post. Once again: I'm on a Windows machine (Win 11), After Effects is 24.4 (I just downloaded build 41, no change), Duik Angela is version 17.1.12. Yesterday, I've tried to reinstall the beta and reverted the settings to default but that didn't work either unfortunately.

 

On my home machine, where Duik is working, i have build 29 installed. Other plugins I've installed should be practically the same between the two machines, if that makes any difference.

Votes

Translate

Translate

Report

Report
New Here ,
Apr 10, 2024 Apr 10, 2024

Copy link to clipboard

Copied

I've also tried a clean install on another machine (Win 11) and only added Duik as a plugin, but i still get the same error.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Apr 10, 2024 Apr 10, 2024

Copy link to clipboard

Copied

Hello @Unter freiem Himmel 

@RxLaboratory mentioned an updated version for Duik which might be out to resolve that issue. But outside of that there should be another updated build for the Beta out on Friday that may resolve this. May @RxLaboratory can let me know if this is the brush/pen custom color calls causing issues or if it is the theme function?

Thanks for the added details.

All the best,
Jessica 
After Effects Engineering
All the best,
Jessica 

Votes

Translate

Translate

Report

Report
New Here ,
May 27, 2024 May 27, 2024

Copy link to clipboard

Copied

LATEST

The beta version of AE (24.5) still gives an error. But in stable version 24.4.1 (build 2) everything works fine. Duik version 17.1.15

Votes

Translate

Translate

Report

Report
Resources