• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
4

24.2.1 Bug: Text essential prop not returning override value

Community Beginner ,
Mar 06, 2024 Mar 06, 2024

Copy link to clipboard

Copied

In the latest 24.2.1, essential property is returning the original text value instead of the esential property override.

AE 2023 seem to return the correct (override) value.

 

Bug Investigating
TOPICS
Scripting , Troubleshooting

Views

357

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Pinned Reply

Adobe Employee , Mar 21, 2024 Mar 21, 2024

Hello again, @Tom Balev,

I was able to reproduce the issue and it appears related to a similar bug reported against 24.2.x. We now have a ticket open and associated with that existing bug, which is already under investigation.

 

Thanks again for the report and for your patience,

- John, After Effects Engineering Team  

Status Investigating

Votes

Translate

Translate
8 Comments
Adobe Employee ,
Mar 06, 2024 Mar 06, 2024

Copy link to clipboard

Copied

Hi @Tom Balev,

Thank you for reporting this issue. Does the bug occur only when reading the .value attribute of the Essential Property via scripting, or does it also occur when overriding the value in the UI of After Effects?

 

Thank you for any further information you can provide,

- John, After Effects Engineering Team 

Status Needs More Info

Votes

Translate

Translate

Report

Report
Community Beginner ,
Mar 12, 2024 Mar 12, 2024

Copy link to clipboard

Copied

Hey John,

 

It only happens on the .value attribute when scripting - UI in After Effects seems to be getting the correct value in the Essential Properties dropdown, as well as in the Properties panel.

 

I have tested 23 versions (all return correct value), but it seems the bug only started happening on 24.2.X - and only on text layers.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Mar 21, 2024 Mar 21, 2024

Copy link to clipboard

Copied

Hey @JohnColombo - any updates on this? It seems to be issue in the latest beta as well.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Mar 21, 2024 Mar 21, 2024

Copy link to clipboard

Copied

Hi @Tom Balev,

Thanks for the follow-up. Edit: my apologies, and thanks very much for your patience.  We had a similar issue reported and are investigating that issue, but this one has not been moved into our bug-tracking system. I will get it in today and start the investigation. 

 

- John, After Effects Engineering Team  

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Mar 21, 2024 Mar 21, 2024

Copy link to clipboard

Copied

Hello again, @Tom Balev,

I was able to reproduce the issue and it appears related to a similar bug reported against 24.2.x. We now have a ticket open and associated with that existing bug, which is already under investigation.

 

Thanks again for the report and for your patience,

- John, After Effects Engineering Team  

Status Investigating

Votes

Translate

Translate

Report

Report
Enthusiast ,
May 02, 2024 May 02, 2024

Copy link to clipboard

Copied

Steps to reproduce:
1. Create a new comp and text layer 'some text'
2. Press UU to reveal SourceText, right-click and Add Property To Essential Graphics
3. Press T then drag Opacity into Essential Graphics panel
4. Click Edit Properties in Essential Graphics and check all options
5. Drag Comp 1 onto new comp icon to create Comp 2
6. Use Essential Properties panel to change the text, font size and set Opacity to 30% in Comp 2 only
7. With Comp 2 active, run attached essential test script
 
Result:

"localValue is not: some text source value: some text
I just can't read it. local value is not: some text
local fontSize is not: 135 source fontSize: 135
local opacity is correct: 30 source value: 100"

 

You can write local text but can't read it. No other text attributes work, even if enabled. Opacity local read/write works as expected, as do other non-text properties.


Expected: You could read and write at least the text properties enabled by Edit Properties.

A scripting ability to set those Edit Properties checkboxes would be good too. I guess we'd also need more stuff like Push/Pull state queries and methods to properly manage existing Essential Graphics projects through scripting.
 
System info
    Application: After Effects (Beta) v24.5.0.21
    OS: macOS v12.6.8, RAM: 64.00 GB GB, CPUs (logical): 12

Votes

Translate

Translate

Report

Report
Adobe Employee ,
May 02, 2024 May 02, 2024

Copy link to clipboard

Copied

Thank you for this report, @Paul Tuersley. We've made it reported previously and have a ticket open to investigate. I've merged this post with the existing report so we can notify all affected parties when there is an update on the issue.

 

Cheers,

- John, After Effects Engineering Team  

Votes

Translate

Translate

Report

Report
Community Beginner ,
Jun 07, 2024 Jun 07, 2024

Copy link to clipboard

Copied

LATEST

Hi @JohnColombo,

any news about this issue? I just tested it in latest beta 24.6.0 build 13 and I think it still doesn't work as expected.

Thanks!

Votes

Translate

Translate

Report

Report