• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
6

Advanced 3D is not working on a high-end PC

Community Beginner ,
Feb 13, 2024 Feb 13, 2024

Copy link to clipboard

Copied

Hello everyone,

I've been experiencing an issue with the advanced 3D render engine. Whenever I attempt to insert a 3D object or enable the advanced 3D engine, After Effects immediately crashes.

What confuses me is that on older-spec PCs with GPUs like the Nvidia 1660 or 3050, the engine works perfectly fine, and I'm able to animate and view the 3D objects.

My current PC specs are:

  • Intel Core i7-13700K, 3400 MHz, 16 Core(s), 24 Logical Processor(s)
  • Nvidia RTX 4060 Ti 8GB
  • 32GB RAM
    Nvidia and Intel drivers are updated.

Could it be a hardware issue with my PC? If so, does anyone have any ideas on what I should troubleshoot?
I'm attaching After Effects log of the exit that happens when I turn on Advanced 3D.

Bug Unresolved
TOPICS
Crash , Performance , Troubleshooting

Views

2.8K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Pinned Reply

Adobe Employee , Feb 15, 2024 Feb 15, 2024

Hi @martynasv31339915 

Ok amending this post:
in one of your messages you said:

" At one point in the After Effects Beta, a message popped up stating, "Advanced 3D is not supported by the current hardware,"

 

That is the biggest clue. Advanced 3D does not work when there is an integrated GPU and another GPU, i.e. 2 GPUs. The Intel vs Nvidia collision is the issue here. So, yes... the hardware is the issue. 😞 
 




 



I'm curious if there are some other things we can try to get you back on track. 

  • Fir
...

Votes

Translate

Translate
51 Comments
Engaged ,
Dec 15, 2023 Dec 15, 2023

Copy link to clipboard

Copied

Hey,

I've tried it now a couple of time with different 3d models but up until now AFX crashes all the time when I try to add a 3d object into a comp. I can sent over a 3d model or import a glb but as soon as I add it to a comp I get an unexpected error which causes the app to shut down. The models are of various degrees of complexity from low to high poly but it happens all the time.

It happened before in the Beta but I thought it was just because of the Beta status but it continues now with the released version as well.

Does this also happens to others?

I'm on a windows 10 pro laptop(AMD CPU and 3080ti GPU with 64GB of Ram) and using the newest AFX version.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Dec 15, 2023 Dec 15, 2023

Copy link to clipboard

Copied

Hi,

 

I'm Sébastien from the AE Team, I'm sorry you are encountering a crash when trying to use a 3D Object. 

Would you be able to share a 3D model with me, either through a DM or via email (mylastname at adobe com), so we can try to reproduce the issue on our side?

Also, when AE crashes, do you get the Crash reporter dialog? If so, could you check the checkbox "allow Adobe to contact me" and fill your email address so I can look for your crash in our database?

Sébastien Perier
AE Quality Engineering

Votes

Translate

Translate

Report

Report
New Here ,
Dec 16, 2023 Dec 16, 2023

Copy link to clipboard

Copied

Hello i just downloaded the new version of After Effects 24.1 and when i try to import a 3D model this error message appear : 

Capture d'écran 2023-12-16 160113.png

I updated all the drivers for my GPU and CPU and it still don't work 

Is there a way to fix that ?

Votes

Translate

Translate

Report

Report
Engaged ,
Dec 18, 2023 Dec 18, 2023

Copy link to clipboard

Copied

Hey Sébastien,

I have recorded a short video showing my usual steps: https://ecloud.global/s/QaSiTKKcidGNxnP

Most of the time I get error showing the message I have attached with my first post but as shown in the video I get non message just the option to save my file.

I have used different models. F.e. the example files that come with Substance or this one I used in the video https://substance3d.adobe.com/assets/allassets/e58461e85748246449fe02dd16ddd1cb2b1bf4e4?q=windturbin...

Best

Pascal

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Dec 18, 2023 Dec 18, 2023

Copy link to clipboard

Copied

Welcome to the community, Clement312367814ka1

Could you share your system specifications (CPU, GPU, RAM, OS version)? Can you try running After Effects in Safe Mode and see if that brings any change?

Let us know.

 

Thanks,

Nishu

 

Votes

Translate

Translate

Report

Report
Engaged ,
Jan 09, 2024 Jan 09, 2024

Copy link to clipboard

Copied

Did my video help?

Votes

Translate

Translate

Report

Report
New Here ,
Jan 12, 2024 Jan 12, 2024

Copy link to clipboard

Copied

Hello, i have the same problem, how can i fix it ?

 

my system specifications :
13th Gen Intel Core i7-13700KF, RAM 64Go, Windows 10 Professionnel Version 22H2.


Thanks !

Léa

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jan 16, 2024 Jan 16, 2024

Copy link to clipboard

Copied

Hi Léa,

 

Did you try running in Safe Mode? When exactly do you get the error? Do you get the error when trying to import a 3D model? What happens when you click OK in the error dialogue box? Are you able to work with the 3D model?

Let us know.

 

Thanks,

Nishu

Votes

Translate

Translate

Report

Report
New Here ,
Jan 21, 2024 Jan 21, 2024

Copy link to clipboard

Copied

Ekran Görüntüsü (94).png

I'm getting the same error, I tried booting in safe mode but it didn't work.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Jan 22, 2024 Jan 22, 2024

Copy link to clipboard

Copied

Hi. I get same error. Are you fix it?

Votes

Translate

Translate

Report

Report
Community Beginner ,
Jan 22, 2024 Jan 22, 2024

Copy link to clipboard

Copied

Hi! If I click ok in the error pop-up, after effects will close.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Feb 02, 2024 Feb 02, 2024

Copy link to clipboard

Copied

Hi all,

 

Can you please go to the Help top bar menu and choose "Enable Logs," Close and Relaunch AE, repro the issue, and then go back to the Help Menu and select "Reveal Logs"? 

Send the logs to me so that I can share them with the devs. Feel free to DM me.

 

Thanks,

Nishu

Votes

Translate

Translate

Report

Report
Engaged ,
Feb 07, 2024 Feb 07, 2024

Copy link to clipboard

Copied

I still haven't had any luck with importing any 3d model into AFX. Everytime I try to add one in I get an instant crash of the advanced 3d renderer

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Feb 14, 2024 Feb 14, 2024

Copy link to clipboard

Copied

Thanks for creating the post.

Are there any third-party plug-ins installed? Do you get the issue in a new project as well? Try running After Effects in Safe Mode with third-party plug-ins disabled.

Let us know if that brings any change.

Note: Moving this thread from Bugs to Discussions for troubleshooting.

 

Thanks,

Nishu

Votes

Translate

Translate

Report

Report
Community Beginner ,
Feb 14, 2024 Feb 14, 2024

Copy link to clipboard

Copied

I attempted to run After Effects 24.1 in safe mode, but encountered the same problem. I also tried running After Effects Beta, which has no plugins, both with and without safe mode, but encountered the same issue—After Effects simply exits. At one point in the After Effects Beta, a message popped up stating, "Advanced 3D is not supported by the current hardware," which seems incorrect, right? Regardless, I gave it a try, but unfortunately, it didn't work.

The plugins I'm using - Animation Composer, AEJuice, FXConsole, Saber, and an effect called Perfect Glow.

martynasv31339915_0-1707922676737.png

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Feb 14, 2024 Feb 14, 2024

Copy link to clipboard

Copied

There is a chance we have fixed this with 24.3x27 Beta builds. I'm not sure which Beta build you tested this on, but if it wasn't the very latest, try downloading that and see if it helps.

 

The bug we fixed was related to comps with Track Matte's being switched into Advanced 3D. You can also try to see if it helps to disable any track mattes in the comp before switching to Advanced 3D. If that works, you should be able to re-enable the track mattes. 

Votes

Translate

Translate

Report

Report
Community Beginner ,
Feb 14, 2024 Feb 14, 2024

Copy link to clipboard

Copied

Just updated the Beta build to 24.3x28, created a new composition, added a solid layer, and turned on 3D - immediately exits and prompts to save.

martynasv31339915_0-1707977259320.png

martynasv31339915_1-1707977346733.png


Tried performing the same action in safe mode. It allowed me to choose the 3D model's size, but after that, it was all the same 😞 .

martynasv31339915_2-1707977540231.png

 

Votes

Translate

Translate

Report

Report
New Here ,
Feb 15, 2024 Feb 15, 2024

Copy link to clipboard

Copied

it was fixed, just because my disk c was full lol

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Feb 15, 2024 Feb 15, 2024

Copy link to clipboard

Copied

Hi @martynasv31339915 

Ok amending this post:
in one of your messages you said:

" At one point in the After Effects Beta, a message popped up stating, "Advanced 3D is not supported by the current hardware,"

 

That is the biggest clue. Advanced 3D does not work when there is an integrated GPU and another GPU, i.e. 2 GPUs. The Intel vs Nvidia collision is the issue here. So, yes... the hardware is the issue. 😞 
 




 



I'm curious if there are some other things we can try to get you back on track. 

  • First, are you sending the Crash Reports to us?
    • When the crash occurs, please fill out your email address before hitting send and then let me know when that has happened. This can give us some major clues into what is going on 
      Crash Reporter Dialog.png
  • Second, and most "big hammer", there is a known issue where Advanced 3D does not work when there is an integrated GPU card + a traditional GPU card, i.e. Nvidia and Intel GPUs.
    • Usually this would throw a warning and say "hey sorry you can't use Advanced 3D" -- but maybe your system is getting past the warning and then crashing. (reading through your comments above it looks like you did see this warning. 
    • What happens if you disable the Intel card? Are you familiar with how to do this in Device Manager? Here's a little crash course on how to do that. 
    • Is the problem resolved when the iGPU is disabled? 


Thank you so much and hopefully we can get you back on track! 

 

- Dacia Saenz, AE Engineering Team

Votes

Translate

Translate

Report

Report
Community Beginner ,
Feb 20, 2024 Feb 20, 2024

Copy link to clipboard

Copied

after effects can't continue Advanced 3d plug-in generated an unexpected exception - Hi everyone, after installing the latest version this error appeared, please help to fix it. 

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Feb 20, 2024 Feb 20, 2024

Copy link to clipboard

Copied

Go into your composition settings and change from the Advanced 3D renderer to Classic 3D. That should remove the error from showing up.

 

If you need the Advanced 3D renderer, try installing the 24.3 Beta release and see if that helps.

Status Needs More Info

Votes

Translate

Translate

Report

Report
Community Beginner ,
Feb 20, 2024 Feb 20, 2024

Copy link to clipboard

Copied

No, that didn't help.(((

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Feb 20, 2024 Feb 20, 2024

Copy link to clipboard

Copied

Which didn't help? 

 

What are your computer specs? Do they meet the minimum for AE and for Advanced 3D? 

Votes

Translate

Translate

Report

Report
Community Beginner ,
Feb 20, 2024 Feb 20, 2024

Copy link to clipboard

Copied

Your tips did not help. The laptop fits of course, Intel 10th generation,
32 RAM, rtx 3060 6gb video card. The problem is not in the hardware. I took
the project for revision, in version 23 did not open, need to open in
version 24.1. Installed it and these problems began

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Feb 20, 2024 Feb 20, 2024

Copy link to clipboard

Copied

Can you go into AE, Help Menu -> Enable Logging, restart AE, then reproduce the error, then Help -> Reveal Logging Files, and then find the After Effects Log.txt file and paste the contents of that file back here. That should give us some clue as to what's going on. Thanks.

Votes

Translate

Translate

Report

Report