• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
19

After Effects 23.6 and 24.0 Not Starting on MacOS 14/Sonoma

Adobe Employee ,
Oct 06, 2023 Oct 06, 2023

Copy link to clipboard

Copied

Issue

Users upgrading to MacOS Sonoma (version 14) may find that After Effects will not startup and will report errors such as:

 

  • After Effects can't continue: internal structure inconsistency (g) ( 25 :: 2 )
  • After Effects error: globals unborn. ( 21 :: 3 )
  • After Effects can't continue: unexpected failure during application startup
  • After Effects can't continue: ... check for permissions or other error messages

 

Users may also find installed plugins are failing to load or exports from the Render Queue are failing in ways they did not before upgrading to Sonoma.

 

Resolution

The cause of the issue appears to be Sonoma adjusting the permissions and access to folders that After Effects requires to run. These include:

  • /Library/Application Support/Adobe/Common/Plug-ins/7.0/MediaCore
  • /Users/[Username]/Library/Preferences/Adobe/After Effects/[Version]
  • /Users/[Username]/Library/Preferences/[com.Adobe.After Effects.23x-24.plist(s)]

 

To check for the appropriate permissions:

 

  1. Navigate to /Library/Application Support/Adobe/Common/Plug-ins/7.0
  • Right-click on the MediaCore folder and choose Get Info from the context menu.
  • Open the Sharing & Permissions section and make sure “everyone” has at least Read Only Privilege set.
  • If the account you are launching After Effects with is listed in the Name column, make sure it has at least the Read Privilege set as well.

 

  1. Navigate to /Users/[Username]/Library/Preferences/Adobe/After Effects/
    • Right-click on the appropriate [Version] folder and choose Get Info from the context menu.
    • Ensure Locked is not checked. Uncheck it if necessary.
    • Open the Sharing & Permissions section and ensure the account you using to launch After Effects has both the Read & Write Privilege.

 

If after completing steps 1 & 2 After Effects will still not load, please make a backup of the above folders, then delete the folders at the paths above. Then uninstall and re-install After Effects.

 

Additional Step, thanks to @Mike Wills Makes 

 

3. Navigate to /Users/[Username]/Library/Preferences/

  • Find the com.Adobe.After Effects.23*.plist files 
  • Backup a copy of them to a safe location
  • Delete the files. 
  • Repeat these steps for any com.Adobe.After Effects.24*.plist files 

 

pin-icon
Bug Started
TOPICS
Troubleshooting

Views

26.2K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Pinned Replies

Adobe Employee , Nov 27, 2023 Nov 27, 2023

An update on this issue

We believe we have a better understanding of why clearing either the preferences or the plist files helps. We are working on testing fixes today and hoping to have a fix out with our next release, potentially next week. 

 

Status Investigating

Votes

Translate

Translate
Adobe Employee , Dec 04, 2023 Dec 04, 2023

AE 24.1 has begun rolling out to users, and should be available for everyone by EOD Wednesday. It contains a few more attempts to fix the issues seen with starting AE under Sonoma. If you're still having trouble, please upgrade to 24.1 once it is available and see if that resolves the issue for you. 

Status Started

Votes

Translate

Translate
67 Comments
Adobe Employee ,
Nov 20, 2023 Nov 20, 2023

Copy link to clipboard

Copied

The plist files are meant to be there. They are generated automatically and contain information about the plugins you have installed (so AE doesn't have to scan them every time) along with some other instrumentation data. The issue seems to be AE being able to read the plist files on MacOS 14. I've checked the sample plist files that have been sent to me, and there is nothing wrong with the contents, so I'm led back to the permission to read them being blocked by the OS. When you open them or delete them, the permissions are being reset and allowing AE to start up again. We are trying to reproduce the issue internally but haven't been able to as yet. 

Votes

Translate

Translate

Report

Report
New Here ,
Nov 21, 2023 Nov 21, 2023

Copy link to clipboard

Copied

Over the last few weeks (since i've upgraded to MacOS 14) and around the same time to AE24 the application freezes frequently and will not restart. 


After this I need to uninstall AE24 - manually delete all preference files and the Cache folders com.adobe.AfterEffects & After Effects. Reboot the system (just to be sure) and re-install the application. A time consuming fix, not counting the work that needs to be re-done before the crash :-).

Hope that Adobe will resolve this bug soon!

Votes

Translate

Translate

Report

Report
New Here ,
Nov 22, 2023 Nov 22, 2023

Copy link to clipboard

Copied

Thanks for the answer! It happen all the times as you told - AE freezes (whole system freezes) on basic actions - like choosing layer or navigating through timeline and computer restarts (if I don't do hard reset earlier). When after restart I try to open AE the error message appears. But on second or third attempt to open AE it opens and works well some time untill the whole system freezes again. Cleaning preferences, plists, etc - doesn't help either. I don't have any plugins installed so it can't be the problem. Do someone else have such problem?

Votes

Translate

Translate

Report

Report
New Here ,
Nov 23, 2023 Nov 23, 2023

Copy link to clipboard

Copied

Yesterday I spent the whole night with the Adobe remote support service - we checked everything we could and the problem still exist - mac continues to shut down after a while. We couldn't rich the decision of a problem but today I had an interesting thought - I see that my CPU gets really hot when i am using AE - can it be some problem in optimisation - that maybe riching some hot point the system just crashes? I really want to find an answer and even support service can't do it. It is really annoying to start using Adobe programms legally and just get crashing piece of nothing.

Votes

Translate

Translate

Report

Report
New Here ,
Nov 27, 2023 Nov 27, 2023

Copy link to clipboard

Copied

This morning again AE freezed my entire system, but instead of uninstalling and reinstalling, I only removed all After Effects preference files and the folder 24.0 under users/[name]/Library/Preferences/Adobe/After Effects. After that I could restart AE again. In the preference folders there also where some txt files (i'm not sure if they where logs) but if Adobe is interested I saved those and can share them with them. 

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Nov 27, 2023 Nov 27, 2023

Copy link to clipboard

Copied

An update on this issue

We believe we have a better understanding of why clearing either the preferences or the plist files helps. We are working on testing fixes today and hoping to have a fix out with our next release, potentially next week. 

 

Status Investigating

Votes

Translate

Translate

Report

Report
New Here ,
Nov 28, 2023 Nov 28, 2023

Copy link to clipboard

Copied

Exactly the same problem for me. I even tried downgrading back to Ventura and the same thing happens. I desperately need to use After Effects, huge issues since I cannot use it, so this is really a disaster for me the last couple of weeks Adobe. When will you fix this?

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Nov 28, 2023 Nov 28, 2023

Copy link to clipboard

Copied

@Cicely Rose Ventura does not have this specific issue, it's specific to MacOS 14. Can you describe in detail what errors you're seeing are? What version of AE you have been using? 

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Nov 29, 2023 Nov 29, 2023

Copy link to clipboard

Copied

If you are running into the issue as described originally in this post, we have a potential fix that is now available in the After Effects Beta. You can install that from the Creative Cloud Desktop in the Betas section. It'd be great to know if you're experiencing the issue and this Beta allows you to startup the Beta. It won't fix 24.0.3 but if the Beta works, we will be getting a new 24.* release out with the fix ASAP. Thanks for any testing you can help with. 

Votes

Translate

Translate

Report

Report
New Here ,
Nov 30, 2023 Nov 30, 2023

Copy link to clipboard

Copied

I've been having the original issue lately with the latest update of AE - the Beta starts up perfectly! Hopefully the issue is resolved in the next release.  

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Dec 04, 2023 Dec 04, 2023

Copy link to clipboard

Copied

AE 24.1 has begun rolling out to users, and should be available for everyone by EOD Wednesday. It contains a few more attempts to fix the issues seen with starting AE under Sonoma. If you're still having trouble, please upgrade to 24.1 once it is available and see if that resolves the issue for you. 

Status Started

Votes

Translate

Translate

Report

Report
Community Beginner ,
Dec 06, 2023 Dec 06, 2023

Copy link to clipboard

Copied

yeah, no solution anywhere seems to work. unfortunate.

Votes

Translate

Translate

Report

Report
New Here ,
Dec 07, 2023 Dec 07, 2023

Copy link to clipboard

Copied

I was able to get AE 24.1 to work on my new M3 Mac with Sonoma once I uninstalled and reinstalled After Effects. Upgrading alone did not do it.

Votes

Translate

Translate

Report

Report
New Here ,
Dec 19, 2023 Dec 19, 2023

Copy link to clipboard

Copied

I was able to resolve AE crashing after Sonoam update by going to User > Library > Preferences, then Get Info on Preferences folder  >  Sharing & Permissions "everyone" from “No Access” to “Read Only”. Hasn't crashed since I changed that. 

Votes

Translate

Translate

Report

Report
New Here ,
Feb 13, 2024 Feb 13, 2024

Copy link to clipboard

Copied

Had this error message the whole time on Sonoma 14.X and After Effects 14.1. (Macbook M1 pro chip)  Tried all the solutions (preferences, changing access, deleting old folders,...) Did the newest Sonoma update 14.3.1 and everything works fine now. Capture d’écran 2024-02-12 à 11.02.37.png

Votes

Translate

Translate

Report

Report
New Here ,
Apr 06, 2024 Apr 06, 2024

Copy link to clipboard

Copied

I just had to go through all three steps to get this app to work and it is April 2024. After Affects has always been glitchy, but this is unexcusable. This fix is from October. Six months later and this still not has been taken care of? I expect an app to work when I download it. I should not have to go through all this to get it to work. And the plain fact is this- After Effects has NEVER worked right away after a download. There is always some glitch. Usually, it's not that bad. But this time it took me two days to look fixes up to get this program to work. Do better, Adobe. I have work to do. 

 

I truly love After Effects. I really do. But to have these same issues after six months is simply not OK.

 

Votes

Translate

Translate

Report

Report
New Here ,
Apr 07, 2024 Apr 07, 2024

Copy link to clipboard

Copied

LATEST

Sorry, my previous post was not helpful. Thank you for the fixes. Everything is working fine now. I realize dealing with new processors and code is difficult. 

Votes

Translate

Translate

Report

Report