• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
9

Auto-deselecting layers when you add keyframes with shortcuts

Community Beginner ,
Oct 11, 2023 Oct 11, 2023

Copy link to clipboard

Copied

Really painfull Bug, when you add any keyframe with shortcut to (selected) layer automaticaly deselect all so if you want to add scale and then position to SELECTED adds scale property but when you add position you have to select them again. Also if you Ctrl+z the undo action steps into every single layer one at a time not all at once.

Please Fix it

Bug Fixed
TOPICS
Performance , Workflow

Views

206

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Mar 27, 2024 Mar 27, 2024

Hi all,

This issue was fixed in After Effects 24.0.1. If you continue to experience this issue, please update that build or a later version—the latest is 24.3 as of this post.

 

Thanks again for reporting this issue,

- John, After Effects Engineering Team 

Status Fixed

Votes

Translate

Translate
23 Comments
Adobe Employee ,
Oct 11, 2023 Oct 11, 2023

Copy link to clipboard

Copied

Reported here already: https://community.adobe.com/t5/after-effects-bugs/layer-is-deselected-when-creating-the-first-keyfra...

 

Fix will go into 24.1 beta builds in the next day or two. 

Status Started

Votes

Translate

Translate

Report

Report
Community Beginner ,
Oct 11, 2023 Oct 11, 2023

Copy link to clipboard

Copied

Thanks!! didn't see it

Votes

Translate

Translate

Report

Report
Explorer ,
Oct 12, 2023 Oct 12, 2023

Copy link to clipboard

Copied

when you select layer and use hold option + P, S, R (and probably others too) deselect layer.

used to be the layer is stay selected, so i can keyframe position, scale, rotation with option+P,S,R without touching anything at three key stroke. now every time i add key farme with shortcut, it deslectes layer, so i keep applying scacle keyframe in entire layer in the comp. this is not productive since i'm use to use shortcut all the time.

please fix!

After Effects 24.0.0

Ventura 13.6

MacStudio

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Oct 12, 2023 Oct 12, 2023

Copy link to clipboard

Copied

Thanks for the report. The fix for this will be in the 24.1 beta builds in a few days from now and we are working on a 24.0.1 release next week to fix this. Sorry for the issue.

Status Started

Votes

Translate

Translate

Report

Report
Community Beginner ,
Oct 13, 2023 Oct 13, 2023

Copy link to clipboard

Copied

When a layer is selected, and you want to add multiple keyframe properties to the layer, after the first keyframe the layer gets deselected and the 2nd keyframe property gets added to every single other layer in the project. On top of that, control z wont undo the entirity of the action, it undos every keyframe individually which is ... not great.

 

Including a loom here for reference: https://www.loom.com/share/598d0ed10dd44f4bbdd387157377e78a?sid=1c5f960c-f3e7-4116-9244-4041b64f3dc1

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Oct 13, 2023 Oct 13, 2023

Copy link to clipboard

Copied

Thanks for reporting the issue and sorry for the issue.

 

The fix will be available for further testing in the 24.1x53 AE Beta build available tomorrow. We are also working on a hot fix for 24.0 that will contain this fix, which we hope to release in the next week. 

Status Started

Votes

Translate

Translate

Report

Report
Community Beginner ,
Oct 15, 2023 Oct 15, 2023

Copy link to clipboard

Copied

Hola a todos, no sé si les pasa esto con After Effects 2024.

Cuando introduzco un fotograma clave de posición en una capa, presionando ALT+MAYUSCULAS+P, el fotograma se introduce bien. Cuando quiero eliminarlo presionando esa misma combinación de teclas, lo que sucede es que se crean fotogramas de posición en todas las otras capas de esa composición, independientemente de que estén seleccionadas o no.  Es extremadamente molesto. Sucede con el ajuste preestablecido por Adobe y también si personalizo el método abreviado.

 

Estimo que es un bug del programa, pero si alguien tiene una solución para esto, le agradecería compartirla aquí.

Votes

Translate

Translate

Report

Report
New Here ,
Oct 16, 2023 Oct 16, 2023

Copy link to clipboard

Copied

Following already reported bug, i selected a Layer and pressed option+P and option+T to add two keyframes zu Pos and Transp... After option+P AE descelected my layer (already reported)... with the following option+T AE added a transparency Keyframe to all layers instead... this couldnt be easily undone, as every keyframe created a seperate  "interpolation change". Seems like a bug, as a small mishap/prior bug created alot of extra work 😕

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Oct 16, 2023 Oct 16, 2023

Copy link to clipboard

Copied

If you can, please download the AE Beta build from Creative Cloud Desktop and see if the problem still happens there. We have a fix in the Beta that should address this issue.

Status Started

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Oct 16, 2023 Oct 16, 2023

Copy link to clipboard

Copied

There is a fix available in 24.1 AE betas, and we are working on releasing a 24.0.1 with the fix later this week.

Status Started

Votes

Translate

Translate

Report

Report
Community Beginner ,
Oct 16, 2023 Oct 16, 2023

Copy link to clipboard

Copied

Gracias!

Votes

Translate

Translate

Report

Report
Community Beginner ,
Oct 17, 2023 Oct 17, 2023

Copy link to clipboard

Copied

Previously you could hold Alt, then press P, S, and R to easily add PSR keyframes to a layer. in AE 24, after the first keyframe is set with Alt+P, the layer is deselected forcing you to manually re-select the layer before adding another keyframe.

 

This is a big undesired regression.

Adding a keyframe with the Alt+[P/S/R/etc] shortcut should not deselect the layer.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Oct 17, 2023 Oct 17, 2023

Copy link to clipboard

Copied

Thanks for the report. We've had a few others report it as well. We have a fix in 24.1 Beta builds and are working on a 24.0.1 hot fix for release in the next few days.

Status Started

Votes

Translate

Translate

Report

Report
Community Beginner ,
Oct 17, 2023 Oct 17, 2023

Copy link to clipboard

Copied

Thank you!

Votes

Translate

Translate

Report

Report
Engaged ,
Oct 18, 2023 Oct 18, 2023

Copy link to clipboard

Copied

EDIT: Apparently this has already been reported and acknowledged. Note to admin - please delete this post.

 

Please fix the behaviour in the recent After Effect version when using shortucts like:

alt-shift-p

alt-shift-t

alt-shift-r

etc...

 

Before after executing these shortcuts the newly created keyframes were selected. It made sense and was practical as the next step was to use ctr-alt-arrow to shift these keyframes on timeline, etc.)

 

Now in the latest After Effects version, after creating new keyframes with shortcut even the selected layers get unselected which leads to workflow issues.

Now if you want to add position, scale, rotation using shortcuts, you need to keep re-selecting the layer which seems to be a counterproductive software bug.

 

Please fix.

Thanks.

 

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Oct 18, 2023 Oct 18, 2023

Copy link to clipboard

Copied

Hello Frank. 

Thanks for reporting the issue. We have a fix for this issue and plan to roll it out most likely by tomorrow with AE 24.0.1.

Regards,

After Effects QE. 

Votes

Translate

Translate

Report

Report
New Here ,
Oct 18, 2023 Oct 18, 2023

Copy link to clipboard

Copied

Thanks for reporting this. This is giving me a headache! Glad to hear it is being fixed.

One additional note to add tangental to this. When adding a keyframe to "X" property (P,S,R, etc.) using option/alt with NO layers selected - thereby adding a keyframe to X property on ALL layers - cmd/cntrl Z will only remove the keyframes individually, not across the whole comp with one undo.

 

So, if you add a keyframe using opt/alt on one layer selected - say for instance Rotation - and don't realize that the layer has been deselected and then try to immediately add a keyframe to Position, for example, using opt/alt you'll accidentally add a Pos keyframe to ALL layers and then have to press cmd/cntrl Z for every single layer in the comp to remove the comp wide keyframe.

Votes

Translate

Translate

Report

Report
Engaged ,
Oct 18, 2023 Oct 18, 2023

Copy link to clipboard

Copied

Hey Joy,
Thank you for the prompt reply and a great news.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Oct 19, 2023 Oct 19, 2023

Copy link to clipboard

Copied

Thanks. Yes, that fix is also into Beta and will release with the 24.0.1 release likely later today.

Votes

Translate

Translate

Report

Report
New Here ,
Oct 20, 2023 Oct 20, 2023

Copy link to clipboard

Copied

Same problem here. 

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Oct 20, 2023 Oct 20, 2023

Copy link to clipboard

Copied

24.0.1 should be available for download now. Please update and see if the issue is resolved.

Thanks
Sean

Votes

Translate

Translate

Report

Report
Community Beginner ,
Oct 20, 2023 Oct 20, 2023

Copy link to clipboard

Copied

What a relief! That's one the most used shortcut combos for me. Thanks for fixing it.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Mar 27, 2024 Mar 27, 2024

Copy link to clipboard

Copied

LATEST

Hi all,

This issue was fixed in After Effects 24.0.1. If you continue to experience this issue, please update that build or a later version—the latest is 24.3 as of this post.

 

Thanks again for reporting this issue,

- John, After Effects Engineering Team 

Status Fixed

Votes

Translate

Translate

Report

Report