Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


After Effects CC renders low quality video with clearly visible pixels

Community Beginner ,
Dec 10, 2016 Dec 10, 2016

Copy link to clipboard

Copied

I used to have AE CS4 and rendering was fine, but I recently switched to AE CC 2017 and recently rendering became quite annoying. After rendering (Quicktime format and H.264 codec) there are pixels glitching, it looks like resolution is smaller, its blurry and quality is really bad. I set composition on 16 bpc and I even tried rendering on 32 but it still didnt make quality better, only made it render longer. Here are screenshots:

this is how it looks in After Effects

this is how video looks when it's played

I also rendered it twice (second time was after restarting pc) and it didnt help. Is something wrong with my output settings? Any help is welcome

TOPICS
Import and export

Views

36.5K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

LEGEND , Dec 10, 2016 Dec 10, 2016
Is something wrong with my output settings?
Yes!
After rendering (Quicktime format and H.264 codec) there are pixels glitching, it looks like resolution is smaller,
how are you rendering? is it through AE's Quicktime format and H.264 codec ? - DON'T it's old and poorly executed. you should export your video through AME. here's a resource file about it (don't worry, there are video tutorials in it too): Basics of rendering and exporting in After Effects CCone gotcha: in the latest CC2017, there i...

Likes

Translate

Translate
LEGEND ,
Dec 10, 2016 Dec 10, 2016

Copy link to clipboard

Copied

Is something wrong with my output settings?

Yes!

After rendering (Quicktime format and H.264 codec) there are pixels glitching, it looks like resolution is smaller,

how are you rendering? is it through AE's Quicktime format and H.264 codec ? - DON'T it's old and poorly executed. you should export your video through AME. here's a resource file about it (don't worry, there are video tutorials in it too): Basics of rendering and exporting in After Effects CC

one gotcha: in the latest CC2017, there is a bug that causes AME to take the resolution from the composition resolution popup, so make sure you set it to full before you Add your composition to AME, or use the handy Queue in AME feature right in the render queue and don't worry about it.

I set composition on 16 bpc and I even tried rendering on 32 but it still didnt make quality better, only made it render longer.

this is not how it works. these settings are not for compressed formats and are there for maintaining a high color depth for further processing later without reducing quality in terms of color depth.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 16, 2016 Dec 16, 2016

Copy link to clipboard

Copied

Thanks for your reply. I installed Quicktime to render with H.264, but since I don't see it in format list like on pc I had before, I thought choosing it from Qicktime would be fine. How can I render with H.264 in AE without using AME, is there any way to install it?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 16, 2016 Dec 16, 2016

Copy link to clipboard

Copied

You do not want to do that. If you are having other issues you should  render a lossless intermediate and then use the media encoder to render your deliverable H.264 MP4 file.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 16, 2016 Dec 16, 2016

Copy link to clipboard

Copied

How can I render with H.264 in AE without using AME, is there any way to install it?

if you have Ae 2017 this means you also have AME 2017 because they are installed together. if you don't want to use AME, there are other transcoders out there. Handbrake is a free transcoder: https://handbrake.fr/.. if you plan to use another transcoder or if you want to use AME as a second step (and not render directly from Ae to AME), then as Rick suggested you will have to render in a lossless format (such as Quicktime Animation) and use this file in your transcoder to create an mp4 compressed file.

more about the process (and more) here:

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 16, 2016 Dec 16, 2016

Copy link to clipboard

Copied

Thanks a lot, I'll use AME then

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 16, 2016 Dec 16, 2016

Copy link to clipboard

Copied

LATEST

Great! if you do choose to render directly from Ae->AME then make sure you use "Queue in AME". it's superior to Composition->Add to AME Queue, and will help you avoid the recent CC2017 Bug.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Dec 10, 2016 Dec 10, 2016

Copy link to clipboard

Copied

Ok. So there could be two reasons:
1. you are using h264 in QT wrapper - not to good idea, lot's of issues and not to good quality. Just use clear h264 - it will give you mp4 file - much better quality.
2. If you are using Render with Adobe Media Encoder you probably are experiencing known issue of newest AE - it mean - changing output resolution to whatever resolution is in your preview. To change that you have two choices:
-  just change resolution of your preview to full before you will use Comp[osition/Add to Adobe Media Encoder Render Queue...
- use Add to render queue... and from your render queue tab use Queue in AME
More about those AE 2017 known issues from Adobe: https://helpx.adobe.com/after-effects/kb/known-issues-after-effects-cc-2017.html

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines