Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


After Effects keeps moving half my comps into a random 'Precomps' folder

New Here ,
Jun 17, 2021 Jun 17, 2021

Copy link to clipboard

Copied

I've had this issue for the past few weeks/months, After Effects keeps randomly creating a Precomps folder and moving some of my comps in there. I've tried deleting the folder but After Effects will create it again and move the comps, which is really annoing as it's messing with my organisation system and I have to keep checking of it's moved them again. I also tried resetting preferences in case I had inadvertently changed anything but it doesn't seem to have fixed it.

 

Any help would be greatly appreciated.

TOPICS
How to, Import and export, Performance

Views

158

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 17, 2021 Jun 17, 2021

Copy link to clipboard

Copied

I have never seen After Effects randomly create a pre-comp. You have to select layers and at least hit the shortcut key. Unless you have some kind of script running there is no way that AE could select one or more layers and pre-compose.

 

Are you working with 3rd party templates? What is your workflow. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 18, 2021 Jun 18, 2021

Copy link to clipboard

Copied

It's not creating pre-comps, rather in the Project panel After Effects will create a folder named 'Precomps' and move some of my compositions in there, which never used to happen. I keep moving the comps out and deleting the folder but it keeps creating it again and moving them.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 03, 2021 Aug 03, 2021

Copy link to clipboard

Copied

Ooops... meant to reply to the original post, not in one of the threads.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 03, 2021 Aug 03, 2021

Copy link to clipboard

Copied

I am having this same issue and would like a solution. After Effects has started assigning any comp placed (not created) inside another comp as a 'Precomp' and moving it to an automatically created folder. The comp is not moved immediately after placement, AE seems to reorganize at certain intervals (my guess is during autosave, but I'm not sure).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 03, 2021 Aug 03, 2021

Copy link to clipboard

Copied

It sounds like a 3rd party project organizer script is running.

 

Maybe something like KleanFast - AE Project Organizer by Bretyboy | VideoHive.

 

 

 

-Warren

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 03, 2021 Aug 03, 2021

Copy link to clipboard

Copied

Ok, could that be something Aftet Effects might have added automatically? Because the only 3rd party script I have running to my knowledge is Duik Bassel.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 23, 2021 Aug 23, 2021

Copy link to clipboard

Copied

LATEST

In the DUIK panel, click the brain icon in the lower right then click on the magic wand to disable live-fix.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines