Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


[bug] text layer's "strokeOverFill" property returning wrong values

Explorer ,
Oct 22, 2017 Oct 22, 2017

Copy link to clipboard

Copied

Hi there,

I've stumbled upon a problem/bug while writing something to sync text layer's attributes.

To replicate:

- In the UI, set a text layer's stroke/fill behaviour to "Fill Over Stroke" (keep the item selected)

- Run this code:

$.writeln(app.project.activeItem.selectedLayers[0].property("Source Text").value.strokeOverFill)

- It returns 'false'. So far, so good.

- Now change the value in the UI to "Stroke Over Fill" and run the above code again

- It returns 'true'. Very nice.

- Change the value in the UI to "All Fills Over All Strokes" and run the code again

- It returns 'true'. Wrong! It should return false.

- Change the value back to "Fill Over Stroke", run the code (this is just to verify that this option returns the right value)

- It returns 'false', which is correct.

- But if you now change the value to "All Strokes Over All Fills" and run the code it still returns 'false'.

After looking at the results of the above test, it seems that the latter two options in the list ("All Fills Over All Strokes" and "All Strokes Over All Fills") don't affect the variable available to the JavaScript API, but only the first two options ( "Fill Over Stroke" and "Stroke Over Fill").

This is quite annoying when trying to sync up many text layer's properties accurately.

I'm on AE CC 2015 (13.5.0.347) on OSX

I suppose there is not really a workaround since accessing text attributes is already quite limited, but if anyone has some good ideas, let me know.

TOPICS
Scripting

Views

696

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Oct 23, 2017 Oct 23, 2017

Copy link to clipboard

Copied

Definitely, that's annoying, but you can upload it as a bug or feature request here:

Wishform - Adobe After Effects

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 01, 2017 Nov 01, 2017

Copy link to clipboard

Copied

Thanks, for the reference Alex+White​. I have written a bug report for the above and a feature request for more properties with write-access.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 15, 2018 Nov 15, 2018

Copy link to clipboard

Copied

LATEST

This bug was fixed in the October 2018 release of After Effects CC (version 16.0). You can install this release via the Creative Cloud desktop application.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines