Locked

Application icon?

LEGEND ,
Nov 18, 2011 Nov 18, 2011

Copy link to clipboard

Copied

Windows XP; Adobe AIR SDK 3.1.0.4880

I have just started using Adobe AIR this week.  I made a litte test app at home, following http://help.adobe.com/en_US/air/build/WS5b3ccc516d4fbf351e63e3d118666ade46-7ecc.html

After completing the app, and installing it, it created a desktop shortcut with an AIR icon.  The application itself also has a little AIR icon in the upper left corner.

Today I created a real little app on Windows XP.  This time no icon appeared on the desktop, nor on the application Window:

MakeISBN.png

Anyone knows why this difference, with the same AIR SDK?

TOPICS
Performance issues

Views

3.1K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Nov 18, 2011 Nov 18, 2011

Hi Pat,

Can you post your app desctiptor xml file?  You should be able to set different size icon in the <icon> section of the descriptor file (though remember to uncomment it before building).

Thanks,

Chris

Likes

Translate

Translate
LEGEND ,
Nov 18, 2011 Nov 18, 2011

Copy link to clipboard

Copied

Sorry, I was wrong - my memory was slightly incorrect.

When running the installed HelloWorld app it looks like

hw2.PNG

What I remembered was when testing, it looked like

hw1.PNG

Now my question is: how can we get the AIR, or any other icon into the installed app window?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 18, 2011 Nov 18, 2011

Copy link to clipboard

Copied

Hi Pat,

Can you post your app desctiptor xml file?  You should be able to set different size icon in the <icon> section of the descriptor file (though remember to uncomment it before building).

Thanks,

Chris

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 18, 2011 Nov 18, 2011

Copy link to clipboard

Copied

Hi Chris,

Thank you for your reply.  I have added the <icon> tag to my descriptor file, as follows

<?xml version="1.0" encoding="utf-8" ?>

<application xmlns="http://ns.adobe.com/air/application/3.1">

    <id>examples.html.HelloWorld</id>

    <versionNumber>0.3</versionNumber>

    <filename>HelloWorld</filename>

    <initialWindow>

        <content>HelloWorld.html</content>

        <visible>true</visible>

        <width>400</width>

        <height>200</height>

        <icon>

            <image16x16>C:\Program Files (x86)\Adobe\AIRSDK\samples\icons\AIRApp_16.png</image16x16>

            <image32x32>C:\Program Files (x86)\Adobe\AIRSDK\samples\icons\AIRApp_32.png</image32x32>

            <image48x48>C:\Program Files (x86)\Adobe\AIRSDK\samples\icons\AIRApp_48.png</image48x48>

            <image128x128>C:\Program Files (x86)\Adobe\AIRSDK\samples\icons\AIRApp_128.png</image128x128>

    </icon>

    </initialWindow>

</application>

However, when trying to build the application I get the following error

Error 103: application.initialWindow.icon is an unexpected element/attribute

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 18, 2011 Nov 18, 2011

Copy link to clipboard

Copied

Obviously the <icon> tag does not belong inside the <initialWindows> section.

Moving it outside I now get this error for every line

Error 105: application.icon.image16x16 contains an invalid value

I tried both with and without quotation marks around the path/filename:

<?xml version="1.0" encoding="utf-8" ?>

<application xmlns="http://ns.adobe.com/air/application/3.1">

    <id>examples.html.HelloWorld</id>

    <versionNumber>0.3</versionNumber>

    <filename>HelloWorld</filename>

    <initialWindow>

        <content>HelloWorld.html</content>

        <visible>true</visible>

        <width>400</width>

        <height>200</height>

    </initialWindow>

    <icon>

        <image16x16>"C:\Program Files (x86)\Adobe\AIRSDK\samples\icons\AIRApp_16.png"</image16x16>

        <image32x32>"C:\Program Files (x86)\Adobe\AIRSDK\samples\icons\AIRApp_32.png"</image32x32>

        <image48x48>"C:\Program Files (x86)\Adobe\AIRSDK\samples\icons\AIRApp_48.png"</image48x48>

        <image128x128>"C:\Program Files (x86)\Adobe\AIRSDK\samples\icons\AIRApp_128.png"</image128x128>

    </icon>

</application>

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 18, 2011 Nov 18, 2011

Copy link to clipboard

Copied

I found some answers in http://forums.adobe.com/thread/91611 - however, whatever change I make to my descriptor file, the error remains the same.  The file is currently

<?xml version="1.0" encoding="utf-8" ?>

<application xmlns="http://ns.adobe.com/air/application/3.1">

    <id>examples.html.HelloWorld</id>

    <versionNumber>0.3</versionNumber>

    <filename>HelloWorld</filename>

    <initialWindow>

        <content>HelloWorld.html</content>

        <visible>true</visible>

        <width>400</width>

        <height>200</height>

    </initialWindow>

    <icon>

        <image16x16>"-C C:/Program Files (x86)/Adobe/AIRSDK/samples/icons/."</image16x16>

        <image32x32>"-C C:/Program Files (x86)/Adobe/AIRSDK/samples/icons/."</image32x32>

        <image48x48>"-C C:/Program Files (x86)/Adobe/AIRSDK/samples/icons/."</image48x48>

        <image128x128>"-C C:/Program Files (x86)/Adobe/AIRSDK/samples/icons/."</image128x128>

    </icon>

</application>

Can you tell me how to code the <icon> section to avoid these errors?  (I have to go and do some other stuff now, so I cannot continues this for now.)

Edit: the paths shown in red above do actually have quotation marks around them; I don't know why this is not shown above.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 19, 2011 Nov 19, 2011

Copy link to clipboard

Copied

I copied the icons into the application folder and changed the descriptor as follows

<?xml version="1.0" encoding="utf-8" ?>

<application xmlns="http://ns.adobe.com/air/application/3.1">

    <id>examples.html.HelloWorld</id>

    <versionNumber>0.3</versionNumber>

    <filename>HelloWorld</filename>

    <initialWindow>

        <content>HelloWorld.html</content>

        <visible>true</visible>

        <width>400</width>

        <height>200</height>

    </initialWindow>

    <icon>

        <image16x16>icons/AIRApp_16.png</image16x16>

        <image32x32>icons/AIRApp_32.png</image32x32>

        <image48x48>icons/AIRApp_48.png</image48x48>

        <image128x128>icons/AIRApp_128.png</image128x128>

    </icon>

</application>

When trying to build the app, I now get these errors

C:\Users\pwillener\Documents\AIRapps\HelloWorld\HelloWorld-app.xml: error 303: Icon icons/AIRApp_128.png is missing from package

C:\Users\pwillener\Documents\AIRapps\HelloWorld\HelloWorld-app.xml: error 303: Icon icons/AIRApp_48.png is missing from package

C:\Users\pwillener\Documents\AIRapps\HelloWorld\HelloWorld-app.xml: error 303: Icon icons/AIRApp_32.png is missing from package

C:\Users\pwillener\Documents\AIRapps\HelloWorld\HelloWorld-app.xml: error 303: Icon icons/AIRApp_16.png is missing from package

I found information about this error in many places, but no solution how to fix it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 21, 2011 Nov 21, 2011

Copy link to clipboard

Copied

LATEST

With a little bit more research I found the answer here Adobe AIR * ADT error messages:

Error 303: The icon files specified in the application descriptor must be added to the package by including them among the files listed on the ADT command line. Icon files are not added automatically.

So I changed my ADT command to include the icon filenames, and everything is fine now (the AIR app window, as well as the desktop shortcut, now contains the icon):

adt -package -storetype pkcs12 -keystore sampleCert.pfx -tsa none HelloWorld.air HelloWorld-app.xml HelloWorld.html AIRAliases.js AIRApp_16.png AIRApp_32.png AIRApp_48.png AIRApp_128.png

hw3.PNG

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines