Locked

Cannot compile AIR app with Xcode 9.3 iPhoneOS11.3.sdk

Participant ,
Apr 23, 2018 Apr 23, 2018

Copy link to clipboard

Copied

After updating MacOS to 10.13.4 and Xcode to 9.3 I can no longer compile any AIR app when the path to the iOS SDK is set.

i.e. /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS11.3.sdk

This is building against the latest AIR SDK 29.0.0.122

Animate 18.0.1 Build 115

I get the following error:

Invalid Input

ld: unexpected token: !tapi-tbd-v3 file '/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS11.3.sdk/usr/lib/libc++.tbd' for architecture armv7

ld: unexpected token: !tapi-tbd-v3 file '/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS11.3.sdk/usr/lib/libc++.tbd' for architecture arm64

Has anyone any idea if there is a workaround for this?

Thanks,

Mark

TOPICS
Performance issues

Views

1.9K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , May 07, 2018 May 07, 2018
Hi,Could you please try once with following workaround and let us know if things are working fine for you:Replace the Runtime LD located at the path <AIRSDK>/lib/aot/bin/ld64/ld64 with the one which comes with Xcode 9.3.You can find it at location: <Xcode9.3InstallDir>/Xcode.app/Contents/Developer/usr/bin/ld.Also, do not forget to rename ld to ld64.Thanks,Pravishti | Adobe AIR Engineering

Likes

Translate

Translate
Adobe Employee ,
Apr 23, 2018 Apr 23, 2018

Copy link to clipboard

Copied

Hi,

Thanks for reporting. This issue is known to us and we're working on it.

As a workaround, you can try with older Xode i.e. Xcode 9.2 or below.

Let us know if you still face issues.

Thanks,

Pravishti | Adobe AIR Engineering

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 23, 2018 Apr 23, 2018

Copy link to clipboard

Copied

Thanks for your reply.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 23, 2018 Apr 23, 2018

Copy link to clipboard

Copied

please fix this issue for windows sdk too.

all air sdk 29 realeses have many issues with codesign and ld64   

also www.adobe.com/go/air_ld64 not working at all. just an empty page.

all win ld64.exe has timestamp 5 year ago.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 07, 2018 May 07, 2018

Copy link to clipboard

Copied

Hi,

Could you please try once with following workaround and let us know if things are working fine for you:

  • Replace the Runtime LD located at the path <AIRSDK>/lib/aot/bin/ld64/ld64 with the one which comes with Xcode 9.3.
  • You can find it at location: <Xcode9.3InstallDir>/Xcode.app/Contents/Developer/usr/bin/ld.

Also, do not forget to rename ld to ld64.

Thanks,

Pravishti | Adobe AIR Engineering

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
May 08, 2018 May 08, 2018

Copy link to clipboard

Copied

Using 29.0.0.122 this has no effect.

But compiling against AIR 30.0.0.85 the issue seems to have disappeared.

I'm not sure if 30.0.0.85 would have fixed the issue without changing the ld file though.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jul 24, 2018 Jul 24, 2018

Copy link to clipboard

Copied

I also had the problem of the ld: unexpected token: !tapi-tbd-v3 file message, which i presume indicates that the latest Apple loader has to be used, else things don't link any more. That they have modified the linker shows they are messing around at the deepest level in OSX. Very worrisome, the loader is the oldest part of every operating system, and precious few people know how loaders work exactly. Thanks for posting this workaround, without it i would be dead in the water!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 10, 2018 Oct 10, 2018

Copy link to clipboard

Copied

LATEST

Well, funny thing is AIR 31 is still not working with Xcode 9.4. One has to manually replace 'ld' in the AIR subdirectory.

Crazy, crazy, but we still love AIR , Starling and Feathers so much.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines