• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Animate 2017 is removing all instances of UIScrollbar from the stage

Community Beginner ,
Nov 10, 2016 Nov 10, 2016

Copy link to clipboard

Copied

This is mainly for Adobe support since I can't seem to find anywhere to report a bug, so here goes:

I updated to Animate 2017 two days ago and loaded up my (rather hefty) project.   Upon publishing it for the first time in this new version, I got errors that certain components were missing, and indeed they were.   ALL instances of UIScrollbar that existed on the stage had been completely removed!   Their layer was still there, but the instance (ie., the key frame it sat on) was gone entirely.

The component itself was still in the library, though, so I dragged it out and put it back where it should be.   Upon republish it worked fine so i wrote it off as a silly glitch and continued working.  HOWEVER:

After saving the FLA and re-opening it, the scrollbars were gone again, and they continue to be removed every time i re-open it!!!

I have since gone and reinstalled Animate CC 2015.2 because this is an unworkable bug.   Thank goodness it still works there.   I refuse to drag out and re-instance my scrollbars every time i open my project, for obvious reasons

Anyhow, thought you should know.    I realize SWF publishing is hardly your focus with Animate anymore, but there are still some of us out there that actively develop and maintain Flash games, and we need this stuff to work.

Cheers

Views

750

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Dec 14, 2016 Dec 14, 2016

Just want to update you all that this issue has been addressed in the update that we have released yesterday. Please update your copy of Animate CC 2017 to the latest using Creative Cloud desktop application. In case if you don't seen an update in Creative cloud app then please click on the gear icon and choose Check for App Updates. Once updated, the build number should display 16.0.1.119 in the About screen.

You can learn more about Animate CC 2017 release at https://helpx.adobe.com/animate/using/whats-new.html

...

Votes

Translate

Translate
LEGEND ,
Nov 10, 2016 Nov 10, 2016

Copy link to clipboard

Copied

If you're willing, could you submit that as a bug, and even include an example file that shows the problem? If you are, go here: Feature Request/Bug Report Form

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 10, 2016 Nov 10, 2016

Copy link to clipboard

Copied

Colin Holgate wrote:

If you're willing, could you submit that as a bug, and even include an example file that shows the problem? If you are, go here: Feature Request/Bug Report Form

Ok, posted, but it wouldn't let me attach any files.   I'll post my report here as well to help anyone else who happens to stumble upon this.   In short, it's directly tied to specifying the linkage name of the containing symbol

Steps to reproduce:

1. Create a new FLA

2. Drag a UIScrollBar component to the stage

3. Hit F8 to wrap it in a symbol

4. In the symbol properties dialog, enable "Export for Actionscript", and leave it at the default name; click OK.

5. Save FLA, and Close

6. Open FLA, and observe the UIScrollBar has been removed from the stage.

** Notes:

1) If you wrap a UIScrollBar in a symbol without a linkage name, it will NOT be removed.

2) If you put a UIScrollBar on the root will NOT be removed.

3) If you open this same file in Animate CC 2015.2, it will NOT be removed.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 11, 2016 Nov 11, 2016

Copy link to clipboard

Copied

Hi,  same problem!

It's not only UiScrollBar - Button, ScrollPane ect. too...

My complete work from last three days is gone!

I worked with ANIMATE - everything was fine.

I exported my AIR/EXE ect. files - everything was fine.

I finished working, started ANIMATE later again - loaded my project - most components in some MC are gone!

And crazy - if I try to put the component back into the MC - it is there - and after saving/reloading it's gone again.

If I put the component in an older MC in my project - it stays!

My software  (AIR desktop) is on the market since two years - now I pronounced an big update - and ALL my work seems to be gone!

AM

UPDATE:  qLipp is right - just open the file in older version (I had to download 1GB Animate 2015) and the file will be loaded correct!

So the problem start, when loading the file in 2017.

So - 2017 update of ANIMATE seems to be buggy! I try to find 2015.2 (any help?)and stay with this until there is a newer 2017... 😉

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 13, 2016 Nov 13, 2016

Copy link to clipboard

Copied

I have the same problem with my comboboxes that disapear from each movieClip where I put them. I have 10 MovieClips that I can slide containing each one a problem (I'm a science teacher). I put a combos on eachone where the answers are store. Everything works well until I close the file. When I reopen it the comboboxes are disapeared. The problem appears with the last update Animate CC 2017 Build 16.0.0.112

I report the bug yesterday and do not receive any news or conformation yet.

I would like to send you a file but the option doesn't appear here.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 10, 2016 Nov 10, 2016

Copy link to clipboard

Copied

qLipp wrote:

This is mainly for Adobe support since I can't seem to find anywhere to report a bug, so here goes:

boog.jpg

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Dec 14, 2016 Dec 14, 2016

Copy link to clipboard

Copied

Just want to update you all that this issue has been addressed in the update that we have released yesterday. Please update your copy of Animate CC 2017 to the latest using Creative Cloud desktop application. In case if you don't seen an update in Creative cloud app then please click on the gear icon and choose Check for App Updates. Once updated, the build number should display 16.0.1.119 in the About screen.

You can learn more about Animate CC 2017 release at https://helpx.adobe.com/animate/using/whats-new.html

Thanks!

Mohan

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 14, 2016 Dec 14, 2016

Copy link to clipboard

Copied

LATEST

Thank you!   Confirmed as working

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines